-   Linux - Laptop and Netbook (
-   -   XFCE fails to initialize and logs me out (

frznchckn 01-25-2009 09:40 PM

XFCE fails to initialize and logs me out
I'm running Eeebuntu 2.0 on an ASUS EEE 1000. I am trying to switch from gnome to XFCE4.

When I log in after selecting XFCE4, I get an error message saying:

your session only lasted less than 10 seconds

or something to that affect and it directs me to check


The dump of that file is below. Any ideas?
[~][2]$ cat .xsession-errors
/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
x-session-manager[17828]: WARNING: Could not parse desktop file /etc/xdg/autostart/eeepc-statusicon.desktop: Permission denied
x-session-manager[17828]: WARNING: could not read /etc/xdg/autostart/eeepc-statusicon.desktop
x-session-manager[17828]: WARNING: Unable to find provider 'gnome-wm' of required component 'windowmanager'
Window manager warning: Failed to read saved session file /home/<username>/.config/metacity/sessions/ Failed to open file '/home/<username>/.config/metacity/sessions/': No such file or directory
seahorse nautilus module initialized
Initializing nautilus-share extension
Unable to open desktop file evolution-mail.desktop for panel launcher
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

x-session-manager[17828]: WARNING: Application 'libcanberra-login-sound.desktop' failed to register before timeout
Failure: Module initalization failed
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x300000a (Terminal)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

cheftec 01-29-2009 03:57 PM

Well, you could try to update your 'libcanberra-login-sound.desktop'.
Try apt-get install libcanberra

see what happens then, you may have to rmmod something. Post your xdm.log. Should be in /var/log/.

frznchckn 02-02-2009 08:38 PM

installed libcanberra

xfce still failed almost immediately after logging in

xdm.log is not in /var/log/

cheftec 02-03-2009 04:33 PM

Ok, so your gnome still runs, right? so its probably not a xorg.conf issue. Try running xfce4 in gnome, and see what happens. You could try strace xfce4 (or whatever the startup is for xfce, i think its xfce4)and post what it does. If you're willing to try, I think Waaaay back in the day I had to remove gdm to get xfce to work, but that was on debian sarge; I don't rightly know what that'll do to your system.

Also, have you tried loggin in with gnome, quitting x (or, starting with text login entirely), then starting xfce manually at the prompt on tty1? If that works, its more than likely a gdm/xdm/login manager problem.

frznchckn 02-03-2009 07:45 PM

Okay, i did learn that this is based on the debian xfce packages as told by the "about"

This is all the xfce stuff I can run:

[~][12]$ xfce
xfce4-about xfce4-panel xfce4-terminal
xfce4-autostart-editor xfce4-popup-menu xfce4-terminal.wrapper
xfce4-kiosk-query xfce4-popup-windowlist xfce4-tips
xfce4-menueditor xfce4-session xfce-mcs-manager
xfce4-mixer xfce4-session-logout xfce-setting-show

I can start xfce4-terminal, it opens another terminal window.

when I run "xfce4-autostart-editor I get

[~][13]$ xfce4-autostart-editor

(xfce4-autostart-editor:21657): libxfce4util-CRITICAL **: Failed to parse file /etc/xdg/autostart/eeepc-statusicon.desktop, ignoring.

(xfce4-autostart-editor:21657): GLib-CRITICAL **: g_string_chunk_insert: assertion `chunk != NULL' failed

(xfce4-autostart-editor:21657): GLib-CRITICAL **: g_string_chunk_insert: assertion `chunk != NULL' failed
Segmentation fault

When I try to run "xfce4-session" I get the following

xfce4-session: Another session manager is already running

cheftec 02-04-2009 10:14 AM

You may have done this, but if you /haven't/ I think this may be your ticket.

From xfce faq:

Setting up GDM

If you installed Xfce system-wide and you want to use the GNOME Display Manager (gdm) to start your Xfce session, you will have to create a .desktop file to teach gdm how to start the Xfce session. This is a sample desktop file, Xfce.desktop:

[Desktop Entry]
Name=Xfce 4.4 Session
Comment=Use this session to run Xfce 4.4 as your desktop environment

It is usually enough to simply copy the example file to the Session directory used by gdm; this directory is usually located in /etc/dm/Sessions, /etc/X11/gdm/Sessions, /usr/share/xsessions, /usr/X11/share/gnome/xsessions or some other location, refer to the documentation of your system for details. You need to restart gdm after you created the file.

If you have done this, maybe try reinstalling gdm.

frznchckn 02-04-2009 10:38 AM

I'll have to try this when I get back to that computer, but doesn't that defeat the point of using xfce? I'm trying to not use gnome to save on processing power and RAM.

or am I not understanding how this all works?

cheftec 02-04-2009 04:47 PM

Well then, you can remove gdm and install xdm. That's as easy as

sudo apt-get install xdm (unless its already installed, but won't hurt to do)

then set your xdm to be the default login manager:

sudo dpkg-reconfigure xdm

and follow the prompts. Then

sudo apt-get remove gdm

frznchckn 02-06-2009 02:19 PM

Okay, tried xdm, it worked but I was unable to selected a different window manager so it started gnome. So I switched back to gdm.

I'll be trying to get gdm to start xfce next. Just ran out of time before I had to get Xilinx FPGA tools up and running which is turning out to be a chore.

Thanks though, I'll let you know when I break something else soon.

All times are GMT -5. The time now is 01:05 AM.