-   Linux - Laptop and Netbook (
-   -   x120e no sound through headphones, fine through speaker (

wilson47 11-28-2011 11:07 PM

x120e no sound through headphones, fine through speaker
I'm setting up Slackware 13.37 on a Lenovo x120e. I've ran into plenty of problems so far, and my next challenge is the audio. So far I have managed to get it to work through the built-in speakers. But when I plug in headphones, sound just continues to come out of the speakers. I tried adding in different options for alsaconf, but that didn't seem to work. Does anybody have any ideas?

output of lspci -v | grep Audio

Audio device: ATI Technologies Inc Device 1314
I did run alsaconf to get my speakers to work properly. Perhaps there is some driver issue?

wilson47 11-29-2011 03:28 PM

So I think I somehow got it to work. I uninstalled alsa-lib using the slackpkg tool, then I installed alsa-lib and alsa-driver from the alsa website. Without running alsaconf or anything, I rebooted my machine and everything works fine. You even get a nifty little beep!

The sound card alsamixer tells me it is using is: HDA ATI SB with Chip: Conexant CX20582 (Pebble). I also have a modified .asoundrc whose contents can be found in my other thread on setting up x120e with slackware 13.37.

Edit: So the above worked at first. Then after a reboot, the sound went all screwy. I then blacklisted a bunch of drivers and got it to work. I'm sure there is a better way to do this, but here is what I added to /etc/modprobe.b/blacklist.conf

blacklist snd_hwdep
blacklist snd_pcsp
blacklist snd_seq_dummy
blacklist snd_seq_oss
blacklist snd_seq
blacklist snd_seq_device
blacklist snd_pcm_oss
blacklist snd_mixer_oss
blacklist snd_hda_intel
blacklist snd_hda_codec
blacklist snd_timer

aus9 11-29-2011 09:28 PM

can you post the sound specs of the laptop pls

I assume you have a jack for speakers and a separate jack for headphone.

but sometimes they share one of those jacks or stacks with input device like a mic because they may have only 3 jacks.

better still give us an image of running alsamixer after running the command

alsamixer -V all
forgive me if you have solved it ...edit your first to solved if so

aus9 11-29-2011 09:35 PM

oh can you post the lsmod output for your sound module as well if not solved

Malacoda93 08-26-2012 02:31 PM

Seeing that this is listed as solved, but I'm having the same issue, and going and blacklisting a set of seemingly relevant drivers seems somewhat sketchy to me. Anyone have a different approach, or can reassure that wilson47's is okay?

allend 09-01-2012 02:02 AM

Why are you posting this when you reported that the problem was solved here?

Malacoda93 09-01-2012 11:37 AM

That was getting the audio working at all. I rarely use headphones, so I didn't bother to check the headphone jack to see if it was working.

allend 09-01-2012 09:41 PM

OK - Got it. You have speakers but not headphones.
After seeing this page you could try

echo "options snd-hda-intel index=1, model=ideapad" > /etc/modprobe.d/snd-hda-intel.conf

Malacoda93 09-04-2012 08:20 PM

I have a thinkpad, not an ideapad, and had already tried handing it the former. Not only did it not work, it actually caused the entire alsa module to get messed up, so I had no sound at all, although deleting that section of the entry did get it back to its previous status. I tried the latter just for shits and giggles, and as I expected it made no difference, although it didn't cause the issues handing it thinkpad did.

My guess is that handing it thinkpad was for a different soundcard for a previous iteration of the computer.

All times are GMT -5. The time now is 03:53 PM.