-   Linux - Laptop and Netbook (
-   -   wireless on Asus netbook using ubuntu (

HiredGun555 11-19-2010 12:53 AM

wireless on Asus netbook using ubuntu
I hace an Asus netbook running Ubuntu 10.10 with Gnome. After experiencing problems with video (due to lack of resources) I've switched from Gnome to blackbox as a lightweight desktop. The problem is my wireles is fine under Gnome, but I can't configure it under blackbox, or fluxbox, or fxwm. The following is my lsmod, lspci. Also iwconfig under Gnome and iwconfig under blackbox.


Module Size Used by
binfmt_misc 6587 1
vboxnetadp 6390 0
vboxnetflt 12740 0
vboxdrv 168753 2 vboxnetadp,vboxnetflt
dm_crypt 11331 0
snd_hda_codec_realtek 203375 1
joydev 8708 0
snd_hda_intel 22037 4
arc4 1153 2
snd_hda_codec 74201 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 5412 1 snd_hda_codec
snd_pcm_oss 35308 0
snd_mixer_oss 13746 1 snd_pcm_oss
snd_pcm 70694 4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 1338 0
snd_seq_oss 26722 0
snd_seq_midi 4557 0
snd_rawmidi 19056 1 snd_seq_midi
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
snd_seq 47263 7 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 19098 2 snd_pcm,snd_seq
snd_seq_device 5700 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
ath5k 121664 0
uvcvideo 57054 0
mac80211 205402 1 ath5k
snd 54180 20 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_se q_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
ath 7611 1 ath5k
videodev 34361 1 uvcvideo
v4l1_compat 13251 2 uvcvideo,videodev
cfg80211 126528 3 ath5k,mac80211,ath
soundcore 6620 1 snd
psmouse 63245 0
serio_raw 3978 0
atl1c 28083 0
led_class 2864 1 ath5k
snd_page_alloc 7076 2 snd_hda_intel,snd_pcm
fbcon 35102 72
tileblit 2031 1 fbcon
font 7557 1 fbcon
bitblit 4707 1 fbcon
softcursor 1189 1 bitblit
lp 7060 0
parport 32635 1 lp
i915 286079 2
drm_kms_helper 29297 1 i915
drm 162409 3 i915,drm_kms_helper
intel_agp 24119 2 i915
ahci 32200 2
agpgart 31724 2 drm,intel_agp
i2c_algo_bit 5028 1 i915
video 17375 1 i915
output 1871 1 video


01:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Atheros Communications Atheros AR8132 / L1c Gigabit Ethernet Adapter (rev c0)

The essid displays hex values under blackbox but shows correct essid under Gnome and the access point disappears under blackbox but is there under Gnome. Any help will be appreciated. I can't show the hex values because the posting gets messed up.

prayag_pjs 11-19-2010 12:59 AM

Manually configure your connections:

Use this link:

HiredGun555 11-19-2010 01:51 AM

I've already tried the info on that link, and was still not able to configure correctly.

markush 11-19-2010 02:27 AM

Hi, maybe you're using networkmanager with gnome. The difference between gnome and the other WMs is that gnome starts this program automatically and in Blackbox you'll have to integrate it into the menu manually or autostart it.
Afaik networkmanager provides wireless network only if a user is logged in. So when leaving gnome, the wireless network is shut down.
A workaround would be to configure your wireless connection in a way that is independend of the WM at all.


HiredGun555 11-19-2010 02:56 AM

I'm willing to try this, but don't have a clue as to where to look for info as to how. Any suggestions?

prayag_pjs 11-19-2010 05:45 AM

Can you try wicd instead of NetworkManager

HiredGun555 11-19-2010 10:40 PM

Ok, the wicd has had the most success, but still doesn't work. I'm now able to see the correct essid under blackbox and fluxbox, but when i try to actually connect, the essid suddenly becomes a string of hex characters as before. The partial success is that the gui portion does work, it does see the correct essid, and I see the correct channel. Blackbox and fluxbox, though, reinterprets the essid upon trying to connect and then fails.

markush 11-20-2010 12:53 AM


Originally Posted by HiredGun555 (Post 4165009)
... but when i try to actually connect, the essid suddenly becomes a string of hex characters as before...

well, could you please post a screenshot of this? I think I've never seen that before.


HiredGun555 11-21-2010 03:15 PM

2 Attachment(s)
Here is two screenshots. Sorry it took so long, but I lost my connection all together, even under gnome.

As you can see in the first screenshot, the essid along the bottom of the gui is nothing but garbage. In the second screenshot is a picture of my iwconfig, which also shows garbage for essid, even though iwlist shows the correct one. I tried iwconfig wlan0 ap [address] and the access point would not set.

markush 11-21-2010 04:25 PM

Well, which encryption do you use?

HiredGun555 11-21-2010 04:28 PM

sorry, meant to say it's open, no wep or wpa, and i'm using IPv4, IPv6 doesn't work.

markush 11-21-2010 04:36 PM

ok, then try the following (provided you have wpa_supplicant and dhcpcd installed). create wpa_supplicant.conf file (normaly located in /etc)

ctrl_interface=/var/run/wpa_supplicant GROUP=0
# Wildcard match for SSID (plaintext APs only). This example select any
# open AP regardless of its SSID.

save it as wpa_supplicant.conf in /etc and execute the following command (as root):

wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
if it connects you may execute

dhcpcd wlan0
to get an IP-configuration via DHCP.
Be aware that this is true if the wireless interface is wlan0 and the driver is wext, you may insert your essid into the wpa_supplicant.conf, look at the manpage.


HiredGun555 11-21-2010 05:44 PM

1 Attachment(s)
i attached another screenshot to show whats happening when i try to execute. under gnome, the driver shows ath5k, but under blackbox it says the ath5k driver doesn't exist and doesn't execute at all. when i used wext, it did execute but still did not resolve the connection. it looks like it connects, then loses the connection.

markush 11-21-2010 05:58 PM

mh, I think I can't help you any further, I have similar issue with Gentoo on a Netbook. But I've not yet found a solution. Anyway good luck, I hope you'll find a solution.


All times are GMT -5. The time now is 02:56 PM.