LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 03-18-2008, 07:05 PM   #16
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416

Have you copied & pasted here, or just done misspellings?:
Quote:
Output of cat /etc/network/interfaces:

auto lo
iface lo inet loopback
address 127.0.0.1 <- is needed here

#auto eth0 <-Why the "comment sign ("#") here?
iface etho0 inet dhcp <- It should be eth0 not etho0 Can't you spot the difference yourself?

auto eth1
iface eth1 inet dhcp
wpa-passphrase [mypassword]
wpa-ssid [myssid]
wireless-channel 11
 
Old 03-19-2008, 07:30 PM   #17
koelemay
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Rep: Reputation: 0
Hi tredegar,

Thanks again for the response.

I added "address 127.0.0.1", and also changed "etho0" to "eth0"--that was pure oversight on my part.

I had the "#" in front of "auto eth0" because I copied your suggestion from an earlier posted (11-11-07, 04:35 AM) and it existed there. I tried taking that out as well.

After those changes, the file is now as follows:

Code:
auto lo
iface lo inet loopback
address 127.0.0.1

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-passphrase [mypassword]
wpa-ssid [myssid]
wireless-channel 11
This hasn't fixed the issue when it boots up--it still has the "eth1:avah" in the output of ifconfig, and does not have internet access until "ifdown eth1" and "ifup eth1".

Once again thank you for your help, it is greatly appreciated.
 
Old 03-20-2008, 01:09 PM   #18
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
This hasn't fixed the issue when it boots up--it still has the "eth1:avah" in the output of ifconfig, and does not have internet access until "ifdown eth1" and "ifup eth1"
I don't know why this is happening.
What sort of modem / router do you have?
Please post the output of ifconfig twice: Once just after you have booted, and again, after you have done "ifdown eth1" and "ifup eth1".
Also, the first 4 lines of the interfaces file should read like this:
Code:
auto lo
iface lo inet loopback
address  127.0.0.1
netmask  255.0.0.0
And please post your interfaces file one more time, after you have added that line.
 
Old 03-23-2008, 04:14 PM   #19
koelemay
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Rep: Reputation: 0
Thank you for your reply again, here is the info you requested:

Interfaces file:

Code:
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

#auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-passphrase mypassword
wpa-ssid myssid
wireless-channel 11
ifconfig right after booting up:

Code:
eth0      Link encap:Ethernet  HWaddr 00:0D:9D:45:AB:A2  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:10 Base address:0x2000 

eth1      Link encap:Ethernet  HWaddr 00:18:6E:35:FD:51  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:101 dropped:0 overruns:0 frame:101
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:462 (462.0 b)

eth1:avah Link encap:Ethernet  HWaddr 00:18:6E:35:FD:51  
          inet addr:169.254.7.29  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:530 (530.0 b)  TX bytes:530 (530.0 b)
ifconfig after "ifdown eth1" and "ifup eth1":

Code:
eth0      Link encap:Ethernet  HWaddr 00:0D:9D:45:AB:A2  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:10 Base address:0x2000 

eth1      Link encap:Ethernet  HWaddr 00:18:6E:35:FD:51  
          inet addr:192.168.2.7  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::218:6eff:fe35:fd51/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12 errors:110 dropped:3 overruns:0 frame:110
          TX packets:69 errors:1 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2221 (2.1 KB)  TX bytes:5469 (5.3 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:66 errors:0 dropped:0 overruns:0 frame:0
          TX packets:66 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:6096 (5.9 KB)  TX bytes:6096 (5.9 KB)
 
Old 03-24-2008, 06:44 AM   #20
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
I have no idea why this is happening.
The simplest solution might just be to restart eth1 at boot by putting these lines lines at the end of the file /etc/rc.local
Code:
# eth1 needs a restart to get a valid IP
ifdown eth1
ifup eth1
At the next boot, you should be properly connected.
 
Old 03-25-2008, 10:35 PM   #21
NongA_TongE
LQ Newbie
 
Registered: Mar 2008
Posts: 2

Rep: Reputation: 0
I'm a total linux newb running Ubuntu Gutsy and using a Netgear MA40 PCMCIA wireless card.
So I originally came across this thread when I couldn't get a connection at all. Since then, I've gotten connected. (WOO-HOO) Turns out it was all due to an ID-10-T error (was typing in my key instead of my passphrase). Nonetheless, I found this very helpful in learning some of the terminal commands I'll need.
Even though I'm connected, I'm a little concerned about my iwlist scanning results, and my ifconfig.


## tried to paste the results below, but it wouldn't let me, saying:
1. You have included 11 images in your message. You are limited to using 10 images so please go back and correct the problem and then continue again.

Images include use of smilies, the vB code img tag and HTML img tags. The use of these is all subject to them being enabled by the administrator.##


Thanks for any assistance.
I'm just trying to figure out if there is anything grossly out of place.

Cheers!
 
Old 03-26-2008, 06:59 AM   #22
koelemay
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Rep: Reputation: 0
Quote:
Originally Posted by NongA_TongE View Post
## tried to paste the results below, but it wouldn't let me, saying:
1. You have included 11 images in your message. You are limited to using 10 images so please go back and correct the problem and then continue again.

Images include use of smilies, the vB code img tag and HTML img tags. The use of these is all subject to them being enabled by the administrator.##
Before submitting your reply, look under the "submit reply" button at the additional options and check the box next to "disable smiles in text"
 
Old 03-26-2008, 11:18 AM   #23
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
@ NongA_TongE:
Quote:
check the box next to "disable smiles in text"
And even better is to click the "Go Advanced" mode and put
Code tags around your output.
But as it is a new problem, please start a new thread (With a sensible title, of course )
@ koelemay: Are you connecting reliably now?
 
Old 03-30-2008, 02:11 PM   #24
koelemay
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Rep: Reputation: 0
Quote:
Originally Posted by tredegar View Post
I have no idea why this is happening.
The simplest solution might just be to restart eth1 at boot by putting these lines lines at the end of the file /etc/rc.local
Code:
# eth1 needs a restart to get a valid IP
ifdown eth1
ifup eth1
At the next boot, you should be properly connected.
Tredegar, I tried this however it did not appear to work. I created a "launcher" on my desktop that runs "sudo ifdown eth1" and then "ifup eth1" when I double click on it, which is an OK solution. If you have any other ideas, I would be glad to hear them, but your help up to now has been more than excellent! Thanks again.
 
Old 03-30-2008, 03:34 PM   #25
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
If you have any other ideas.. .
I don't have any other ideas, apart from sitting in front of your PC and "sorting it out", but I don't have the time, sorry.
We could spend days discussing the finer points of your distro & how it handles wireless, but you have managed to get it working for you. Well done!
The chances are that you'll switch distros sooner or later, and you'll find things either work (likely), or they don't. If the latter, then you have at least learnt something about how linux networking works, and will probably be able to fix it yourself. Meanwhile, you are connected at last. Good!
 
Old 04-08-2008, 02:02 AM   #26
IronOgre
LQ Newbie
 
Registered: Apr 2008
Posts: 2

Rep: Reputation: 0
This thread is having such wonderful success I'd like to throw my own pleas for help into the mix.

I've been experimenting but won't list what I've done until someone asks what I've broken (mostly been playing with wpa_supplicant).

My wireless doesn't seem to be working despite the fact that I often have status bars on my GUI telling me how strong the connection is. I've posted the errors resulting from ifup and ifdown at the end of my outputs.

I have a sneaking suspicion that I'm not even dealing with WPA. My roommate (even less technically savvy than myself) gave me what AT&T provided him: a Network Name (SSID) and a WEP (Encryption Key) number. This was all that it took to get a Windows wireless connection running. But I threw my encryption key in there for wpa_passphrase anyways and now patiently await wise advice.

Output for sudo iwlist scanning

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:1E:C7F:2E:C9
ESSID:"2WIRE264"
Mode:Master
Frequency:2.422 GHz (Channel 3)
Signal level:-49 dBm Noise level:-79 dBm
Encryption keyn
Cell 02 - Address: 00:1CF:0E:CD:A4
ESSID:"Sparerib"
Mode:Master
Frequency:2.412 GHz (Channel 1)
Signal level:-72 dBm Noise level:-85 dBm
Encryption keyn
Cell 03 - Address: 00:18:3F:27:69:21
ESSID:"2WIRE655"
Mode:Master
Frequency:2.437 GHz (Channel 6)
Signal level:-77 dBm Noise level:-87 dBm
Encryption keyn
Cell 04 - Address: 00:17:9A:4A:66:1F
ESSID:"ShadyJr"
Mode:Master
Frequency:2.412 GHz (Channel 1)
Signal level:-75 dBm Noise level:-85 dBm
Encryption keyn
Cell 05 - Address: 00:18:3F:AF:A9:F9
ESSID:"2WIRE113"
Mode:Master
Frequency:2.437 GHz (Channel 6)
Signal level:-81 dBm Noise level:-87 dBm
Encryption keyn


Output for cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth1
iface eth1 inet dhcp
wpa-passphrase 5125722068
wpa-ssid "2WIRE264"
wireless-channel 3

Output for ifconfig

eth0 Link encap:Ethernet HWaddr 00:A010:3D:3A
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth1 Link encap:Ethernet HWaddr 00:02:2D:36:6E:CE
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:19507 (19.0 KB)
Interrupt:11 Base address:0x100

eth1:avah Link encap:Ethernet HWaddr 00:02:2D:36:6E:CE
inet addr:169.254.6.189 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
Interrupt:11 Base address:0x100

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:254 errors:0 dropped:0 overruns:0 frame:0
TX packets:254 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:24927 (24.3 KB) TX bytes:24927 (24.3 KB)

Output for sudo ifdown eth0

ifdown: interface eth0 not configured

Output for sudo ifdown eth1

There is already a pid file /var/run/dhclient.eth1.pid with pid 21677
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit (website removed so I can successfully post for first time)/

Listening on LPF/eth1/00:02:2d:36:6e:ce
Sending on LPF/eth1/00:02:2d:36:6e:ce
Sending on Socket/fallback
DHCPRELEASE on eth1 to 192.168.1.254 port 67

Output for sudo ifup eth1

Error for wireless request "Set Frequency" (8B04) :
SET failed on device eth1 ; Device or resource busy.
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Invalid argument
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - There is already a pid file /var/run/dhclient.eth1.pid with pid 134519120
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit (website removed so I can successfully post for first time)/

Listening on LPF/eth1/00:02:2d:36:6e:ce
Sending on LPF/eth1/00:02:2d:36:6e:ce
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 16
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
 
Old 04-08-2008, 07:52 AM   #27
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
You are using WEP, not WPA, so try this in your interfaces file:

Code:
auto eth1
iface eth1 inet dhcp
wireless-essid 2WIRE264
wireless-key 5125722068
wireless-channel 3
 
Old 04-08-2008, 08:34 PM   #28
IronOgre
LQ Newbie
 
Registered: Apr 2008
Posts: 2

Rep: Reputation: 0
That's what it took alrighty. Many thanks.

I also removed Network Manager which seems intent on sabotaging things. That also seems to have stopped the eth1:avah network connection from popping up (someone else on this thread was having that pop up). I replaced it (still addicted to GUI) with Wicd which has been very cooperative.
 
Old 05-29-2008, 08:07 AM   #29
leoleta
LQ Newbie
 
Registered: Mar 2006
Location: kingston Oklahoma
Distribution: ubuntu 8.04 64bit
Posts: 5

Rep: Reputation: 0
wifi not work on dell 1501 with Hardy 8.04 64bit

Hi tredegar Iam new to linux and hope that not a problem. I have tried several tutorial, no luck, I reinstall Hardy to get it back start and tried some more, no luck.
I am using a Dell 1501 with Hardy Heron I have done the commands you ask for this is the result.

sudo iwlist scanning
[sudo] password for leoleta:
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

cat /etc/network/interfaces
auto lo
iface lo inet loopback


iface wlan0 inet dhcp
wireless-key s:5807373679
wireless-essid netgear

auto wlan0
leoleta@leoleta-laptop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:19:b9:7c:b0:74
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::219:b9ff:fe7c:b074/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2202 errors:0 dropped:0 overruns:0 frame:0
TX packets:2207 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1153542 (1.1 MB) TX bytes:286072 (279.3 KB)
Interrupt:21

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:240 errors:0 dropped:0 overruns:0 frame:0
TX packets:240 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12000 (11.7 KB) TX bytes:12000 (11.7 KB)

leoleta@leoleta-laptop:~$ lo Interface doesn't support scanning.
>
> eth0 Interface doesn't support scanning.
bash: lo: command not found
leoleta@leoleta-laptop:~$
leoleta@leoleta-laptop:~$ wmaster0 Interface doesn't support scanning.
>
> wlan0 Interface doesn't support scanning : Network is down
bash: wmaster0: command not found
leoleta@leoleta-laptop:~$

Last edited by leoleta; 05-29-2008 at 08:59 PM. Reason: personal info.
 
Old 05-29-2008, 11:10 AM   #30
chewinette
LQ Newbie
 
Registered: May 2008
Posts: 2

Rep: Reputation: 0
same problem here

I installed ubuntu a few weeks ago and my wireless doesn't work since then...

My computer is a toshiba satellite, and there is a list of wireless networks, but even with a valid password it cannot seem to work.
I may have a problem with the restricted driver, atheros hardware access lawyer is enabled but still " not in use"

what is wrong?
so now I plugged the wired internet of my work so I can get an answer, please help me!!

I tried the
sudo iwilist scanning
cat/etc/network/interfaces
ifconfig

and I got this:
tiphaine@tiphainerosa:~$ sudo iwilist scanning
[sudo] password for tiphaine:
Sorry, try again.
[sudo] password for tiphaine:
Sorry, try again.
[sudo] password for tiphaine:
sudo: 2 incorrect password attempts
tiphaine@tiphainerosa:~$ cat/etc/network/interfaces
bash: cat/etc/network/interfaces: No such file or directory
tiphaine@tiphainerosa:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:A01:7F:78:C7
inet addr:192.168.1.136 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::2a0:d1ff:fe7f:78c7/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9382 errors:0 dropped:0 overruns:0 frame:0
TX packets:6763 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:11659947 (11.1 MB) TX bytes:757108 (739.3 KB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0 Link encap:Ethernet HWaddr 00:1B:9E:48:980
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:6768 (6.6 KB)
Interrupt:16 Memory:f0700000-f0710000
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Upgrade Ubuntu 7.04 (Feisty Fawn) to Ubuntu 7.10 (Gutsy Gibbon) LXer Syndicated Linux News 1 03-28-2009 01:17 PM
LXer: The Perfect Server - Ubuntu Gutsy Gibbon (Ubuntu 7.10) LXer Syndicated Linux News 0 10-21-2007 11:20 AM
LXer: Ubuntu Gutsy Wireless Help LXer Syndicated Linux News 0 10-19-2007 08:10 AM
sleep and hibernate not working on ThinkPad T60 with Ubuntu 7.10 (Gutsy Gibbon) CharlieBucket Linux - Laptop and Netbook 4 10-10-2007 08:18 AM
LXer: Ubuntu 7.10 (Gutsy Gibbon) Release Dates and Mark Shuttleworth About Gutsy LXer Syndicated Linux News 0 04-12-2007 04:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 12:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration