LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 03-19-2019, 03:24 PM   #1
HPBaxxter
LQ Newbie
 
Registered: Jun 2012
Posts: 8

Rep: Reputation: Disabled
Question Windows 10 can't install updates (dual boot with Kali)


deleted

Last edited by HPBaxxter; 03-29-2019 at 08:25 AM.
 
Old 03-19-2019, 04:24 PM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,468

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
What are you using to boot? Is this an EFI or Legacy system? WHen you reboot, you need to make sure it is rebooting to windows from your boot menu.

Quote:
but it show me that Windows can't install them,
That's a pretty vague statement. What happens exactly? Do you get some warning/error message? If so, it would help to post it.

Windows 10 does take a long time to start unless you have their fastboot/hibernation on.

Why can't you set the default? Again, how are you booting? If you are using the Linux Grub bootloader that's a pretty simple problem to solve.
 
Old 03-19-2019, 08:00 PM   #3
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 971

Rep: Reputation: 259Reputation: 259Reputation: 259
This has nothing to do with Linux, it's a Windows issue.
Google these key words: We couldn't complete the updates, Undoing changes
EDIT: I recently ran into this issue and have not resolved it yet mostly because I don't care if it can't install extra spyware or whatever. Windows is running fine without it.
For me it was these updates:
windows10.0-kb4489899
windows10.0-kb4486553

I did download and install the second one with standalone installer, but first one won't take, boo-hoo!

Last edited by Brains; 03-19-2019 at 08:04 PM.
 
Old 03-20-2019, 05:54 AM   #4
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 10,001

Rep: Reputation: 1095Reputation: 1095Reputation: 1095Reputation: 1095Reputation: 1095Reputation: 1095Reputation: 1095Reputation: 1095
If you haven't got a boot menu in grub, reconfigure grub and take out the 'hidden' option. I forget how to do it, but google it.

I relegated windows 10 to a vm. It runs off an ext4 disk, but in a disk file which it has formatted. Due to it's obnoxious reporting habits, it doesn't even have my name. It comes up greeting me: "Hello, Tight Ass!"

Do you really need that stuff for your job or something? The standard solution would be to reinstall windows over windows. . .
 
Old 03-22-2019, 03:25 PM   #5
HPBaxxter
LQ Newbie
 
Registered: Jun 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
What are you using to boot? Is this an EFI or Legacy system? WHen you reboot, you need to make sure it is rebooting to windows from your boot menu.



That's a pretty vague statement. What happens exactly? Do you get some warning/error message? If so, it would help to post it.

Windows 10 does take a long time to start unless you have their fastboot/hibernation on.

Why can't you set the default? Again, how are you booting? If you are using the Linux Grub bootloader that's a pretty simple problem to solve.
Its legacy bios system, when I turn off the pc and after choosing Windows 10 it appear as in the photo, then the pc restart and I have to choose windows 10 again !
https://i.postimg.cc/bYG82bp1/DSC-0072.jpg

Last edited by HPBaxxter; 03-22-2019 at 04:45 PM.
 
Old 03-22-2019, 04:29 PM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,335

Rep: Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744
what is that image telling you?

it is still updating, do NOT TURN OFF, set up your grub to keep going to windows to boot it until it is done updating, then go take a nap or go shopping, or something ...
Code:
GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
update-grub
so it will automatically boot windows again and again until it is finished updating.

Last edited by BW-userx; 03-22-2019 at 04:33 PM.
 
Old 03-22-2019, 04:47 PM   #7
HPBaxxter
LQ Newbie
 
Registered: Jun 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
what is that image telling you?

it is still updating, do NOT TURN OFF, set up your grub to keep going to windows to boot it until it is done updating, then go take a nap or go shopping, or something ...
Code:
GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
update-grub
so it will automatically boot windows again and again until it is finished updating.
I did mistake lol, this is the right photo
https://i.postimg.cc/bYG82bp1/DSC-0072.jpg
 
Old 03-22-2019, 05:51 PM   #8
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,335

Rep: Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744
don't sweat that either, is windows still working. so .. let it work. it should pick up the update on the next time...



I had the same thing happen to me...
 
Old 03-25-2019, 02:54 PM   #9
HPBaxxter
LQ Newbie
 
Registered: Jun 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
don't sweat that either, is windows still working. so .. let it work. it should pick up the update on the next time...



I had the same thing happen to me...
It doing it all the time, the updates didn't install !
 
Old 03-25-2019, 03:19 PM   #10
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,335

Rep: Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744Reputation: 1744
it is strictly a windows thing, you'll have to search and log in a post on it if you cannot find anything on a windows related forum.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] In a dual boot (windows 10 and kali (Debian)) but win10 doesn't show in the boot screen LilDeadGirl Linux - Software 5 03-02-2019 08:21 PM
[SOLVED] dual boot windows and kali but kali is main distro josephschmoe Linux - Newbie 1 01-21-2019 12:07 AM
Triple-boot Kali 2.0/LXLE 14.04.2/Win7 - USB 3.0 file transfer issues in Kali MX372 Linux - Hardware 4 10-10-2015 07:06 PM
Failed to fetch http://http.kali.org/kali/dists/kali/Release.gpg aymeric75 Linux - General 2 07-11-2015 05:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 09:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration