-   Linux - Laptop and Netbook (
-   -   Wifi OK on USB, but not when installed (

ramoseley 11-18-2012 03:06 PM

Wifi OK on USB, but not when installed
I'm loading Mint 13 on an Acer Aspire. Wifi works fine when booting from USB, but after installing the wifi does not work. I assume this means that I've got the correctd driver in the .ISO on the USB (Atheros), so what changes when it's installed on the hard drive?

Using the wifi power switch doesn't seem to have any effect.

Going back to boot Win XP, the wifi works fine there, too. The only difference between wifi under XP and under Linux is that the led is more visible (on more or on longer) under XP.


yancek 11-19-2012 08:45 AM

What have you tried? Are you just trying to use a browser and not connecting? Any error messages? Have you tried connecting to an ip with your browser from a terminal?

Try going to the site below and reviewing the commands to get more detailed information on your wireless hardware and post it here:

The link below gives you more options to get more detailed info:

ramoseley 11-19-2012 09:18 AM

No error messages, as the wifi appears to be powered off. I don't see any SSIDs. There is a hardware power switch on the Aspire, with click-on, click-off action, so I assume it's monitored by software, not an actual on-off switch. The associated LED emits to show activity, not power, so it's difficult to know what state the hardware is in if it's not transponding.

Hardware is the Atheros chipset. The following responses to the lspci command are identical for USB boot and hard drive boot.

01:00.0 Atheros AR242x/AR542X
Kernel Driver ATH5K
Kernel Module ATH5K

thanks for your help,

ramoseley 11-19-2012 11:13 AM

iwconfig wlan0 provides the following:

mode 802.11bg
essid "lakehouse" (this was carried over from the USB install)
mode managed
access point not associated
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

no data on link quality, obviously, or rx/tx function

icarusthecow 11-20-2012 11:43 AM

check out rfkill, it could be that the chip is soft blocked from making connections.

sudo rfkill unblock all
or something similar

also, to get more information, you can try restarting network-manager and monitoring the output of /var/log/syslog for network-manager messages relavant to the problems youre having.

ramoseley 11-21-2012 09:21 AM

I tried your sudo line, with no apparent effect. Then

ifup wlan0

and got the response, after about 2 minutes,

Failed to bring up wlan0

I am assuming that the Atheros chip is powered down, since there is that independent capability in the Acer.


All times are GMT -5. The time now is 04:24 PM.