-   Linux - Laptop and Netbook (
-   -   Video driver on Lenovo X120e, slackware 13.37 (

wilson47 11-27-2011 10:21 PM

Video driver on Lenovo X120e, slackware 13.37
I just got a Lenovo ThinkPad X120e and installed slackware 13.37. I spend a lot of time on the command line, but often switch to Fluxbox to use firefox or adobe reader. I started up xwindows just fine and got Fluxbox, xfce and kde working on separate occasions, but when using X windows, if I switch to a virtual terminal I just get a black screen. The terminals are functional---verified by running commands blind---but just display a black screen. My googling suggests this is a video driver problem, but I do not know the first place to start to fix this problem. Can somebody point me to some documentation, or suggest a way to fix this problem?

camorri 11-28-2011 03:01 PM

Could you post the output of 'lspci | grep VGA'? I looked at Levono's site, it looks like you have this:


AMD Radeon HD 6310 Graphics, AMD Fusion Processor E-240
Have you installed a driver from Radeon? If not, you will be running the default Newveau driver.
It does not support all video functions. I would suggest you install the driver from the manufacturer. This thread -->

walks you through it.

rovitotv 11-28-2011 03:35 PM

How do you like the X120e?
I am considering buying a X120e after you get the ATI driver installed let us know what you think? The other contender for me is the HP DM1Z which is basically the same hardware but by HP. Several links on the web seem to indicate these systems should work great with Linux. I was also considering ThinkPad X220 but it is more money than the X120e. Ironically I was going to install Slackware too.

TobiSGD 11-28-2011 04:14 PM


Originally Posted by camorri (Post 4536663)
Have you installed a driver from Radeon? If not, you will be running the default Newveau driver.

What? I think you are confusing some things here. At first, the videochips manufacturer (the chip is in fact inbuilt in the CPU) is AMD. While it is a Radeon chip the name of the proprietary driver module is fglrx, opposite to the open source radeon-driver, which supports that chip only in newer version, IIRC. The nouveau driver (I think you meant that with Newveau) is for NVidia cards and has nothing to do with that laptop.

wilson47 11-28-2011 08:11 PM

Hey! Thanks all for the replies. Here is the output:

00:01.0 VGA compatible controller: ATI Technologies Inc Device 9802 (prog-if 00 [VGA controller])
I managed to figure out how to get the graphics card (sort of) working. I did wind up installing the proprietary driver found here:
Do not follow the instructions you might read elsewhere about how to install it! Just be naive and run:

and follow all the suggestions. Do not try to install a distribution specific version (it will ask you) if you are installing Slackware 13.37. The last time I checked, I couldn't get xfce4 working with this driver, but fluxbox and kde seem to work just fine and support switching between virtual terminals and xwindows now. For what I do with the graphics---not much---, everything works without problems.

If you are thinking about getting the x120e, you have to be prepared for video driver problems, wireless driver problems, and adjusting the mouse to work if you like the scroll functionality. See the arch linux wiki for more info on issues with x120e.

I suppose the install would all go quite quickly if you know how to fix these bugs. It's been a headache for me. Now that it is in working condition, though, I do really like the laptop. If you want, I can post all the things I needed to do to get Slackware 13.37 working!

rovitotv 11-28-2011 08:21 PM

If you have time I would really enjoy a post about the steps you took to get the computer working. For sure I would read the post. Thanks.

wilson47 11-28-2011 09:22 PM

1 Attachment(s)
OK. So here is the list of things I needed to do to get Slackware 13.37 working on my Lenovo X120e.

1. You need to make a usbboot disk since there is no CD drive. You can accomplish this by downloading the files at a mirror like this. To make the usb drive, supposing you are already on a linux machine, you can transfer the image to the usb drive /dev/sd? by

dd if=usbboot.img of=/dev/sd?
In my case, my usb drive was located at /dev/sdb, so you have to replace that question mark with something.

1.a. If you want to dual boot Windows 7 and slackware, you need to use something like gdisk somehow to resize your partitions. I did this using an Ubuntu usb installer.

2. Boot up the slackware usb drive installer. I used the ftp/http installation route since I didn't feel like figuring out where to put the sources, and I have a fast internet connection. This installation went fine without any problems. Make a USB boot loader though!!!

3. I needed to install Lilo to the MBR, unlike what is suggested in the install. I think this was because with dual booting, I needed to have linux installed on an extended partition and my computer didn't like to boot that for some reason. The default Lilo settings to detect my linux and windows OSs worked great though, so no worries. It was just a mess trying to figure this out having to boot from the slackware usb installer every time!

4. This should get you to a slackware command line! Once you are here, you can also even get kde or fluxbox or xfce working. You just won't be able to switch back to a virtual terminal. So to fix this you need to install the proprietary ati driver.

5. The driver is located here. Neither of the open source drivers seemed to work. The installation was surprisingly simple. When you download the driver, you get a file:
To install, just run

and follow the on-screen instructions. DO NOT install the distribution specific version. If memory serves me correct, this was buggy.

You will then need to run something like

aticonfig --initial
to generate an xorg.conf file. My current xorg.conf is attached to this post.

This should hopefully have your video/graphics up and running.

5'. IN A PINCH:, the vesa framebuffer xorg.conf will work just fine, but it has poor resolution.

To get Xwindows just to work with framebuffer, you need to be root, go to /etc/X11 and then

mv xorg.conf-vesa xorg.conf
Then running

should get you started.

6. My audio wasn't working right away. I needed to run

and follow the on-screen installation. This worked just fine. You then need to make a new .asoundrc file in your home directory to get alsamixer to work right. Create a file .asoundrc in /home/USER with:

type hw
card 1
ctl.!default {
type hw         
card 1

7. You will also need to install the proper wiereless driver. You can find it here.
I recall this installation going through without any trouble, in a straightforward manner.

8. I think these were all my headaches. Make sure to do a (nearly) full installation of slackware. This saves you a lot of trouble hunting down libraries and kernel sources if something goes wrong. I didn't install the Tex distro since I like TexLive better, but I did install everything else!

9. I hope these are all the problems you run in to. Best of luck!

10. Well, I thought the audio was working. I had to blacklist some drivers to get the audio to work correctly. I didn't have sound coming out of my headphones...

rovitotv 12-04-2011 02:08 AM

Thanks for the detailed how do you like your computer now that you have everything running. I am curious about the graphics are those fast enough? I don't do much gaming but I do play videos occasionally.

wilson47 12-07-2011 10:55 PM

The graphics are a bit slow, and it is a wee bit frustrating. Luckily, I don't do much full screen video or anything. I'd say if video is a big concern, look elsewhere. I'm pretty content with my vt100 :)

Also, I've noticed that the wireless card support isn't fantastic. It seems to forget the essid settings randomly sometimes. That has been getting annoying... I might ask about that soon.

By and large, this does just fine for me for now. I might try Ubuntu or some better supported distro to see if I can't get better support.

All times are GMT -5. The time now is 04:56 PM.