LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 05-11-2009, 11:30 PM   #16
ilcontegis
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 0

I installed the last versione of the alsa drivers 1.0.20
Nothing changed.
 
Old 07-09-2009, 03:29 AM   #17
ilcontegis
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 0
any news?
 
Old 07-16-2009, 06:53 PM   #18
rockor
LQ Newbie
 
Registered: Jul 2009
Posts: 15

Rep: Reputation: 0
Wink me having same problem

hey i have also got sony and me too same problem on fedora 10...
just keep this thread going.. it's going good and maybe we may find some solution....

till then news is that i somewhere found that problem maybe due to bios settings.
 
Old 07-16-2009, 06:54 PM   #19
rockor
LQ Newbie
 
Registered: Jul 2009
Posts: 15

Rep: Reputation: 0
link to bios settings clue here.
 
Old 09-08-2009, 11:07 PM   #20
ilcontegis
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rockor View Post
link to bios settings clue here.
what should I do? I did not catch what should be done....still the mic does not work...
 
Old 09-11-2009, 10:21 PM   #21
rockor
LQ Newbie
 
Registered: Jul 2009
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by ilcontegis View Post
what should I do? I did not catch what should be done....still the mic does not work...
well i also still have no clue.... infact i have found this problem with many distros and with many laptops.... it's like some driver is missing which is very much required... codegurus should pay attention....

meanwhile u can use external mic.... it's working 4 me.....
 
Old 09-16-2009, 09:55 PM   #22
ilcontegis
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 0
I installed the new version of alsa 1.0.21 and the latest kernel 2.6.31, still no improvements.
 
Old 10-06-2009, 08:59 PM   #23
ilcontegis
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 0
I installed the latest ubuntu 9.10 beta. now on my laptop everything is working, EXCEPT THE INTERNAL MIC! this is a curse!
I do not know anymore what to do!
 
Old 12-07-2009, 07:41 PM   #24
ilcontegis
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 0
updated to the new kernel 2.6.32, the mic is still not working.
I started losing my hope...
 
Old 12-07-2009, 09:39 PM   #25
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
Do you even have a setting in alsaconf for the internal mic. I know that the external port and the internal one are shown differently in there and you may wanna check that they are not muted.
 
Old 12-07-2009, 11:04 PM   #26
ilcontegis
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by exvor View Post
Do you even have a setting in alsaconf for the internal mic. I know that the external port and the internal one are shown differently in there and you may wanna check that they are not muted.
Man thank you,
But that's not my problem only. The vaio tt has this issue....
On the ubuntu international forum we made a post on this, we all have the same problem..unfortunately.
Yes I have both mic (internal and external) and obviously they are not muted
 
Old 12-08-2009, 01:22 PM   #27
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292Reputation: 1292
You said it worked with one version of Ubuntu, did you save any info on the modules that were inserted, and what the ALSA config was, and other possibly useful info ? That might help you get it working on a newer version of Ubuntu.
 
Old 12-08-2009, 06:52 PM   #28
ilcontegis
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by H_TeXMeX_H View Post
You said it worked with one version of Ubuntu, did you save any info on the modules that were inserted, and what the ALSA config was, and other possibly useful info ? That might help you get it working on a newer version of Ubuntu.
Nope it never worked with any version of ubuntu, archlinux and debian.
I tried now to compile the newer alsa drivers, but nothing again.

Last edited by ilcontegis; 12-08-2009 at 08:12 PM.
 
Old 12-08-2009, 07:11 PM   #29
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
Try these options
options snd-hda-intel enable_msi=1 model=dell-m4-1

if that doesn't work try not specifying any options. I got mine working without having to put any options to the driver in there. Then again I have never tried using the internal mic.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
microphone does not work with Realtek ALC883 HDA fakie_flip Linux - Hardware 47 03-26-2012 07:25 PM
No sound with hda-intel card on Sony Vaio laptop using Gentoo xadist Linux - Laptop and Netbook 7 06-01-2007 11:01 AM
HDA Intel/Realtek microphone/line in very quiet format C: Linux - Hardware 1 02-20-2007 01:50 PM
integrated hda audio modem bluetooth , (intel hda audio does not work) reggae linux Linux - Laptop and Netbook 2 07-05-2006 03:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 01:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration