-   Linux - Laptop and Netbook (
-   -   USB key drive mysteriously stopped working (

legalbeagle 09-17-2004 04:32 PM

USB key drive mysteriously stopped working
I am running Mandrake 10 (kernel 2.6.3-7) on an Averatec 3150-P laptop and have been using a Lexar 128 mb JumpDrive for a couple of months. Today, the drive will not respond when I plug it into the usb port (have tried all three ports on the machine). It does not light up or anything. I have tried the drive on another linux machine and on an XP machine and it works fine on both. I am also still able to use my usb printer on the laptop with no problems, but have not tried any other usb storage devices. I have not knowingly made any adjustments to my laptop that would affect the jump drive. Can anyone offer any suggestions as to why my jump drive has mysteriously disappeared? Thanks.

arcadejedi 11-12-2004 12:21 PM


I have recently done extensive research on USB devices (Thumbdrives and Card Readers) for my Averatec 5110Hx. I now have everything working (slack10)... let's see what we can find...

First open your favorite terminal and su. Now run this command:

tail -f /var/log/messages

Now leave that window up, and plug in the device... you should see some activity in the terminal... cut n paste and post it back...


legalbeagle 11-12-2004 01:08 PM

I appreciate your reply, although I have since managed to convince Lexar to replace the device. So far, the new device works perfectly. I guess it was a hardware problem, althouth I remain perplexed about how it continued to work under XP - albeit not very well - but eventually would not work at all under Linux.

By the way, I am quite pleased to find another averatec owner who uses linux. I have yet to get mandrake 10 working satisfactorily on my laptop and am thus forced to use XP b/c I rely so heavily on my laptop for day to day stuff. I would love to correspond with you on some other issues (particularly power management and wireless networking), so I can completely divorce myself from windows on this machine.

Thanks again.

arcadejedi 11-12-2004 01:59 PM

That sounds great, I noticed your email is not pub, you can contact me directly via my email link on the bottom of this post.


All times are GMT -5. The time now is 10:55 PM.