-   Linux - Laptop and Netbook (
-   -   upgraded kernel to now no sound (

jpgillivan 09-05-2004 01:02 AM

upgraded kernel to now no sound
I upgraded the kernel from to and now the sound doesn't work. Even if I boot back into it does not work.

Sound did work before I updated. btw, i compiled from complete source, not patch.

lspci returns
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio Controller (rev 01)

Exactly what options should I have set when configuring the kernel. I used xconfig.
I tried selecting intel for the sound card but no luck. ALSA and OSS are selected.

It appears that there are no mixers installed anymore. ??

When trying to set the sound settings in control center I get :
device /dev/dsp can't be opened (No such file or directory)

I verified that there is indeed no directory with that name but there is

did I do something wrong when configuring the kernel or is there something else that I should install.

OS: Mandrake 10.0
Computer: Dell 600m laptop

I think that everything else is working ok.

spacedoubtman 09-05-2004 07:18 AM

seems strange.

try this command as root:
/dev/MAKEDEV audio

that will make the file /dev/dsp

if your using alsa you might need to add the OSS PCM API and OSS Mixer API options

z35 09-28-2004 09:11 PM

same here
I have the same Problem, I have not changed anything. I just upgraded? I have not done any extensive looking, just a quick search. I did not look at any changes or anything due to the dredful thing called limited time. A quick make oldconfig, make menuconfig, changed PentiumM and added cpu freq scaling stuff (Inspiron 8200). And that was that, cp, blah and etc (I have done this a couple times). I do not know what the problem is. Any advice, help, aid etc, thank you in advance.


christhom 09-29-2004 02:49 AM

I had this problem recently on my 500m. Are you using hotplug and alsa? the problem is most likely that the old sound modules are being loaded first, before the alsa ones and this screws things up. Well, that's what happened with my debian laptop.

Try editing the blacklist in
and add the OSS modules to it. mine contains the following:

#try to get sounds working again
#i810_audio is OSS module and snd_intel8x0m is modem

if this doesn't fix the problem, hopefully it'll put you on the right track...

z35 09-30-2004 12:08 AM

I am using alsa... so I tried adding a a couple of these to the /etc/hotplug/blacklist, then did (each time the <file> was editied
/etc/init.d/hotplug restart ; /etc/init.d/alsasound restart
Alright, lsmod:

Module                  Size  Used by
snd_intel8x0          30472  0
snd_ac97_codec        66692  1 snd_intel8x0
snd_mpu401_uart        6400  1 snd_intel8x0
snd_rawmidi            20644  1 snd_mpu401_uart
snd_seq_oss            31872  0
snd_seq_midi_event      6400  1 snd_seq_oss
snd_seq                50192  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          7048  3 snd_rawmidi,snd_seq_oss,snd_seq
snd_pcm_oss            50216  0
snd_pcm                86920  2 snd_intel8x0,snd_pcm_oss
snd_page_alloc          9352  2 snd_intel8x0,snd_pcm
snd_timer              22020  2 snd_seq,snd_pcm
snd_mixer_oss          18048  1 snd_pcm_oss
snd                    49508  12 snd_intel8x0,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_oss,snd_seq_midi_event,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore              7776  1 snd
nvidia              4815988  10
sg                    30880  0
rtc                    10680  0
3c59x                  36136  0

I will prob try a restart, and if all else fails, I will work on it more this week-end-ish-maybe. But if rebooting does not work, I will just use my previous version: 2.6.6-rc1. Until I find time to get it working...

Krugger 10-01-2004 06:19 PM

/dev/dsp is the device for the OSS which is now deprecated. So we are supposed to stop using it.

But there is some problems with this card with ALSA. I still have to updated to a newer version of the kernel, but

I found out that if you

modprobe snd_intel8x0
rmmod snd_intel8x0
modprobe i810_audio
chmod 777 /dev/dsp
chmod 777 /dev/mixer

gives me sound in a version that didn't give sound because of a buggy snd_intel8x0 module. There was a warning on the alsa project site. The downside is that it wasn't made to work this way and therefor probably makes the system a bit unstable. Because as long as we inicialize the ALSA submodules the OSS emulation is there. Don't forget that in the new 2.6.x kernel if you are trying to use OSS modules.

otoomet 10-05-2004 12:21 AM

I had a somewhat similar problem with HP d530 sff, programs were complaining about
/dev/dsp. I simply repaced ALSA by OSS and it "just worked" for my big surprise. This is probably an ALSA bug related with intel8x0.


jfromcanada 11-15-2004 05:09 AM

ALSA works with a little pushing... also need to make sure all your apps are using ALSA. and/or build OSS compatibility mode into the kernel along with ALSA.
Also, you can try just using a daemon like esound or something; I do that, my env is gnome with enlightenment as wm, and I just use the esound daemon and get all apps to play through that
last but not least, check your mixer settings, the upgrade might have reset them all to zero (use alsamixer).
have fun!
hope this helps!

All times are GMT -5. The time now is 08:47 AM.