-   Linux - Laptop and Netbook (
-   -   Upgraded kernel, NDISwrapper don't work no more (

nyghtone 04-14-2004 10:42 PM

Upgraded kernel, NDISwrapper don't work no more
aight, check this, I just spent a week getting ndiswrapper-0.6 to work on my HP ze4600, got it working, did updates, and bam, don't work no more

I upgraded my kernal from 2.6.1-1.65 to 2.6.5-1.322, now ndiswrapper didn't work, so I tried recompiling it with the new kernel sources, and it won't even compile. It keeps erroring out on

[root@localhost jlaustill]# cd /usr/src/ndiswrapper-0.6
[root@localhost ndiswrapper-0.6]# make install
make -C driver install
make[1]: Entering directory `/usr/src/ndiswrapper-0.6/driver'
make -C /lib/modules/2.6.5-1.322/build SUBDIRS=/usr/src/ndiswrapper-0.6/driver DRV_VERSION=0.6 modules
make[2]: Entering directory `/lib/modules/2.6.5-1.322/build'
/bin/sh: line 1: /usr/src/ndiswrapper-0.6/driver/.tmp_versions/ndiswrapper.mod: No such file or directory
Building modules, stage 2.
make[2]: Leaving directory `/lib/modules/2.6.5-1.322/build'
mkdir -p /lib/modules/2.6.5-1.322/misc
install -m 0644 ndiswrapper.ko /lib/modules/2.6.5-1.322/misc
install: cannot stat `ndiswrapper.ko': No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory `/usr/src/ndiswrapper-0.6/driver'
make: *** [install] Error 2
[root@localhost ndiswrapper-0.6]#

so I uninstalled every file I could find and redownloaded it and still does the same thing, anyone know what is causin this? ARG

Joshua L. Austill

If I didn't love my laptops so much this linux stuff would be SoooO much easier, haha

Tino27 04-15-2004 04:21 PM

Re: Upgraded kernel, NDISwrapper don't work no more

Originally posted by nyghtone
mkdir -p /lib/modules/2.6.5-1.322/misc
install -m 0644 ndiswrapper.ko /lib/modules/2.6.5-1.322/misc
install: cannot stat `ndiswrapper.ko': No such file or directory

make[1]: Leaving directory `/usr/src/ndiswrapper-0.6/driver'

If I am understanding correctly from the bit that you posted, this isn't actually a compilation error, but an installation error. Without having checked out the NDISWrapper program, most programs follow the general

make install

pattern. The 'make' portion actually compiles and builds the modules, libraries, apps, etc. The 'make install' portion actually moves the compiled bits to the appropriate directories, sets up permissions, etc.

Based on the part I quoted from your original post, it seems that the problem that 'make install' is running into is that when it tries to copy the ndiswrapper.ko file from /usr/src/ndiswrapper-0.6/driver to /lib/modules/2.6.5-1.322/misc, it can't find ndiswrapper.ko at the /usr/src/ndiswrapper-0.6/driver location.

What I would suggest is to './configure' and 'make' again. As an extra safeguard, you might even want to do those from a clean source tree (re-extract the .tar.gz archive). Before you run 'make install', check to see that ndiswrapper.ko is in the right place. If not, put it in the spot that the 'make install' script expects it to be. Then run 'make install'.

I've run into this before with 'make install' and sometimes you just have to continue tweaking it until it works right.

nyghtone 04-15-2004 11:27 PM

went back
I just went back to the old kernel and recompiled and it worked, so I think I should try updating the kernel from source and compiling without a red hat configured kernel??? who knows


All times are GMT -5. The time now is 07:02 PM.