-   Linux - Laptop and Netbook (
-   -   Ubuntu 9.04 - Atheros AR242x wireless (

Something Else 08-02-2009 12:36 PM

Ubuntu 9.04 - Atheros AR242x wireless
I've been using a budget-line Compaq laptop which has an AR242x wireless controller from Atheros. It was running out of the box when I first put 8.10 on the system, but future kernel upgrades stopped the drivers from working - so I'd just been booting into an old kernel. After upgrading to 9.04, however, it was working out of the box again - until I rebooted, and presto! the wireless card was no longer detected by the system, even though there was supposedly an active proprietary driver.

I went to the compat-wireless site, downloaded and made the package, and after typing "make load," it appeared to work. Here's what I got.

ath5k loaded successfully
Module bcm43xx not detected -- this is fine
b43 loaded successfully
b43legacy loaded successfully

My networking applet now shows a "wireless networks" tab, but cannot see any networks. Further, I installed the wifi-radar package, to make sure it wasn't somehow a problem with GNOME and not the hardware drivers, and the terminal output says:

wlan0    Interface doesn't support scanning : Device or resource busy
Does anyone have any idea how I can resolve this issue and get my wireless back up and running? If going back to proprietary drivers will work, I'll do it - but I think that was what was working and stopped for no particular reason.

iwconfig results:


lo        no wireless extensions.

eth0      no wireless extensions.

pan0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0    IEEE 802.11bg  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated 
          Tx-Power=20 dBm 
          Retry min limit:7  RTS thr:off  Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

toreric 08-03-2009 12:18 PM

Your problem seems to depend on some volatile and undocumented bug in the ath5k driver.

I have experienced about the same appearance of "perhaps-functionality" of that new driver when upgrading from 8.04 to 9.04, and decided to revert to the madwifi driver -- which has been removed from the jaunty repositories!

Well I dowloaded the .deb from Debian instead, and the madwifi's driver (ath_pci) does function reliably.

Note: Remember to blacklist ath5k since it is told that they don't like each other!

I can tell more details if relevant, keep in touch!

P.S. Your problem may/may not be related to
(just a note).

Something Else 08-04-2009 01:58 AM

Update: I did a clean install, and the wireless worked out of box - until I had used it for a couple of hours, then the connection failed and when I disabled and reenabled wireless, it was back to how it was.

I tried installing the ndiswrapper Windows driver, but that gives the same net result. What is wrong here?

toreric 08-04-2009 06:05 AM

Did you check that the ndiswrapper driver does "take the command"? Maybe the default ath5k is still loaded in the kernel and acting just like before?

You may check using sudo lsmod or e.g. sudo lsmod | grep ath to verify loaded driver modules.

In order to prevent ath5k being loaded you may need to blacklist it in the /etc/modprobe.d/ directory.

In my case, after blacklist, lspci -k still shows that ath5k is an available module, but it doesn't come up in lsmod | grep ath since it isn't loaded (but the madwifi driver ath_pci comes up).

All times are GMT -5. The time now is 11:25 PM.