LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Trouble with ALi 5451 soundcard (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/trouble-with-ali-5451-soundcard-103453/)

Punkduplo 10-13-2003 12:10 PM

Trouble with ALi 5451 soundcard
 
Hie..
I know that are several threads in this forum concerning this same issue.. but i have tried to fix my problem for a few days now with help from the threads but havent had any succes.

I am going to provide as much info as i can for you people so someone can help me as easaly as possible.

Dist: RedHat 9
Soundcard: ALi corporation | m5451 pci AC-link controller audio device Computer: Toshiba Sattelite S1800-204

dmesg returns:
Trident 4DWave/SiS 7018/ALi 5451,Tvia CyberPro 5050 PCI Audio, version 0.14.10h, 18:00:09 Mar 13 2003 PCI: Found IRQ 11 for device 00:06.0 trident: ALi Audio Accelerator found at IO 0xed00, IRQ 11 ALi 5451 did not come out of reset. trident_ac97_init: error resetting 5451. I am not shore if i have completly installed ALSA in my try to use that.. what i did was:

Checked so i had soundcore working wich i did then: ------------------------------------------------
Make a directory to store the alsa source code in.

cd /usr/src
mkdir alsa
cd alsa
cp /downloads/alsa-* .

Now unzip and install the alsa-driver package

bunzip2 alsa-driver-xxx
tar -xf alsa-driver-xxx
cd alsa-driver-xxx
./configure --with-cards=ali5451 --with-sequencer=yes;make;make install
------------------------------------------------
And couldn't realy understand what to next or if it was finished there. I got help from this link:
http://www.alsa-project.org/alsa-doc...module=ali5451

I dont quit know wich angle to work frpm now.. to either continue trying to get ALSA to work or reinstalling the trident driver or something else. I realy want to get this working now.. gimmy some help!

Punkduplo 10-14-2003 09:03 AM

No feedback yet.. come on!.. I want to sort this out! I know there are people here who can help!.. =)

renegade69 10-14-2003 06:01 PM

Hey Punkduplo,
I had the same problem which you currently have. I revived my soundless soundcard by reconfiguring the kernel with the new 2.4.21 or 2.4.22 source code.
I have your same distribution, and same laptop.
I am unfimiliar with ALSA. But if you decide to go about this problem by reconfiguring the kernel, I will help you as much as need be.
The new source code has the core drivers for our ali 5451. This will solve your problem. To download either source code... go to www.kernel.org

Renegade

renegade69 10-14-2003 06:06 PM

z

h1tman 10-15-2003 01:17 PM

or you can just compile the trident module

quatsch 10-15-2003 08:50 PM

on my mdk9.1 the 'trident' module does not work for some reason that I don't understand - it worked just fine in 9.0 and before. I have to use snd-ali5451 which is the alsa driver for the same module.

You will need to do teh stuff they tell you about alsa-lib and alsa-util on that alsa-project page. And then do the modprobe thing. And then it should work.

Punkduplo 10-19-2003 09:40 AM

Hmm.. okey, havent realy don that modprobe thing.. might give it a shot though. After that i'l just go for recompiling the kernel for the newer version to make it work as renegade69 told me about since he had the same laptop and same dist that should be a save card. Well if i dont post another reply asume that i have solved the problem.


All times are GMT -5. The time now is 03:59 AM.