-   Linux - Laptop and Netbook (
-   -   trident cyberblade 9397 w/ linux 2.6 -- framebuffer help (

rabidundead 11-14-2004 02:12 PM

trident cyberblade 9397 w/ linux 2.6 -- framebuffer (solved)

I am trying to get a framebuffer console working on an IBM ThinkPad 770 with a Trident CyberBlade 9397 display. I have had it work before many times at 1024x768 with kernel 2.4.21 and various distros. However, I cannot get any but the default console mode working with kernel 2.6.7.

Background info:

For kernel 2.4 the argument 'vga=791' worked great. I was using LILO then and I am aware that LILO interprets this parameter and sets the mode, not the kernel.

My display is capable of 1024x768 at 16bpp, though, I don't know the refresh rate of that mode.

According to < >, the Trident CyberBlade is VESA 2.0-compliant, so I assume that the kernel 2.6 'vesafb' support should work.

I also know from various web resources that, although the 'tridentfb' driver mentions possible support for this display, it, in fact, does not work with my display.

Current situation:

I am upgrading to kernel 2.6.7. I included 'framebuffer support', 'vesafb', 'vga16fb' (basically all of the generic framebuffer support I could find) as built-ins to the kernel via menuconfig.

I did build the 'tridentfb' driver as a built-in also, though when I specify it as the driver to use via the kernel argument 'video=", I get nothing but a blank screenwhile the system boots.

Using 'video=mtrr.vesa:1024x768' drops to normal console mode.

Using 'video=vesafb' does the same, even if i add ':1024x768' or such to the line

Using 'vga=791' does the same, and AFAIK, is supposed to not work with this kernel anyway.. obsoleted in favor of the 'video=' syntax

One more piece of info:

As this may be a gotcha, I think it may be helpful to point out that I am not using LILO as the bootloader this time around, having opted to migrate to GRUB.


Anybody having any clue in this arena (including links to thorough documentation on the linux 2.6 'video=' syntax and all available options, etc. -- as I am not above RTFM-ing this problem) would be most appreciated.


rabidundead 11-14-2004 05:45 PM

New situation

I have recompiled and installed the kernel without 'tridentfb' at all

I am assuming that this driver is responsible for every test involving the 'vesafb' to result in a blank screen regardless of the boot-time "video=" kernel arguments i put in.


While it did alleviate the blank screen issue, i still only get standard console mode using either the "vga=" or "video=" syntax.

So, still not home, yet...

rabidundead 11-14-2004 07:38 PM

The "tridentfb" was a problem, not a solution.. it caused one part of the problem. The other part was following the general advice to use the "video=" syntax.. as I have successfully got my console at 1024x768 with a nice Tux logo despite this.


I recompiled the kernel making these changes:
  1. removed the "tridentfb" driver completely -- as in: it's not a module or a built-in
  2. removed the "vga16fb" driver, as well
For GRUB, I used the "vga=791" boot argument instead of the "video=" argument.


Problem solved


All times are GMT -5. The time now is 01:18 AM.