-   Linux - Laptop and Netbook (
-   -   Touchscreen suddenly stopped working (

Fa773N_M0nK 11-14-2012 03:33 PM

Touchscreen suddenly stopped working
Hey, I ran into some trouble lately.

Some basic info about my computer first. I have a Tablet PC ( to be specific, a ThinkPad x201t ). It has a touch and pen input.

My computer was originally shipped with Windows 7 Pro. Since then I have installed a huge variety of OSs on my computer; which includes a bunch of Ubuntu based distributions and Windows 8 Release Preview. I primarily use Linux Mint 13.
The tablet features on my computer are from Wacom and it was supported well in my OS, right from Linux Mint 10. Also, Windows 8 gives a smooth experience with the touch interface.
I am using the '3.2.0-32-generic' version of the Linux kernel and a 64-bit architecture.

Now the problem.
One fine day on my Linux Mint 13 I find that touch had suddenly gone. I thought that it might be a problem with that OS alone, so I checked up with Windows 8. Touch and Pen were gone there too. Hell, the system showed - No Pen or Touch available for this computer. Then, I thought that somehow the hardware had failed. BUT, when I went to my Windows 7, there it was working like a charm.
So what happened is, out of the blue my touchscreen and pen disappear from all my GNU/Linux's and my Windows 8 but work in Windows 7 ... !!!

Things I've tried.

I've reinstalled every package which had the string "wacom" in its name, to no avail.
In Windows 8, under Device Manager, my Wacom Two-Finger Touch does show up and it reports working properly. Still, I uninstalled everything under Human Interface Devices (HID). When I rebooted, everything came back ( including the Wacom ), but the computer reported no touch even then.

Linux Live
Usually touch worked in the Linux Mint 13 bootable media, but now it doesn't.

My fresh Linux Mint install leaves the touchscreen in relative (touchpad like) mode instead of the absolute (touchscreen like) mode. This is due is one faulty input attach rule in the above file (the only rule in the file, which is for Fujitsu tablets). Commenting it out used to remove the problem.
Now I found that it had 2 rules, one for Fujitsu and one for Wacom, both uncommented. I tried all possible combinations of comment/uncomment and rebooted, but no success.

I read that the 'inputattach' rules were referring to /dev/input/event*. So I 'cat' each of the event by turn, but none of them gave anything!
But, when i 'cat' '/dev/ttyS4' I got full response for my touch and pen. ( YAY! It seems hardware is working fine. )
Also, 'inputattach --dump /dev/ttyS4' responds to pen and touch.

Xorg logfile
'cat /var/log/Xorg.0.log | grep wacom' gives

[    24.550] (II) LoadModule: "wacom"
[    24.550] (II) Loading /usr/lib/xorg/modules/input/
[    24.550] (II) Module wacom: vendor="X.Org Foundation"
[    24.551] (II) Using input driver 'wacom' for 'Serial Wacom Tablet'
[    24.551] (II) Loading /usr/lib/xorg/modules/input/
[    34.312] (II) UnloadModule: "wacom"
[    34.312] (II) Unloading wacom

It seems the module is getting unloaded!

So finally some bunch of questions ...

Why does it work in Windows 7 but not in any other OSs? ( considering it used to )

What caused it to stop working, seemingly without reason?

Why did it stop working on all GNU/Linux's and Windows 8 simultaneously? ( and not Windows 7 )

AND ... how to make it work again?

P.S. : Really appreciate your help!

markush 11-15-2012 04:10 PM


a few questions. Did you any upgrades on Mint? or did there anything change in the /lib/udev/rules.d/40-inputattach.rules file?

could you please post the output of lsmod? and please try as root to load the wacom-module again

sudo modprobe wacom
Note that if modprobe exits without any message it could load the module and it would be shown when you execute lsmod afterwards. If there are any errormessages, please post them here.

It would also be good if you posted the output of

sudo lspci -k

Fa773N_M0nK 12-20-2012 02:56 AM

One fine day, my touchscreen started working on its own. And till now, I cannot find one reason why.


Thanks for your reply, but unloading/loading wacom did no good. Also, it works now without any wacom loaded!

"lspci -k" does not show any "acom" or "touch". So doesn't "lsusb".

Sorry for replying this late but I had my university exams and after that I was on the move, most of the time. :redface:

All times are GMT -5. The time now is 06:10 PM.