LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 06-01-2003, 11:00 PM   #1
wartstew
Member
 
Registered: Apr 2002
Location: Albuquerque, NM USA
Distribution: Slackware, Ubuntu, Debian, Maemo
Posts: 464

Rep: Reputation: 30
Tossh Sat Xfree Keyboard bounce prroblem


My Toshiba Sat 1405 has a nasty keyboard "bounce" prroblem wwith XFree86-4.3.0 (Knoppix 3.2), as you caan see. The saame distro is fine on my desktop machines. Any Ideas? Itt is fine in cconsole mmode.

I haven't tried earlier XFree86's yet. I guess I should.
 
Old 06-02-2003, 01:30 AM   #2
rmartine
Member
 
Registered: Dec 2002
Location: San Luis Obispo, CA
Distribution: Fedora Core 3
Posts: 618

Rep: Reputation: 30
In your XF86Config file, uncomment the XKBdisable option. This will stop the keyboard from bouncing.

Good Luck
 
Old 06-02-2003, 08:29 AM   #3
laurentbon
Member
 
Registered: Mar 2003
Distribution: Slack 9.1 + Dropline Gnome
Posts: 160

Rep: Reputation: 30
I have had that problem for quite a while. I have a toshiba laptop with a french keyboard.
If I uncomment XKBdisable, the keys stop bouncing fine, but I can't use the key 'Alt Gr' which gives access to extra character on a french keybord, like the pipe sign, the at sign...
Anyone Had a similar problem and managed to fix the bouncing while still keeping the AltGr key working? I would really like to tackle that one...

If it helps, this is my keybord section in Xf86config:

Quote:
Section "InputDevice"
Identifier "keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "AutoRepeat" "1000 30"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
Option "XkbLayout" "fr"
#Option "RightAlt" "ModeShift"
Option "XkbVariant" "nodeadkeys"
#Option "XkbDisable"
EndSection
 
Old 06-02-2003, 08:41 AM   #4
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
I had this issue as well with RedHat 8.0 on my Toshiba Satellite. I found that XkbDisable fix, after a lot of searching, and it works great. Since then I have upgraded to 9.0. Apparently they resolved this issue in 9.0 because I don't have to change anything in the config files.

Just a little FYI
 
Old 06-02-2003, 09:13 AM   #5
wartstew
Member
 
Registered: Apr 2002
Location: Albuquerque, NM USA
Distribution: Slackware, Ubuntu, Debian, Maemo
Posts: 464

Original Poster
Rep: Reputation: 30
Yea, thanks guys.

It worked great. In my case I had to add an "option "xkbdisable", and since I'm on a US keyboard, no bad side effects happened.
 
Old 06-02-2003, 11:52 AM   #6
rmartine
Member
 
Registered: Dec 2002
Location: San Luis Obispo, CA
Distribution: Fedora Core 3
Posts: 618

Rep: Reputation: 30
Quote:
Originally posted by laurentbon
If I uncomment XKBdisable, the keys stop bouncing fine, but I can't use the key 'Alt Gr' which gives access to extra character on a french keybord, like the pipe sign, the at sign...
Anyone Had a similar problem and managed to fix the bouncing while still keeping the AltGr key working? I would really like to tackle that one...
Try this method. It slows the bounce and return of the keys. Someone presented me this solution because he could type VERY fast and disabling Xkb extentions didn't cut it.


http://www.calpoly.edu/~rmartine/con....html#Keyboard

BTW this is my Linux site for Toshys
 
Old 06-03-2003, 12:10 PM   #7
laurentbon
Member
 
Registered: Mar 2003
Distribution: Slack 9.1 + Dropline Gnome
Posts: 160

Rep: Reputation: 30
Thank you very much for the tip martine! I am not sorted. It is great to be able to type properly!
I hope they will sort out this problem on the next kernel...
I found a very interesting site here detailing all the possible problem regardinf setting up Linux on a Tosh laptop by the way...
http://www.thorstenhaas.de/toshiba2410/
 
Old 06-05-2003, 02:37 AM   #8
laurentbon
Member
 
Registered: Mar 2003
Distribution: Slack 9.1 + Dropline Gnome
Posts: 160

Rep: Reputation: 30
Having said that...

Xkb works great. However, I don't understand in which file I should add the lines:
xkbset exp bo &>/dev/null
xkbset bo 1 &>/dev/null

to have them automatically exectuted when kde (my default manager) starts.
I haven't got a file /etc/X11/xdm/Xsetup, but mine is /etc/X11/xdm/Xsetup_0 and when I put it in that file, it doesn't execute it at start up.
As for the file .xinitrc, same thing: it doesn't seem to get executed...

So I have to execute those lines manually everytime I start my box... :-(

Any idea someone?
L
 
Old 06-05-2003, 02:45 AM   #9
rmartine
Member
 
Registered: Dec 2002
Location: San Luis Obispo, CA
Distribution: Fedora Core 3
Posts: 618

Rep: Reputation: 30
This will work when starting Kde.

1) Make a script containing the commands you need.
2) Right click on the Desktop -> Create New Link to Application
3) Move $HOME/Desktop/my_script to $HOME/.kde/Autostart

This is probably the chesse ball way of doing this but it's all I can think of right now.

Good Luck
 
Old 06-06-2003, 04:07 AM   #10
laurentbon
Member
 
Registered: Mar 2003
Distribution: Slack 9.1 + Dropline Gnome
Posts: 160

Rep: Reputation: 30
That doesn't work. I created a file with those two lines, made it executable. When kde starts instead of executing the file as a batch, it opens it in kedit on the desktop. How can I change that behaviour?
Cheers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
prroblem while compiling module mas00d Programming 1 02-22-2005 04:05 PM
XFree and DE-Keyboard? rntm Linux - General 1 01-13-2005 01:48 AM
X Keyboard no response. Something to do with xfree on tty2 smehi Linux - Software 0 06-03-2004 04:06 PM
Keyboard, XFree and Kde Half_Elf Linux - General 0 01-02-2003 01:34 AM
Multiple interfaces prroblem liuyangtj Linux - Networking 9 09-25-2001 03:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 08:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration