LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   tilde, pipe keys don't work on my dell laptop. (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/tilde-pipe-keys-dont-work-on-my-dell-laptop-551855/)

glarbl_blarbl 05-06-2007 11:38 PM

tilde, pipe keys don't work on my dell laptop.
 
It's the weirdest thing.

Whenever I try to use the tilde or pipe keys under linux on my Dell Inspiron 5100, nothing happens.

It doesn't matter if I'm in Xwindows or in a tty console, and xev doesn't respond when I hit the keys, holding shift makes no difference. It persists under both flavors of linux I run on this box (Slack 11 and 64 studio - a Debian variant). I seem to recall these keys working when winxp used to be on it, but that was a while ago...

I haven't found anything by searching these forums or googling, so any help would be greatly appreciated.

G

ak-87 05-07-2007 03:31 AM

Did you properly set your keyboard in xorg.conf?

glarbl_blarbl 05-07-2007 06:18 PM

I've tried all of the Dell keyboard variants under the gnome preferences- I just put it back to generic PC-104 since the dell keymaps screwed things up even more... No joy.

It seems to me that it doesn't have anything to do with X, since it happens when I open a tty console (e.g. CTRL-ALT-F1)- hell, I just tried them under grub and they didn't work.

I guess I can take another look through the BIOS, but I don't recall seeing anything regarding keyboards in there.

EDIT:
Took a look through the BIOS settings, but the only thing in there is a setting to use the numpad - either with the Fn key or with the numlock key.

Also, and I'm not sure if this is relevant- but the Fn key acts like the control menu key..

glarbl_blarbl 05-20-2007 03:54 PM

Still more weirdness.

I don't know what the hell I did, but now those keys work. And the Fn key does what it is supposed to. I guess the computer has become possessed and was just waiting for me to post a question about it. Frakking demon computers.


All times are GMT -5. The time now is 11:46 PM.