-   Linux - Laptop and Netbook (
-   -   Thinkpad keys stopped working (

NSKL 06-01-2008 02:55 PM

Thinkpad keys stopped working

So I've upgraded my T60p to new Ubuntu 8.04 and now some thinkpad keys do not work. In particular, thinkpads have two keys just above the left and right arrow keys that I used to change virtual desktops in 7.10 and they worked like a charm. However, they do not work anymore. I can map them to actions to change virtual desktops in Gnome keyboard shortcuts (they produce keycodes, 0xea and 0xe9), but pressing them does not change virtual desktops anymore. Any ideas how to get them to work again? Perhaps with xmodmap?

Thanks for help,

NSKL 06-02-2008 03:06 AM

Had a read around, and although I don't understand why they stopped working in the first place, I managed to fix this. I found out the keycodes of the keys (233 and 234) using xev, then mapped them to XF86Back and XF86Forward actions. Saved that to .Xmodmap and loaded it, reassigned the shortcuts in Gnome keyboard shortcuts setup, and auto magically everything works now.

Here is my ~/.Xmodmap

keycode 234 = XF86Back
keycode 233 = XF86Forward

Hope that helps someone,

All times are GMT -5. The time now is 05:23 PM.