Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).


  Search this Thread
Old 05-25-2005, 05:38 PM   #1
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
Things that make laptop go into power save

I just installed Slackware on a laptop. After about 5 minutes of being unattended, it goes into some sort of low-power mode (screen goes totally black and I can't ssh into it until I wake it up), even when it's on AC power. I was wondering what things make it do any power-save stuff so I could check/edit them.
Old 05-26-2005, 02:16 PM   #2
Registered: Jan 2005
Location: Washington, D.C.
Distribution: Arch (Custom), CentOS
Posts: 239

Rep: Reputation: 30
One possibility is to check in your xorg.conf file for something called DPMS. Under the ServerLayout section, you should have:

Option "StandbyTime" "###"
Option "SuspendTime" "###"

And under "Monitor" section you should have:

Option "DPMS" "true"

Probably one of the values in ServerLayout is a little too low for you.

For more help, google for "acpid" or "dpms"
Old 05-26-2005, 04:16 PM   #3
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Original Poster
Rep: Reputation: 32
Two things:

I boot to CLI, so I'm pretty sure it's not in the X config file. Also, I have apmd not acpid because it's too old for acpid, but I'll see what Google has to say.
Old 05-26-2005, 04:56 PM   #4
Registered: Jan 2005
Location: /dev/input/chair0
Distribution: Slackware, Gentoo, Vector, Roll-your-own-with-GNU binutils
Posts: 174

Rep: Reputation: 30
Not on my slackware box atm, but I think:
It is called from /etc/rc.d/rc.M
look for a line near the beginning of the file that starts with:
/bin/setterm -blank 15

thats your powersave options



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn off Power save mode killersheep Debian 2 07-12-2005 05:34 PM
Enable Power Save on My Linux Laptop to Prevent Lost of Data lennysokol Linux - Laptop and Netbook 4 06-01-2005 02:11 AM
screen goes to power save mode in X michael_j_w Fedora 0 01-08-2005 01:17 AM
Enabling power save/power management/cpu freq scaling features for a Debian system zero79 Debian 0 12-19-2004 02:17 PM
Screen Goes Power Save Mode CrAzY G Linux - General 10 01-18-2004 03:38 PM > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 09:42 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration