-   Linux - Laptop and Netbook (
-   -   The dreaded 82845G Intel Integrated Graphics - Does any Linux work with it? (

BobNutfield 04-16-2010 05:11 PM

The dreaded 82845G Intel Integrated Graphics - Does any Linux work with it?
Hello Everyone,

I have been on holiday this week and one of the things I was going to do was take an afternoon and revive an old laptop I have for my wife (P4 1GB mem). Well that afternoon has turned into four days of headaches.

I really didn't research it before I undertook this because Linux supports so much hardware now I did not think this was going to be an issue.

My original desire was to install Slackware, which would work with the vesa driver, but could never get networking solved.

I next installed Fedora 13 which was very slow and it booted to a black screen three out of five boots.

I have now installed Ubuntu Lucid (10.04) and the video is still crashing. I have since learned that Ubuntu does not even support this chipset.

On Intel's site, the chipset is listed as being support by both the i915 module and the i810. All three distros I have tried installed the i915 module during the install. All three failed to work with any stability (except Slack with the vesa driver only.)

So, my question is: Does anyone have any Linux running with that chipset with success? It appears that many, many people have had difficulty with this graphics chipset, and I guess it may be that I have found a machine that cannot be used with Linux with any stability at all.

Any replies are appreciated.


RockDoctor 04-17-2010 07:24 AM

No problems with Fedora 12. Try using the intel driver

BobNutfield 04-17-2010 08:03 AM


Originally Posted by RockDoctor (Post 3938432)
No problems with Fedora 12. Try using the intel driver

Thank you for your reply. Since there is no xorg.conf in any of the newer distros, I assume one would rmmod i915 and modprobe intel. I have not tried that, as I did not understand the difference between the drivers.

I will give that a shot. Right now Ubuntu Lucid is installed and I can get to a desktop which works fine as long as it is there. It abruptly crashes sometime with no warning.

It seems odd to me that a chip this old has caused so many problems for so many (many posts on Ubuntu, Fedora and LQ).

If I could get it stableized, the desktop works OK. This chip has 128M of AGP memory with the ability to share another 8M. It would be an alright experience if it were stable.

Thanks again.


jlinkels 04-17-2010 08:18 AM

Read this:

Planning one afternoon and being occupied for 4 days is nothing new, it happened to me 2 weeks ago when (also!) my wife's desktop crashed and I decided to install Debian Sid. :)

BTW, I see you are using 3 different distro's. Usually it is not such a good idea, if you have these kind of problems they are hardly solved by swapping distros. Most modern distros all have the same drivers or those drivers can be installed. The main difference between distros usually is the way they install packages, and the 3 distros you used are completely differen regarding package management. It might be better to stick to one distro and try to solve the problem there, now you do a lot of duplicate work.

That having said, now you are using Ubuntu which pulls from the Debian repos. The solution as posted in the link might work for you and then you are done.

If you swap a distro once more, I can recommend Debian, good package management and it doesn't violate the Linux security model like Ubuntu does.


BobNutfield 04-17-2010 11:44 AM


BTW, I see you are using 3 different distro's. Usually it is not such a good idea
Thank you for your reply and the link you provided. I have used those three distros for five years simultaneously, but on different machines and for different purposes. I have a number of computers in my home network. All of the of machines/distros on them are exactly as I want them. Some things are too difficult to work in Slackware (which is my distro of choice) so I use Ubuntu for that, such video editing and my always-on desktop. I have to admit that the only reason I keep Fedora running on one machine is because I am a little sentimental about the fact that it was Red Hat/Fedora introduced me to Linux in 1997. I don't like the direction that Fedora has taken over the last couple of versions, but I suppose I will always be running a copy of it on one machine so that I can keep up with its progress.

Slackware is my main workhorse and that will remain true. If I had to choose one and could not run anything else, that would be my choice.

I did run Debian for a couple of years back about two versions ago. I did like it, but it just did not run as smoothly for me as Slackware.

This laptop that I am trying to set up now is one that my wife used to use before Windows became unusable on it. This whole episode was unfortunate because I was in the midst of convincing that Linux was now easy and stable, and she could trust it. This ordeal has done little to help that effort.

Thanks again for your help.


UPDATE: The link provided suggests an edit to the xorg.conf file, which of course no longer exists in Ubuntu. I am not sure if it is possible to add one and have it override the defaults.

BobNutfield 04-17-2010 12:23 PM


[ 0.000000] Phoenix BIOS detected: BIOS may corrupt low RAM, working around i

[ 13.104216] intel_rng: FWH not detected
[ 13.342150] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[ 13.343411] Linux agpgart interface v0.103
[ 13.433758] ppdev: user-space parallel port driver
[ 13.434800] agpgart-intel 0000:00:00.0: Intel 830M Chipset
[ 13.435088] agpgart-intel 0000:00:00.0: detected 8060K stolen memory
[ 13.485506] agpgart-intel 0000:00:00.0: AGP aperture is 128M @ 0x88000000
[ 13.663619] [drm] Initialized drm 1.1.0 20060810
The above is from dmesg. I have never seen anything like the possibility of a corrupt BIOS before. The dmesg info about the graphics chip looks normal.


PTrenholme 04-17-2010 12:59 PM

Bob, the "no xorg.conf" thing you mentioned in #3, above, is only "true" if you want the X-server to apply its defaults to your system. Since, as you noticed, the defaults don't work for you, use the Xorg -configure command to create an xorg.conf (in the $CWD) that you can modify an move to /etc/X11/. If you have an xorg.conf file in there, it will be used instead of the default values.

To see what drivers you have installed, do something like this:

$ find /usr/lib64/xorg/modules/ -iname i*so

and then modify the "Device" stanza to use an alternative driver. For example, if the Device stanza used the i740 driver, you'd make the changes I highlighted in bold, below:

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "SWcursor"                  # [<bool>]
        #Option    "HWcursor"                  # [<bool>]
        #Option    "NoAccel"                  # [<bool>]
        #Option    "ShadowFB"                  # [<bool>]
        #Option    "VideoKey"                  # <i>
        #Option    "FPDither"                  # [<bool>]
        #Option    "FPScale"                  # [<bool>]
        #Option    "ScalingMode"              # <str>
        #Option    "EXAPixmaps"                # [<bool>]
        Identifier  "Card0"
#      Driver      "i740"
        Driver      "intel"

        VendorName  "Intel"
        BoardName  "82845"
        BusID      "PCI:0:18:0"

BobNutfield 04-17-2010 01:44 PM

Thank you, PTrenholm. I have spent too much time away from the insides. I have got Ubuntu 10.04 installed and it the first time I have encountered Grub2 and I have to say to don't like it a bit. I have no idea how to close X and get to a command line so that I run Xorg -configure. Ubuntu's module directories are different. It will take me a little while to find where they are at.

I'll keep plugging.

Thanks again.


PTrenholme 04-17-2010 05:41 PM

Well, GRUB (whatever the version) has nothing to do with the X-server or its configuration, so that should be a non-issue in the X-server configuration.

Since I saw all the problem reports (and the move to software patent encumbered "Mono" dependencies) in Ubuntu 10, I haven't bothered to upgrade from Jaunty and, frankly, haven't even logged in to that partition of my drive for several months.

That being said, the Jaunty (and prior Ubuntu releases) always had a "Recovery" boot option that, among other choices, offered a "command line" log-in option. That's one way to start a terminal session, but it would probably be easier just to open a terminal session (Applications->System->Terminal), run the Xorg -configure command, edit the output file (gedit xorg<tab>), and then do a sudo mv xorg<tab> /etc/X11/xorg.conf (where, at least on Jaunty, the xorg.conf should be located).

Note: In the above comment I suggest using the "tab completion" feature of bash for the output file name of the Xorg command since Xorg may be "creative" about naming the output file. (I've seen a and other names when the ".new" already exists.)

jlinkels 04-17-2010 07:00 PM

If you run Xorg-configure with these magnificent new distros you won get an xorg.conf. Xorg-configure finds everything default and doesn't ask any questions and doesn't build an xorg.conf

It is better to copy an xorg.conf from one of the older distros and adjust it to your needs. So you don't need to switch off KDM, just restart it. Usually the command would be /etc/init.d/kmd restart, but maybe Ubuntu found a more user friendly way to accomplish this (reboot). Either way should work.


RockDoctor 04-18-2010 05:51 AM

Unlike Fedora, one very annoying thing about Ubuntu is that Ubuntu does not have one of its runlevels set up to start with all services but without X. I usually end up doing something like <ctl><alt>-F2 to get to a terminal, sudo /etc/init.d/gdm stop, and using kill -9 on X and any programs that run under X, sometimes multiple times before they're all dead. Then I can run X -configure.

It might be easier to boot without X by setting up a totally broken xorg.conf and just reboot - haven't tried that method.

PTrenholme 04-18-2010 01:28 PM

Oh, sorry:redface:: I forgot that Xorg needs to be run on a ptty with no X-server attached. Just do a Xorg :1 -configure if you have a running X-server on :0 (the default).

Note that you can test your new xorg.conf by starting a new server on an alternate ptty by entering a startx -- :1 -config xorg<tab> If you do that, when you logout of that X session, you'll be returned to the running session on display :0. If you have the correct options set (see man xorg.conf) you can switch between the different displays with a <ctrl>-<alt>-<Fn> key combination, where "Fn" is usually F7 for display 0 through F10 for :4, although Fedora now uses F0=:0, F7=:1, etc.

JAQ 06-08-2010 03:18 AM

Can I just ask if there is any hope for someone like me, who is new to Linux and experiencing exactly the same issue as Bob, and can only grasp about 10% of what is written here simply as I have no experience with Linux.

Everything is great about Ubuntu 10.04, but if it's not stable due to a graphic card compatibility issue it becomes useless to me.
Am I forced to return to the Windows I detest?

ahzthecat 06-08-2010 03:37 AM

I have a Dell with that chipset, and Slackware proved to be to much work to set up. I am running Debian Lenny on it now, and it works great. Ubuntu has video problems out the wazoo on my machine, older versions worked, but anything after 8.04 is problematic. Vector Light worked very well, Puppy of course played nice with the clunker too. I have also used Mepis (long, long ago) to some success on this machine. Give Deb a try, it works for me!

craigevil 06-08-2010 06:58 AM

A lot depends on what version the Intel driver is in the distro.

I don't have the same card as the OP, mine is Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub [8086:2580] (rev 04), using the Intel driver is Debian works reasonably well.

Installed: 2:2.9.1-4
Candidate: 2:2.9.1-4

If it helps here is my xorg.conf

Section "ServerFlags"
          Option                "AllowMouseOpenFail"        "true"
        Option          "DontZap"              "off"

Section "Device"
        Identifier        "Device 0"
        Driver                "intel"
        BoardName        "Intel Corporation 82915G/GV/910GL Integrated Graphics Controller"
        BusID                "PCI:0:2:0"

Section "Module"
  Load  "dbe"
  Load  "dri"
  Load  "extmod"
  Load  "glx"
  Load  "bitmap"
  Load  "freetype"

Section "DRI"
  Mode  0666

Section "Extensions"
        Option        "Composite"        "on"

All times are GMT -5. The time now is 04:32 PM.