LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Synaptics TouchPad Problem (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/synaptics-touchpad-problem-334392/)

Toniee 06-16-2005 08:35 PM

Synaptics TouchPad Problem
 
Hey,

I own a Compaq Presario M2005US Laptop and it comes with a touchpad like all other laptops. I run SuSE 9.3 Pro and use KDE 3.4.

A problem with the touchpad tapping has gotten a little annoying. When I tap the touchpad lightly on a browser or in any text feild, it pastes the last copied text I copied.

How do I fix that? I've played with everything on the KDE Control Panel and YaST, no options to fix, sax2 cannot fix it too.

Can someone help me?

Thanks
Tony
:cry:

craigevil 06-17-2005 01:18 PM

Look for ksynaptics or qsynaptics, tpconfig, and make sure you have the right driver; xfree86-driver-synaptics.

awtoc123 06-24-2005 01:30 AM

Just to inform you I have the same notebook, and none of those driver do anything, I have even totally uninstalled all touchpad drivers, and still the touchpad is working. I want to totally un-install and disable the touchpad.

Redhat RHEL4 - kernel 2.6.11

Any Idea how to disable the touchpad without having to re-write the kernel, or better open the box and pull the plug is perhaps the easy way.

priller 07-01-2005 05:11 PM

try changing

Code:

Option        "MaxTapTime"    "180"
to

Code:

Option        "MaxTapTime"    "0"
in the xorg.conf file.

awtoc123 07-01-2005 10:21 PM

Touchpad
 
Hi Piller and thanks for your reply, I have totally uninstalled all drivers realating to the touchpad, and ther is no reference to the touchpad in the xorg.conf file, I think the touchpad is driven via PS2 muse driver, so I need to disable the PS2 support, as I'm using USB mouse.

priller 07-02-2005 04:09 AM

So you want to completly turn off the touchpad? No idea howto do that but, if you install the driver then change the line above it wont react to you tapping it.

basileus 07-02-2005 12:14 PM

Synaptic touchpad (those I've tried) work fine with the psmouse module and PS/2 -protocol (in XF86Config-4).

If "psmouse" is loaded as a module (check /sbin/lsmod), then you might try preventing it from loading. You could add "psmouse" to /etc/hotplug/blacklist. I'm not sure if it works, but it might.

If that does not work, try installing the xfree86-driver-synaptic, editing XF86Config-4 (or xorg.conf) appropriately and then disabling the tap as suggested above:

Option "MaxTapTime" "0"


All times are GMT -5. The time now is 09:45 PM.