-   Linux - Laptop and Netbook (
-   -   Synaptic drivers and touchpad (

autophil 06-27-2011 02:38 AM

Synaptic drivers and touchpad
My touch pad does not work properly. I get no acceleration and no "tap-tap and drag" feature. below is one section of my xorg.conf.
Can anyone advise me if this looks correct.
I also get the message "No synaptic drivers loaded". Its a Toshiba Satellite laptop running Zenwalk 7.0

Section "InputDevice"

# Identifier and driver
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/input/mice"
# Option "Protocol" "Xqueue"
# Option "BaudRate" "9600"
# Option "SampleRate" "150"
# Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"
# Option "ChordMiddle"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
Identifier "Pad1"
Driver "synaptics"
Option "Protocol" "auto-dev"
Option "Device" "/dev/tp1"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
Option "TapAndDragGesture" "Yes"
# Option "VertEdgeScroll" "1"
# Option "HorizEdgeScroll" "1"
# Option "LeftEdge" "1700"
# Option "RightEdge" "5300"
# Option "TopEdge" "1700"
# Option "BottomEdge" "4200"
# Option "FingerLow" "25"
# Option "FingerHigh" "30"
# Option "MaxTapTime" "180"
# Option "MaxTapMove" "220"
# Option "VertScrollDelta" "100"
# Option "MinSpeed" "0.09"
# Option "MaxSpeed" "0.18"
# Option "AccelFactor" "0.0015"
Option "SHMConfig" "on"

superdog 06-27-2011 07:55 PM

try uncommenting (removing the # before) # Option "VertEdgeScroll" "1" and # Option "AccelFactor" "0.0015". All of the lines starting # are ignored.

Where do you get the message?

fbsduser 06-28-2011 12:45 PM

Try booting it off an opensuse liveCD. I have had a few bad experiences with Toshiba laptops that will act strange under any distro not based on SUSE, but working normally under suse and windoze.

markush 06-28-2011 01:30 PM

I don't know how Zenwalk 7 is configured, but as of Slackware-13.37, look at the "Changes and Hints" ftp://sunsite.informatik.rwth-aachen..._AND_HINTS.TXT there is explained how you can configure the files within the /etc/X11/xorg.conf.d/ directory

from Changes_and_Hints.txt
The version of Xorg in Slackware 13.37 will not (in most cases) require an
/etc/X11/xorg.conf file. Input hotplugging is no longer done using hal;
instead, it now uses udev for input device detection and keyboard mapping.

/usr/share/X11/xorg.conf.d/ is the "packaged" configuration directory; all
files ending with ".conf" in this directory are used by the X server
unless there is an identically-named file in the local sysadmin directory.
The local sysadmin config directory is /etc/X11/xorg.conf.d/ - all files
ending with ".conf" in this directory are parsed.

There are several default config files in /usr/share/X11/xorg.conf.d/:
* 10-evdev.conf
a "catchall" file for input devices using the evdev driver; this
should work for most hardware in the absence of a better driver
* 50-synaptics.conf
overrides the earlier 10-evdev.conf file and uses the synaptics
driver for all touchpads
* 50-wacom.conf
overrides the earlier 10-evdev.conf file and uses the wacom driver
for Wacom tablets
* 90-keyboard-layout.conf
this sample ("normal" en layout) keeps the "old" default of
allowing Zap'ing the Xserver.
If you need to modify any of these defaults, then copy the relevant file
from /usr/share/X11/xorg.conf.d/ to /etc/X11/xorg.conf.d/ and edit the

You can still create an xorg.conf file if you wish, or you can create some
minimal xorg.conf snippets with only the specific contents that you wish
to override (as an example, to use a binary-only video driver) as separate
files in the /etc/X11/xorg.conf.d/ directory.
As I said, I don't know if this is already available for Zenwalk.


autophil 06-28-2011 01:43 PM

Thanks Superdog for your reply. OK. I was a bit wary of changing that file as the message at the top warns to edit the file "with caution". Anyway I changed those features but everything is still the same. I must say though that I have not rebooted the laptop.
When I type in
#synclient -l
I get the message about no synaptic drivers loaded.

markush 06-28-2011 02:02 PM

could you please post the output of

lsmod | sort

autophil 06-28-2011 02:16 PM

Thanks Markus.
In my /etc/X11/xorg.conf.d I have two files. 10-evdev.conf and 50-synaptics.conf
Both of them I put there from /usr/share/X11xorg.conf.d

It has Section "InputClass"
Identifier "touchpad"
Driver "synaptics"
MatchDevicePath "/dev/input/event*"
MatchIsTouchpad "on"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
Option "TapAndDragGesture" "Yes"


The man page gives loads of further options. Does this page then have to be extensively set up?

autophil 06-29-2011 07:54 AM

Thanks Markush. I went and read that document and although Im not really a computer guy I did find it interesting.
Zenwalk 7.0 does in fact include the /lib/udev/rules.d directory as well as /etc/udev/rules.d
And so it seems that /etc/X11/xorg.conf.d is something in the past.
Anyway the bottom line is that my touchpad is still not working properly. It does the basics, but one needs a bit more than that.

The output of lsmod |sort, is like this:

root[xorg.conf.d]# lsmod | sort
8139too 12480 0
Module Size Used by
ac 1792 0
agpgart 15204 3 ttm,drm,ati_agp
arc4 772 2
ath 8832 1 ath5k
ath5k 102292 0
ati_agp 3180 0
battery 6512 0
button 2884 0
cfg80211 76736 3 ath5k,ath,mac80211
drm 96688 4 radeon,ttm,drm_kms_helper
drm_kms_helper 16228 1 radeon
ecb 968 2
ehci_hcd 25316 0
evdev 5216 0
fan 1388 0
fuse 40188 3
hwmon 756 1 radeon
i2c_algo_bit 2896 1 radeon
i2c_core 9512 5 radeon,drm_kms_helper,drm,i2c_algo_bit,i2c_piix4
i2c_piix4 6264 0
ip_tables 6872 3 iptable_mangle,iptable_nat,iptable_filter
iptable_filter 572 0
iptable_mangle 672 0
iptable_nat 1668 0
joydev 6028 0
lp 4996 0
mac80211 113460 1 ath5k
mac_hid 1768 0
mii 2332 1 8139too
mmc_core 30764 1 ssb
nf_conntrack 27912 3 iptable_nat,nf_nat,nf_conntrack_ipv4
nf_conntrack_ipv4 5720 3 iptable_nat,nf_nat
nf_defrag_ipv4 556 1 nf_conntrack_ipv4
nf_nat 7900 1 iptable_nat
ohci_hcd 14952 0
output 772 1 video
parport 17928 3 ppdev,parport_pc,lp
parport_pc 22204 0
pci_hotplug 14780 1 shpchp
pcmcia 21008 1 ssb
pcmcia_core 6544 3 yenta_socket,pcmcia_rsrc,pcmcia
pcmcia_rsrc 5928 1 yenta_socket
ppdev 3684 0
processor 17632 1
radeon 472428 1
sg 14932 0
shpchp 15608 0
snd 27052 12 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_intel,snd _hda_codec,snd_pcm,snd_timer
snd_hda_codec 34996 2 snd_hda_codec_realtek,snd_hda_intel
snd_hda_codec_realtek 186724 1
snd_hda_intel 14020 2
snd_mixer_oss 8464 2 snd_pcm_oss
snd_page_alloc 3872 2 snd_hda_intel,snd_pcm
snd_pcm 33828 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_pcm_oss 22180 0
snd_seq 26128 4 snd_seq_oss,snd_seq_midi_event
snd_seq_device 2852 2 snd_seq_oss,snd_seq
snd_seq_midi_event 2704 1 snd_seq_oss
snd_seq_oss 15384 0
snd_timer 10504 2 snd_seq,snd_pcm
soundcore 2592 2 snd
sparse_keymap 1352 0
ssb 25664 1 ohci_hcd
thermal 5248 0
ttm 28588 1 radeon
video 8612 0
x_tables 7080 4 iptable_mangle,iptable_nat,iptable_filter,ip_tables
yenta_socket 13500 0

markush 06-29-2011 09:09 AM

You should try to load the module "acpi_toshiba" and the module "synaptics_i2c" via modprobe, maybe that helps.
I'm not sure.
If you get an errormessage when using the modprobe command "no such device" the module will not work for you, but if you get a message that the module is not there, you can rebuild your kernel with the module. If modprobe exits without any message the module is loaded.


autophil 06-29-2011 09:56 AM

For #modprobe "acpi_toshiba" I get

WARNING: All config files need .conf: /etc/modprobe.d/alsa-base, it will be ignored in a future release.
FATAL: module acpi_toshiba not found.

For #"synaptics_i2c" I get
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base, it will be ignored in a future release.

SO does this mean Rebuild the kernel? Sounds daunting!

markush 06-29-2011 10:59 AM

That looks like the synaptics_i2c module has been loaded (the errormessage about the config files doesn't matter).

You could check that with lsmod (note that if you've rebooted, you'll have to load the module again).

Has anything changed with your touchpad when this module is loaded?


All times are GMT -5. The time now is 11:21 PM.