-   Linux - Laptop and Netbook (
-   -   Suspend to RAM causes laptop to shut down (

linuxpyro 07-10-2010 02:06 AM

Suspend to RAM causes laptop to shut down
I have a Lenovo G530 laptop, currently running Fedora 13 (64 bit). When I try to suspend to RAM, the machine just shuts down. I can restart it and have it run just fine, but I cannot get it to resume. I had the same problem with Ubuntu after upgrading to Lucid; I decided to give Fedora a try and found no change with this problem.

I've tried suspending from the shell, but the same thing happens. I use the following command (as root):


echo mem > /sys/power/state
Has anyone else had this problem?

business_kid 07-10-2010 03:47 AM

Is your kernel set up for all of this?

linuxpyro 07-10-2010 04:22 PM

It should support it:


[me@host ~]$ cat /sys/power/state
mem disk

The other ACPI things on my laptop seem to be supported.

fbsduser 07-10-2010 06:39 PM

can you try using pm-suspend or s2ram instead? One old laptop I used to have would only suspend/hibernate with pm-tools, using uswsusp and tuxonice would result in a crash.

linuxpyro 07-10-2010 09:06 PM

I tried using s2ram, but just running the command gave the following output (my machine wasn't recognized):


Machine is unknown.
This machine can be identified by:
    sys_vendor  = "LENOVO"
    sys_product  = "444624U            "
    sys_version  = "Lenovo 3000 G530                "
    bios_version = "6GET17WW(V1.08)    "
See for details.

If you report a problem, please include the complete output above.

I tried s2ram --force, but this again just made the machine shut down. I also tried pm-suspend, but it did the same thing.

All times are GMT -5. The time now is 10:57 PM.