-   Linux - Laptop and Netbook (
-   -   Suspend/Hibernate Fail to Resume (

Quantumstate 10-13-2010 12:57 PM

Suspend/Hibernate Fail to Resume
This has always worked for me in Debian, but on my recent full reinstall, no more.

Suspend puts it down just fine, although seemingly much faster than before. The power button intermittently flashes, as before. I hit power and it seems to resume, but the screen is blank and Mute light is on on the keyboard. The Wifi light comes on fine and flashes as if there's traffic. Mainly a dead-blank screen. Does this whether suspend or hibernate, kernel 2.6.32-23, -28, or 2.6.30.

I hit the power button and after 30 seconds it reboots as it should, and comes up just fine. There's nothing odd in the pm-suspend.log or messages, so I am at a loss.

kilgoretrout 10-13-2010 03:55 PM

I assume you are using the proprietary nvidia driver. Could you post which one you are using. Also, post your xorg.conf file. I've run into this several times over the years with the proprietary nvidia driver. Many times just adding this line to the "Device" section of xorg.conf cures the problem:

Option "NvAGP" "1"

Quantumstate 10-14-2010 10:46 AM

Yep, you're on the right track, kilgoretrout.

I tried everything I could think of, including newer/older kernels, newer/older nVidia drivers, manually running pm-suspend, etc. But it turns out the problem was damned Compositing.

With the new install, I decided to try and let X make all the decisions, rather than having an xorg.conf file. When I reinstated my xorg.conf then I now have Suspend and Hibernate working properly. This is what it looks like:

Section "Device"
    Identifier    "Video0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
        Option                "NoLogo"        "True"
        Option                "UseEvents"        "True"
        Option                "AddARGBGLXVisuals" "True"
        Option                "DPMS"                "True"

# For MythTV VDPAU
Section "Extensions"
    Option        "Composite" "Disable"

When that worked, I commented out my Device Options and tried again, and it still worked. So the problem is Compositing.

(BTW, AGP is way old and is not present on current cards)

kilgoretrout 10-14-2010 11:50 AM


BTW, AGP is way old and is not present on current cards
I know but many people still use them, particularly on older laptops, and the NvAGP trick is still necessary from time to time or you will get exactly the symptoms described in your original post. If you don't post your hardware specs, people are just left guessing. That's why I asked what driver you were using. A legacy driver would have indicated and older AGP card.
At any rate, I am glad you figured it out. I will file away the disable compositing in the list of tricks to use to get suspend/hibernate to work with the proprietary nvidia driver.

All times are GMT -5. The time now is 08:09 PM.