-   Linux - Laptop and Netbook (
-   -   Suspend Fails to Resume (

dengel 11-27-2005 08:58 AM

Suspend Fails to Resume
I have a Systemax Pursuit 2130 C27 BTO Notebook running Gentoo. I have the Gentoo kernel sources (not suspend2) and I have the hibernate script package installed.

When I 'hibernate -n' everything seems to work fine.

When I hibernate, it seems to work fine, too, and then appears to power down. I have to assume for now that it's keeping the ram powered; however, I'm not sure.

But when I press the power button to resume, the power comes back on (that is, the fan starts spinning) and the access lamps for the hard drive and the CD-ROM drive each flash twice (one at a time, going back and forth, not at the same time.) Then it just sits there.

Using the keyboard doesn't seem to do anything (can't get the caps lock to light or anything, machine doesn't reboot or anything), and I've let it sit for as long as a half hour, just to see if there was somthing going on that was really slow.

There is an ATI Radeon video chip, and I've tried using the vbetool to save and restore the state, as well as doing the hibernate in X ( 6.8.2), which had been suggested for ATI's. I've also tried doing it from the console with no framebuffer console and no X running. No dice.

Here's what 'lspci' prints out:

0000:00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS645DX Host & Memory & AGP Controller (rev 01)
0000:00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
0000:00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO] (rev 14)
0000:00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
0000:00:02.3 FireWire (IEEE 1394): Silicon Integrated Systems [SiS] FireWire Controller
0000:00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
0000:00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
0000:00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
0000:00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
0000:00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
0000:00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
0000:00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
0000:00:0a.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL 9000] (rev 01)
0000:02:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

Here's my kernel command line:

/dev/hdc=ide-cd root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda5 acpi_sleep=s3_bios

I've tried doing it with acpi_sleep=s3_mode, as well as with no acpi_sleep option.

I've checked and tried the tricks and options suggested in other threads on suspend/resume.

Does anyone have any other ideas, or know what might be getting in the way of resuming?

All times are GMT -5. The time now is 06:07 AM.