LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 05-30-2005, 10:08 PM   #1
Hinokagutsuchi
LQ Newbie
 
Registered: May 2005
Distribution: Suse 9.1
Posts: 4

Rep: Reputation: 0
Suse not recognizing all of my processor


I have a Compaq Presario 2100 with Suse 9.1 Pro installed.

The problem I have is that Suse says my processor is running at 530mhz. I check the hardware info under YaST and for cpu mhz it reads 530, so Suse 'thinks' that my processor is only 530mhz unless I'm misreading it. However, I don't think I am. My laptop begins to lag when I play flashfiles, even simple ones that are simply loops, which leads me to believe that it only recognizes my processor as being 530mhz instead of 1.8ghz. I know that under XP my processor speed varied depending on what I did; that is, it would read 800mhz if I was simply on irc, but if I started doing more then it would recognize it as a faster processor.

I've checked the bios, and there's nothing relating to the CPU there. I can't even see anything in order to see if my CPU's clock speeds have been changed. I've also checked here and on linux-laptop.net and I've come up empty handed. I've looked on google and I haven't found anything, but I may not be searching with the right terms.

Any help is greatly appreciated.
 
Old 05-30-2005, 10:40 PM   #2
saneax
Member
 
Registered: Aug 2004
Distribution: Gentoo, Suse, Fedora, Debian
Posts: 86

Rep: Reputation: 15
yast displaying ... wrong CPU Speed is normal... dont worry..
post or take a look at
#>cat /proc/cpuinfo
 
Old 05-30-2005, 11:12 PM   #3
Hinokagutsuchi
LQ Newbie
 
Registered: May 2005
Distribution: Suse 9.1
Posts: 4

Original Poster
Rep: Reputation: 0
Ok, here's the output of cat /proc/cpuinfo

processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 8
model name : mobile AMD Athlon(tm) XP2200+
stepping : 1
cpu MHz : 529.946
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext 3dnow
bogomips : 1048.57
 
Old 05-31-2005, 01:39 AM   #4
fangorn
LQ Newbie
 
Registered: May 2005
Distribution: Gentoo/Debian/AIX
Posts: 9

Rep: Reputation: 0
If your processor is too slow try looking at
/proc/acpi
there are directories for
processor
thermal_zone
and so on.
look for variable throttling in the processor tree and do
cat <path>/throttling
If there is something other than zero in this, your processor is "waiting for cooler weather" some of its calculation cycles. In this case you will have to mess with thermal states, fan states, trip_points and other stuff to get it working faster.
 
Old 05-31-2005, 12:55 PM   #5
Hinokagutsuchi
LQ Newbie
 
Registered: May 2005
Distribution: Suse 9.1
Posts: 4

Original Poster
Rep: Reputation: 0
I tried that, and here's what I got:

cat /proc/acpi/processor/CPU0/throttling
<not supported>
 
Old 05-31-2005, 04:16 PM   #6
ithawtewrong
Member
 
Registered: Jul 2004
Location: Mile High
Posts: 161

Rep: Reputation: 30
Try this see if it helps:

I believe what you need to do is go and do:

YaST->System->/etc/sysconfig Editor->Powermanagment->Powersave->CPU->Powersave_CPUFREQD_MODULE=powernow-k8
 
Old 05-31-2005, 08:15 PM   #7
Hinokagutsuchi
LQ Newbie
 
Registered: May 2005
Distribution: Suse 9.1
Posts: 4

Original Poster
Rep: Reputation: 0
Haha, it worked. CPU Clock: 1788, CPU Mhz: 1788.742.

Thanks a bundle.
 
Old 05-31-2005, 11:54 PM   #8
ithawtewrong
Member
 
Registered: Jul 2004
Location: Mile High
Posts: 161

Rep: Reputation: 30
Glad I could help out. I have noticed that it doesn't throttle all the time. I like to kick it up manually when I do updates or installs. The way to manually throttle is to click on the power cord icon on the system tray (near the system clock) and select Select CPU Frequency Policy then select Performance.

I would also suggest you take some time and peruse the Runlevel editor when you have some free time. I'm sure you'll find stuff in here that will tweak you system a little better and even make it a little more secure. (ie..ssh is probably enabled and you probably don't use it on a laptop). I have found lots of stuff by reading these forums over the past several months. The key is read, read, then read some more.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
suse 9.3 not recognizing raid array blackbeast Linux - Hardware 8 01-24-2006 12:44 AM
SUSE not recognizing hda luken SUSE / openSUSE 2 09-05-2005 11:16 AM
SuSE 9.2 install not recognizing hdd Jerman SUSE / openSUSE 2 05-06-2005 09:28 AM
SuSE 9.1 not recognizing file on cdrom tykkea811 SUSE / openSUSE 1 12-15-2004 05:25 PM
Recognizing 2nd Processor blfinche Linux - Newbie 1 01-01-2003 08:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration