LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 08-18-2004, 05:59 PM   #1
nbcthreat
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Rep: Reputation: 0
succesfully screwed up boot while messing with apm


While trying to get apm suspend working correctly with the PCMCIA card in my IBM TP X21, I seem to have broken Linux. I'm running SuSE 9.1

Here's what I get at boot, immediately after it activates the loopback interface (successfully)

Cleaning up using /sbin/modify_resolvconf: done
double fault, gdt at c01192el, esp = ce7ffffc
edx = ce7fe000, ebx = 00000000, ecx = 00000007b, edx = ce8000a0
esi = 00000000, edi = c0119260

and then it locks. Or it reboots.

Suggestions?
 
Old 08-19-2004, 08:58 PM   #2
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: Fedora (LXQT)
Posts: 276

Rep: Reputation: 30
if you have a linux bootdisk or cdrom, boot from it, if cdrom login as root, then make a dir in your ramdisk /oldroot, then mount your old root dir to it i.e.
mkdir oldroot
mount -t ext3 /dev/hda1 /oldroot
then goto /oldroot/etc and modify your lilo.conf to match an old copy of your kernel then run lilo to set it up. if you didn't modify your kernel, then goto /oldroot/etc and modify your rc.local if that is what you did to change your apm settings. Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screwed up boot TaNeK Linux - Newbie 11 12-10-2004 05:12 PM
apm vs. acpi ? (modprobe: FATAL: Error inserting apm) OneManArmy Linux - Laptop and Netbook 0 05-12-2004 04:39 PM
boot and X screwed up jalsk Linux - Newbie 3 04-12-2004 04:57 PM
Can't boot up Mandrake 9.0 after messing w/HardDrake mjdava Mandriva 6 04-01-2004 11:25 AM
apm screwed up after upgrade Delorian Linux - Hardware 1 05-11-2003 05:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 03:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration