LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   strange lockups... (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/strange-lockups-139347/)

pestilence 01-27-2004 04:22 PM

strange lockups...
 
I am running Mandrake 9.1 (which now has been slowly upgraded to a cooker devel version) on a Acer Travelmate 800 lci.
My problem is that during first day of my installation time to time i experience Lock ups in my X session...Lock ups occure with no warning or error output...and my mouse and system seems to keep on working.
More specific, my X Session freezes (everthing including animations + keyboard stop responding) but my mouse keeps on working.
The only way to deal with the lock up is to power off my laptop. When i reboot after the annoying checking when i log and check the logs i find nada...the only message appended in there is that my system was shutted down (like it was shutted down properly) but that ain't the case since i have to power off the laptop (maybe from the initial power off button touch i get this log entry).
Anyone experiencing the same? I though that this might be co-related with Java but i am unable to reproduce the lockup, another small hint i have is that this might be related with the ATI Mobillity card my laptop has...anyone else experiencing the same symptoms?
I though in the beggining that this might be related to apm...so apm is gone...but Lockups still exist...

Brian1 01-27-2004 04:47 PM

Give this a try, when it happens close the notebook for about 5 secs and reopen and see iff it returns. Best guesses here are the kernel and or hotplug ( relates to usb mostly ).

pestilence 01-28-2004 07:26 AM

Ok more on this...i just had my X session again Freezing some minutes ago...rebooted and here is the output of the logfiles:

/var/log/messages ->
Code:

Jan 28 14:29:59 pestilence shutdown: shutting down for system halt
Jan 28 14:29:59 pestilence init: Switching to runlevel: 0
Jan 28 14:31:43 pestilence shutdown: shutting down for system halt
Jan 28 14:33:13 pestilence last message repeated 3 times
Jan 28 14:54:59 pestilence syslogd 1.4.1: restart.

As you can see in this output my system was not actually frozen just my X session...the switching to runlevel 0 occured after i started pushing my power button...

Next:
/var/log/acpid ->

Code:

[Wed Jan 28 14:31:43 2004] executing action "/sbin/poweroff"
[Wed Jan 28 14:31:43 2004] BEGIN HANDLER MESSAGES
[Wed Jan 28 14:31:43 2004] END HANDLER MESSAGES
[Wed Jan 28 14:31:43 2004] action exited with status 0
[Wed Jan 28 14:31:43 2004] completed event "button/power PWRF 00000080 00000002"
[Wed Jan 28 14:31:44 2004] received event "button/power PWRF 00000080 00000003"
[Wed Jan 28 14:31:44 2004] executing action "/sbin/poweroff"
[Wed Jan 28 14:31:44 2004] BEGIN HANDLER MESSAGES
[Wed Jan 28 14:31:44 2004] END HANDLER MESSAGES

This is the acpid output...system is still working fine...except that everything is frozen...the signals are caught by pressing again the power button....

As you can see from my logs my system continues working as nothing ever happened...except that my screen is frozen and my keyboard....mouse keeps on working (i can move it around...but i can't click offcourse)...and the only way to handle this situation is by hard reboot...i can't aquire a console by swicthing from X...and i can't kill the X session...i just only can reboot...
Any ideas?

P.S WHEN THE LOCK UP OCCURS I CAN HEAR MY FAN STARTING AS SOMETHING HEAVY IS RUNNING ON THE SYSTEM, THE PROBLEM IS THAT THE LOCK UP DOES NOT OCCURE IF I FIRE AN APPLICATION OR A DEVICE IT JUST FREEZES SUDDENLY WITHOUT ANY SYMPTOMS... ATI PROBLEMS?


All times are GMT -5. The time now is 09:43 PM.