-   Linux - Laptop and Netbook (
-   -   Strange console behavior after exiting X (

rcrules 06-11-2004 01:57 AM

Strange console behavior after exiting X
I have a Compaq Presario R3140US laptop, running on a Gentoo install, which is giving me problems every time I exit. The screen is a 15.4" WXGA LCD, which uses really strange settings to get the resolution to the proper 1280x800 setting that it uses, and I figure that this might be worth mentioning, because whenever I close X, the console starts to look really crazy. All of the pixels on the screen are shifted down and two the left a litle, and the screen gets kind of dim, compared to what it once was. Also, the first character of each line is partially repeated in the right-hand margin that is created when this happens. It doesn't matter if you clear the screen output or if you switch to another terminal ([Alt]+[F1] through [Alt]+[F4]), too. I'm not using a framebuffer, too. I'm really not sure why this is doing this; the only way to fix it right now is just to reboot the entire system.
Thanks for any help!

mrjava 06-14-2004 04:53 PM

I also have the R3140US. Im using Mandrake 10. Im able to run @1024x768.
Im NOT starting X on bootup and the screen is fine. I startx , resulution, colors, display is great.

My problem is, when I choose to logoff, my console screen is all garbled.
I was looking for a fix for this when I came across your post.
Let me know if you find anything

Ryeguy_24 06-29-2004 09:50 AM

Identical problem - please help.

rcrules 06-29-2004 10:59 AM

This is just a guess, since i haven't got around to setting everything up for it, but, does anyone think that enabling a framebuffer on the console will fix anything? If the console and X are both running at the same resolution, could that possibly help at all, or would it make matters worse? other than that, I'm pretty much at a loss, myself... :confused:

CeljskiGrof 08-31-2004 06:17 AM

Same problem here! If i consider the Mandrake logo in the lower right portion of the screen, however, the console is not a "classical" text console. Is it possible to set it up as a "classical" text console, maybe that would help...

Ryeguy_24 08-31-2004 07:32 AM

Fixed the problem
I actually fixed it by downloading the new NVIDIA drivers. Works like a charm.

CeljskiGrof 09-06-2004 04:03 AM

Installed the 6111 NVIDIA divers, corrected the config but still the same type of problems (although the "disturbance" on the screen is different, now I can actually see the first couple of characters, but they're "huge"). I've got an Innovision NVIDIA GeForce Ti4200, Mandrake 10.

brgr88 05-20-2006 09:39 PM

Try command: setfont
I know I'm about 2 years late for this thread, but I had the same problem and some website suggested the 'setfont' command, and it worked just fine for me.

Oddly enough, this only happened if I used any of the "extended" VGA modes in LILO (vga=...), that is, anything higher than the normal value of 80x25 (I'd set mine to 80x50, but if I tried setfont in 80x60, my screen went berserk and I still had to reboot).

If you run LILO in "vga=normal" mode (the default), just typing 'setfont' should be fine. I run LILO in "vga=extended" (80x50) and the default 'setfont' will switch it back to 80x25 (font size 8x16, I believe). So, what I want is a font size of 8x8.

The fonts are stored in '/usr/share/kbd/consolefonts' and other places (see 'man setfont' for more details), so passing any one of those font names as an arg to setfont will give you that font. For me, the font iso08.08 seems to work just fine to get me back my 80x50 console, so:
# setfont iso08.08

I haven't looked too deeply into this, but if there's some sort of script that's used when X quits (maybe at the bottom of /usr/X11R7/startx?), then maybe the setfont command line can be placed there to restore as soon as you quit X.

All times are GMT -5. The time now is 02:09 PM.