LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 07-04-2004, 01:53 PM   #1
Corallis
Member
 
Registered: Jan 2004
Location: EST
Distribution: Slackware 10.0
Posts: 150

Rep: Reputation: 15
Sound card problems


Im pretty new to linux, but I just got a laptop (Dell 600m) a few days ago, and I set slackware linux up on it. The installation went pretty well, and most of the essential things are working, but Im still having some problems with a few things, namely my soundcard, wireless card, and mous wheel.

I just finished installing the alsa drivers, lib, and utils off of their website, but when I try to run alsamixer it says "No mixer elems found". Im not quite sure what this means. I tried this on my desktop, and it works fine.

The output from my lspci is:

00:00.0 Host bridge: Intel Corp. 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corp. 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 01)
00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 01)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [Radeon Mobility 9000 M9] (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet (rev 01)
02:01.0 CardBus bridge: O2 Micro, Inc.: Unknown device 7113 (rev 20)
02:01.1 CardBus bridge: O2 Micro, Inc.: Unknown device 7113 (rev 20)
02:03.0 Network controller: Intel Corp.: Unknown device 4220 (rev 05)


Does anyone have any idea what this means? If anyone could help Id really appreciate it. Thanks.

(Also if someone is feeling extra generous, I could use some help with my mouse... I have read that you need to edit your xf86config file, but I actually dont have one. All Ive got is an xorg.conf, but it looks pretty different from what its supposed to look like. Ive got a logitech wireless/optical 3 button usb mouse)
 
Old 07-04-2004, 03:28 PM   #2
PYREST
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Rep: Reputation: 0
You need to load up the intel8x0 module and the related modules. Follow the previous link and see if that helps.
 
Old 07-04-2004, 06:45 PM   #3
Corallis
Member
 
Registered: Jan 2004
Location: EST
Distribution: Slackware 10.0
Posts: 150

Original Poster
Rep: Reputation: 15
I followed that guide, and I still get the same message when I try to use the alsamixer command.
 
Old 07-05-2004, 02:56 PM   #4
Corallis
Member
 
Registered: Jan 2004
Location: EST
Distribution: Slackware 10.0
Posts: 150

Original Poster
Rep: Reputation: 15
Upgrading to kernel 2.6.7 solved this problem without me doing anything else.
 
Old 07-13-2004, 11:38 AM   #5
giddyupman
LQ Newbie
 
Registered: Nov 2003
Posts: 16

Rep: Reputation: 0
Did you get that mouse wheel thing figured out? That's one thing I think I can actually help with. I don't have the code right here (yeah my wireless card doesn't work --> can only use internet with EvilOS) but if you haven't figured it out I'll check it out and get back to you................. Later.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Blaster Sound Card problems idioticneophyte Linux - Hardware 17 02-01-2005 04:02 AM
problems with sound card ... melodious Linux - Hardware 0 11-16-2004 04:09 PM
sound card problems k0ncept0ne Linux - Hardware 3 10-26-2004 12:14 AM
Sound card problems pp_snake Linux - Hardware 1 04-07-2004 05:04 AM
Problems with sound card... zZeEkiEeZz Linux - Newbie 6 07-05-2003 05:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 11:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration