-   Linux - Laptop and Netbook (
-   -   Sony Vaio VGN-B1XP / sony driver question (

kentri9 12-27-2004 12:00 PM

Sony Vaio VGN-B1XP / sony driver question
Hey I'm trying to make Fn keys work on my Sony Vaio VGN-B1XP but have some problems...
the distro is FC2 with kernel 2.6.9-1.6_FC2.

I did as follows:

- downloaded from :

# rpmbuild -tb spicctrl-1.7.tar.bz2
# rpmbuild -tb sonypid-1.9.1.tar.bz2
# rpm -Uvh /usr/src/redhat/RPMS/i386/spicctrl-1.7-1.i386.rpm
# rpm -Uvh /usr/src/redhat/RPMS/i386/spicctrl-debuginfo-1.7-1.i386.rpm
# rpm -Uvh /usr/src/redhat/RPMS/i386/sonypid-1.9.1-1.i386.rpm
# rpm -Uvh /usr/src/redhat/RPMS/i386/sonypid-debuginfo-1.9.1-1.i386.rpm

# /sbin/modprobe sonypi

- I have tried to execute: # /dev/sonypi -D but it says it's not allowed. I have also
changed the permission for this file but the same result.

KDE can recognize the sony driver and I still can't adjust the screen brightness.
When I push Fn key + Function keys, it says e.g.: unhandled event: 13

I am a newbie and I have absolutely no idea what I am doing.
Can anybody tell me what I should do to make it work?

another question:

there is a patch available:

it says 'Loading the sony_acpi.ko module will create a /proc/acpi/sony directory....'
well, how do I do that???

thanks in advance

All times are GMT -5. The time now is 06:28 AM.