-   Linux - Laptop and Netbook (
-   -   Slackware Sound on Portege R200 (

MaNiFeX 11-08-2012 12:32 AM

Slackware Sound on Portege R200
Hi All,

Long time linux user, first time posting. At work, a coworker couldn't get this little laptop working, so I threw Slackware 14 on it just for fun. Lo and behold, I really like this little Toshiba Portege R200. The only problem I am having is that I can't get sound to work out through the speakers. I've seen others with this issue online, but from what I can tell, I've exhausted my options. So here we go:

Problem: Sound plays just fine through the headphones, but will not play through the internal speaker.
Hardware: Stock Toshiba Portege R200
Software: Slackware 14
Window Manager: KDE

The sound module is loaded into the kernel correctly from what I can tell. alsamixer displays the soundcard as:

Card: Intel ICH6
Module: Analog Devices AD1981B

I've read some people having problem with the headphone autosense, but I have the same performance on either setting. As well, it doesn't matter what my privilege level is, if I'm logged in as my normal user or root, the problem is the same.

Thanks for your help!


markush 11-10-2012 05:33 PM

Hello MaNiFeX, welcome to LQ,

could you please check which modules there are loaded with "snd" in their name, there should be more than one.

lsmod | grep snd
Which kernel did you install?

What does alsamixer show?


MaNiFeX 11-13-2012 01:35 PM

Hi Markus,

Thanks for helping me out! I installed the default Slackware kernel (the biggy.) The following is the output from lsmod:

snd_seq_dummy 1119 0
snd_seq_oss 24956 0
snd_seq_midi_event 4568 1 snd_seq_oss
snd_seq 41599 5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device 4276 3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss 33254 0
snd_mixer_oss 12984 1 snd_pcm_oss
snd_intel8x0 22636 2
snd_ac97_codec 89635 1 snd_intel8x0
snd_pcm 59013 3 snd_ac97_codec,snd_intel8x0,snd_pcm_oss
snd_page_alloc 5925 2 snd_pcm,snd_intel8x0
snd_timer 14798 2 snd_pcm,snd_seq
snd 43657 13 snd_timer,snd_pcm,snd_ac97_codec,snd_intel8x0,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_s eq_oss
soundcore 4570 1 snd
ac97_bus 834 1 snd_ac97_codec
Alsamixer shows the following:
Card: Intel ICH6
Chip: Analog Devices AD1981B

The mixer levels are at 70% and the Master, Master Main, Headphone and PCM are all unmuted. If I mute the headphones, or turn on Jack Sense, nothing comes out of the built in speakers.

The headphones still work like a charm.

Thanks in advance,


MaNiFeX 11-13-2012 01:37 PM

PS - the kernel version is 3.2.29-smp.

markush 11-13-2012 04:27 PM

mh, there's some other point. What happens when you plug the headphones off the computer? And what does alsamixer show?


MaNiFeX 11-13-2012 05:00 PM

Hi Markus,

If the headphones are unplugged, no sound is made at all... That's the crux of my issue. All the sound works just fine through the headphone jack, but when a headphone is unplugged, there is no sound routed to the built-in speakers.

The modules that are installed look correct, right?

When using alsamixer, the normal bars come up. By default, Jack Sense is off. It doesn't seem to matter if it is on or off. Is there something I should be looking for?

Here's some of the previous work I've looked at to try and get this to work: (en francais)

Thanks for your help,


markush 11-13-2012 05:01 PM

Yes, the modules look ok. I daubt that there's something wrong with the setup. It could also be a hardware-issue.


MaNiFeX 11-13-2012 05:06 PM

Hi Markus,

I'm pretty sure this is not a hardware issue. When it was running Windows, the speaker worked...

I saw in some of the articles listed above, that some people have tried a force-reload to get the sound to work. Also some say that the jack sense needs to be turned off. What do you think of the following?



The AC97 audio chipset works well with ALSA. However after ALSA is configured via alsaconf, "Line Jack Sense" and "Headphone Jack Sense" must be turned off or the internal speaker will not work. This can be accomplished via alsamixer.

The following Sound related kernel modules are needed for audio support:

Sound card support
Advanced Linux Sound Architecture
Sequencer support
Sequencer dummy client
OSS PCM (digital audio) API
OSS Sequencer API
RTC Timer support
Dummy (/dev/null) soundcard
Virtual MIDI soundcard
MOTU MidiTimePiece AV multiport MIDI
UART16550 serial MIDI driver
Generic MPU-401 UART driver
Intel/SiS/nVidia/AMD/ALi AC97 Controller


markush 11-13-2012 05:21 PM

Well, do you have the OSS modules loaded? maybe you try to load them manually with modprobe (as root of course).


MaNiFeX 11-13-2012 05:25 PM

Hi Markus,

OK. I'll give that a try and let you know how it goes. Thanks for the help.


markush 11-13-2012 05:30 PM

Don't forget, when alsamixer is running, to press F2 in order to get more information! Check if there are other settings available in alsamixer which you don't see at first sight!


MaNiFeX 11-13-2012 06:17 PM

I haven't loaded the OSS modules yet, but pressing F2 in alsamixer gives me a lot more information. I see plenty of capture/playback devices, but am not sure what to do with that information.



rokytnji 11-13-2012 10:48 PM


808624c5 Yes Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller snd-intel8x0 kernel-version 2.6.25-

driver used is snd-intel8x0. Yes, means it works in sound.

which you show


snd_intel8x0 22636 2
So probably a setting is turned off like speakers in alsamixer (F5 gives me all settings in Alsamixer, I guess F2 is for Slackware).

might want to post


cat /var/lib/alsa/asound.state
also to beef up the thread maybe.

MaNiFeX 11-14-2012 11:27 AM

Thanks rokytnji,

Just to clarify what I see in alsamixer: F5 gives me all my output and input devices on the screen with sliders, mute, etc. F2 gives me a list of files with a variety of what looks to be hardware addresses, flags, or settings.

I left my machine at home today, so I'll have to post the output of asound.state when I get off of work. I've been using slackware since 1998 and have usually had no problem with the sound, so I guess I get to use this as a learning opportunity!

PLease remember, I just installed Slackware 14 on this puppy, so it's running kernel version 3.2.29-smp. I don't know if this affects the sound modules or not.



markush 11-14-2012 11:43 AM

Referring to your post #8 in this thread, I cannot find

MOTU MidiTimePiece AV multiport MIDI
in the kernel. But I don't know what this is, the other modules you've listed are available in the stock-Slackware-14-kernel


All times are GMT -5. The time now is 03:34 AM.