-   Linux - Laptop and Netbook (
-   -   Slackware 13.0 Apple MacBook Pro (

Zackney 10-24-2009 01:57 AM

Slackware 13.0 Apple MacBook Pro
Hello, I am running Slackware 13.0 64-bit on my Apple MacBook Pro with the following specs

MacBook Pro:

Model Identifier: MacBookPro5,3
Processor Name: Intel Core 2 Duo
Processor Speed: 2.8 GHz
Number Of Processors: 1
Total Number Of Cores: 2
Memory: 4 GB
Bus Speed: 1.07 GHz
Graphics: NVIDIA GeForce 9400M
Wireless Card Type: AirPort Extreme
Wireless Card Firmware Version: Broadcom BCM43xx

I come seeking help on several issues they are as followed:

1. Mouse doesn't work at all, I don't use KDE I have Fluxbox
I have tried several different mouse drivers and I don't get any response.
2. Backlight has no response
I don't expect the function keys to work obviously but the LCD needs to have a controller somewhere and I can't find it. My friend who is a Slackware user for almost eight years now wrote a script for his Thinkpad because when ever he changes windows in Stumpwm the LCD brightness gets reduced to nothing. Him and I could not locate a device at all.
3. Power consumption
Slackware sitting idle will burn my entire battery charge in almost two hours, OS X lasts all day. I don't have the know how to change/regulate any power settings.
If anyone currently has any Ideas on how to address any of the problems I would love to hear what you have to say. I have looked at the forum up and down but can't seem to find a thing. Maybe the problems just need a fresh set of eyes, if you need more information I would be happy to post any follow up.

Thanks a lot

xeleema 10-24-2009 03:06 AM


I might be able to help on the mouse-front. First a few basic questions;
1. Does it work when Fluxbox isn't running? In console-land?
2. Is gpm running?
3. Are you running the default kernel for Slackware 13? (If you're not sure, the answer's probably "Yes")
Type "uname -a" and post the output. It might contain something like

The first goal would be to get "gpm" working correctly in console-land. Try running /usr/sbin/mouseconfig.

Once you have a working mouse in console-land, we can move on to X.
Make a quick copy of the following files;
/etc/xorg.conf (if it exists)
Now run the following whilst in your home directory, then check the "~/Xorg.conf" it creates to see if there's a mouse section;
Xorg -configure
If it does, copy it over to /etc/ and fire up X!
Hope that helps. :)

Zackney 10-24-2009 12:09 PM

xeleema, I am running the default kernel. As for the console-land I boot into tty1 unless I start X I don't even get a pointer on the screen. I will try what you suggest and let you know how it works.
Thank you

All times are GMT -5. The time now is 06:35 PM.