-   Linux - Laptop and Netbook (
-   -   sensors output doesn't show cpu fan on laptop... (

micro. 01-20-2011 01:54 PM

sensors output doesn't show cpu fan on laptop...
I have fedora 13 installed (upgraded from fedora 12) and at some point after an update my cpu fan NEVER runs at full speed and sometimes the machine shuts down as a result of high cpu temps. I have lm-sensors installed and the output of sensors is:

# sensors
Adapter: Virtual device
temp1: +64.0C (crit = +105.0C)

Adapter: PCI adapter
temp1: +73.2C (high = +70.0C)

I've looked at many forums and googled how to get the cpu fan to run faster (it is running, just not at very fast) but I'm still having problems finding the information I need. I did configure lm-sensors by running 'sensors-detect' as root. I also installed ksensors (a KDE frontend to lm-sensors) and adjusted the options to have the 'ideal' temp down to about 140 but the fan still doesn't run any faster.

I've also looked in the BIOS to disable any 'cool and quiet' that it might have but didn't see any.

System is a Toshiba a505d-s6958 laptop running an amd processor.

I've attached output from dmesg.

What might I need to do? Thanks for any help...

corbintechboy 01-20-2011 02:23 PM

Might be very well that Linux itself is shutting the computer down due to heat.

The k10 CPUs have a borked sensor! What the sensor does is try and give a low and high reading that seems to work fine in Windows but lm_sensors don't deal with a sensor that gives an approximate value.

I have a Quad K10 in my laptop and have learned that is I minus 8-10 degrees from the output of the sensor that I hit the temp right about on the nose (basing figures on when I used Windows (which I run Linux solo now)).

The BIOS should be able to handle fan speeds without any intervention. As a matter of fact messing with fan speeds is really a bad thing, we tend to panic when there really is nothing to panic over. Let the BIOS handle the fan and find a way to deal with the borked sensor.

I use a script on mine...

H_TeXMeX_H 01-20-2011 02:57 PM

Another thing is make sure you have the modules 'fan', 'processor', and 'thermal' inserted. They probably already are tho. Maybe try cleaning out the dust.

micro. 02-05-2011 03:14 PM

@ H_TeXMeX_H - So when I run 'modprobe -l fan' I should get some kind of output, right?

@ corbintechboy - How would I go about making sure the BIOS has control over the cpu fan? I'm also not sure where to start with dealing with the sensor...

Thanks for your help, guys.

H_TeXMeX_H 02-05-2011 03:36 PM

You will get output if fan is a module, if it is built in, then no output. You would have to check your kernel config in that case.

micro. 02-22-2011 05:47 PM

Just a heads up, I own a PC and laptop repair and servicing company so I always make sure my machines are clean. ;-) Here's the latest after having been busy moving into a new place and working a bunch of hours...

I have a snippet from dmesg.

ACPI: Fan [FAN1] (off)
thermal LNXTHERM:01: registered as thermal_zone0
ACPI: Thermal Zone [THZN] (77 C)

acpi device:02: registered as cooling_device3

When I searched for 'fan' in the kernel config file I found:



That's it. It would appear that it is built in. Btw, since I have installed ksensors and have both the acpitz and the k10 sensors set 'ideal' to 130 degrees and 'max' at 145 degrees. (obviously Fahrenheit) So far, so good but I was seeing temps up to 153 degrees before it appeared that the settings actually stuck. I will continue to monitor it and, if all continues to go well, I will set this thread as solved...

I appreciate the help.

All times are GMT -5. The time now is 06:25 PM.