Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).


  Search this Thread
Old 07-20-2010, 02:03 AM   #1
LQ Newbie
Registered: Feb 2010
Location: Norrköping, Sweden
Distribution: Debian
Posts: 9

Rep: Reputation: 1
Question screensavers and backlight


I have noticed that the backlight is not switched off when the blank screensaver is activated on my laptops and netbooks using Ubuntu and Debian. Why is that? This must be a very good way to save battery. Is it a hardware thing or is it just me not getting the settings right?

Old 07-20-2010, 04:33 AM   #2
LQ 5k Club
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,576
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
Which desktop are you using ... Gnome, KDE, Xfce ... ?
Old 07-21-2010, 01:48 AM   #3
LQ Newbie
Registered: Feb 2010
Location: Norrköping, Sweden
Distribution: Debian
Posts: 9

Original Poster
Rep: Reputation: 1
Gnome and LXDE at the moment and Xfce in the past.

Old 07-22-2010, 03:52 PM   #4
Registered: Mar 2010
Distribution: Debian
Posts: 180

Rep: Reputation: 31
You could use Gnome power manager, or KPowersave (that is the one I use) KPowersave has a panel applet that you can left click on to configure it. You should be able to set it to use DPMS to shut your screen off when the computer is inactive.
Old 07-23-2010, 06:10 AM   #5
William (Dthdealer)
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Rep: Reputation: 19
If you are using Gnome:

AFAIK the blank screensaver is not intended to turn the screen off, just to provide a fallback if no other screensavers are installed or if the warm-up time on your monitor is long but burn-in is a problem.

If you want to save power, as alan99 said then use the 'Put display to sleep when inactive for' feature in Gnome Power Management ( System --> Preferences --> Power Management --> On Battery Power Tab ).

Last edited by William (Dthdealer); 07-23-2010 at 06:11 AM. Reason: Added gnome line


backlight, battery, screensaver

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Backlight control Daemon- Linux - Laptop and Netbook 0 03-03-2008 02:38 PM
backlight problem on pc linux os rahul_goutam Linux - Laptop and Netbook 3 01-25-2008 09:43 AM
radeon backlight eggoz Linux - Software 1 09-06-2005 10:32 AM
No Screensavers. Screensavers Diaspearerd! raid517 Linux - Software 1 04-23-2005 01:32 AM
[ibook G4] Screen backlight always on kemkem Linux - Laptop and Netbook 1 11-14-2004 12:49 PM > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 05:12 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration