-   Linux - Laptop and Netbook (
-   -   Screen resolution on Sony Vaio with dead Radeon chip (

isopodz 11-28-2009 11:02 PM

Screen resolution on Sony Vaio with dead Radeon chip
Hello Linux folk
I have a Sony Vaio VGN-S28GP where the Radeon chip packed it in last year. I have installed Ubuntu 9.04 and it works fine in the default vesa failsafe setup, but is stuck at 800x600, although the display area can be 1280x768. In XP I can get 1024x800. Does anyone have any suggestions about how to bump up the display resolution?

Here's a few diagnostics:

lspci | grep -i vga
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]


$ sudo xrandr --verbose

Screen 0: minimum 640 x 480, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 (0x102) normal (normal) 0mm x 0mm
        Identifier: 0x101
        Timestamp:  18547
        Subpixel:  unknown
        CRTC:      0
        CRTCs:      0
        Panning:    0x0+0+0
        Tracking:  0x0+0+0
        Border:    0/0/0/0
        Transform:  1.000000 0.000000 0.000000
                    0.000000 1.000000 0.000000
                    0.000000 0.000000 1.000000
  800x600 (0x102)  29.3MHz *current
        h: width  800 start    0 end    0 total  800 skew    0 clock  36.6KHz
        v: height  600 start    0 end    0 total  600          clock  61.0Hz
  640x480 (0x103)  18.4MHz
        h: width  640 start    0 end    0 total  640 skew    0 clock  28.8KHz
        v: height  480 start    0 end    0 total  480          clock  60.0Hz

Any suggestions gratefully received.

MrCode 11-29-2009 12:58 AM

If you can, could you post the contents of your /etc/X11/xorg.conf file? It might just be a matter of adding the resolution you want to the list of modes there.

isopodz 12-06-2009 01:46 PM

Thank you for the suggestion. I installed Jaunty (kernel 2.6.28-16) in failsafe mode and it seems to be only able to do 800x600. I've tried a range of changes to the xorg.conf file. Some that try to access the Radeon chip crashes the display. Most changes, that look legal, cause the xorg.conf to not be read correctly - it seems to hate any changes I make to the file. I was hoping for a way to reconfigure the failsafe mode.


Section "Device"
Identifier "Configured Video Device"
Driver "vesa"

Section "Monitor"
Identifier "Configured Montor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Montor"
Device "Configured Video Device"

isopodz 01-30-2010 05:20 PM

Update on thread. I decided to upgrade the Sony Vaio with the dead Radeon chip to Karmic (9.10). The failsafe screen is now 1024x768, which matches what xp does. I have tried a series of xorg.conf settings using the "headless" setup in "Linux Format" LXF128, p.104-105. Of course the

get-edid | parse-edid
command didn't work, because the Radeon chip is dead. If I insert what appears to be the correct settings for a widescreen sony vaio below in the Monitor section of xorg.conf, I get the segmentation fault that happens when an attempt is made to access the dead radeon chip.


Mode "1280x800_60.00"
# 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
DotClock 83.46
HTimings 1280 1344 1480 1680
VTimings 800 801 804 828
Flags "-HSync" "+Vsync"
The xorg log shows that the glx drivers are loaded, which is the probable cause of the segfault, even though I have quoted out the glx module in xorg.conf.

So at this point, I don't have anything further that I can think of, unless someone knows how to change the default settings in the debconf database for the failsafe option, or can think of another approach. At least now under Karmic, the screen is a usable size, even though I lose the widescreen and a thin line at the top and bottom. So for once, an Ubuntu upgrade fixed something instead of borking a half dozen things that worked in the previous version.

isopodz 01-30-2010 05:37 PM

Follow-up on previous. I got into the bios and found a setting called

expand LCD
that I changed from no to yes. Now the OS thinks the monitor is only 1024x768, but the bios expands it to the full screen. Some clarity is lost but now all of the screen is used. I can now use this laptop for email and websurfing.

All times are GMT -5. The time now is 11:59 PM.