LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 12-18-2009, 07:04 AM   #1
trafikpolisen
Member
 
Registered: Jun 2008
Posts: 96

Rep: Reputation: 1
Screen goes blank after reboot (xubuntu on Asus X51)


My laptop, an Asus X51R seems to be allergic to linux. I have tried several of the major distributions and i have various problems with all of them, some not working att all. I have now settled for Xubuntu, and things seems to be working fine except for one little thing. When i choose "Log out" and then "Restart", my computer shuts down, reboots and just before entering the xubuntu splash-screen, the screen goes completely blank and the computer stops working. The only thing to do is pressing the power button for 4 seconds. When i start again xubuntu starts with no problem.
If i choose "Log out" and then "Shutdown" instead, my computer shuts down, and after starting it again xubuntu boots fine. So it's just when i choose "Restart", that it freezes.

edit: After not having been able to start for two or three times in a row (blank screen and at least one time with the hd-led lit with drive apparently doing no work), it now seems to work every time. The only change i made was to edit the Grub configuration to remove the "quiet splash", to maybe be able to see what happens. Weird..

Last edited by trafikpolisen; 12-18-2009 at 07:16 PM.
 
Old 12-19-2009, 03:48 PM   #2
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: Slack14.2/Many
Posts: 5,573

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
you might want to also install anything lappy specific
like ubuntu-laptop-mode
or laptop-mode
laptop-tools,etc
most likely its got to do with acpi,etc

go get your xubuntu sources.list setup too
and enaable all your repos for best software
http://repogen.simplylinux.ch/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
why do I always get a blank screen when I'm try to log into xubuntu? Mac_09 Linux - Software 6 07-13-2008 06:20 AM
Blank screen on reboot after compiling 2.6.18.1 cdale77 Slackware 3 11-03-2006 01:57 PM
blank screen on gentoo reboot blurhappy Linux - Newbie 1 08-31-2004 08:54 PM
Blank screen after reboot diesel Linux - General 1 04-04-2004 02:53 PM
Blank screen on reboot after 2.6 compile Myrkul23 Slackware 1 01-11-2004 12:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 02:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration