-   Linux - Laptop and Netbook (
-   -   resolution too low (

cspclay 03-09-2005 01:49 AM

resolution too low
I am not entirely new to the linux world, I have been "tinkering" with it for a while now but I have just recently gotten into using it alot and I am currently making the transition from windows to linux on all of my computers. So far I have had very little trouble except with my laptop. I have a Gateway M305CRV laptop. Specs are as follows :
Intel P4 2.2ghz
512 mb DDR PC2100
30 gig HD
Intel 852GM chipset with integrated LAN, Audio, and Video cards.
Integrated Actiontec Wireless 802.11G LAN card
CD Rom drive
5 in 1 card reader

I am running Suse Linux 9.2 Professional. I managed to configure ndiswrapper and get my wireless network adapter runnign fairly easily. The audio card was detected and configured on boot with little help from me. The integrated intel LAN card was detected and loaded properly out of the box as well. My only problem is I cannot get my resolution to go any higher than 800x600 or 640x480. Upon the first loading of Suse, the video card was detected as an Intel 855GM video card and the monitor was set to the basic Vesa 800x600 setting. I downloaded the newest set of linux drivers for the 852/855 video cards from the Intel website and installed and configured them. I followed the directions precisely and when i was finished installing them i had extra features enabled but was still unable to increase my resolution beyond 800x600. I tried updating X to the newer 6.8.2 but this did not help out either. After updating X, i reinstalled the intel drivers and reconfigured everything all over again and but still the problem remains. I began editing my XF86Config file trying to resolve the issue but have had no success. I have a second desktop computer running Suse 9.2 as well and i compard the two different XF86Config files and found only relatively minor differences. My LCD monitor on my laptop is capable of running 1024x768 resolution at 32 bits, but so far the best i have been able to obtain is 800x600 at 24 bits. If anyone has any insight into this i would be extremely grateful for any help what-so-ever. Thank you in advance for anyone responding.

Clay Powell

masand 03-09-2005 04:34 AM

what editing did u try in XF86Config file???
did u change the horizontal/vertical settings


shpishay 03-09-2005 01:10 PM explains the problem as best as I can find. It's an issue that I, too, would definately like fixed.

Just found this:

I'll try it out tonight and let you know if it works if you don't beat me to it.

cspclay 03-09-2005 02:17 PM

i already tried the link you gave me to the 855patch. it did not work for me. the way the problem is decribed there it makes sense why the video card will not go to a higher resolution and i believe that may very well be my problem but i cant figure out how to get linux to increase the video memory. the bios default for itis 8mb, but i cant change it in the bios. wheni had windows on it the driver's properties page allowed me to adjust the amount of memory alloted to the video card itself. i tried that 855patch and set it up to load on boot but it did nothing to help with my resolution. in the xf86config file i tried adjusting the different modes available to the monitor, i added viewport settings that were missing, changed the settings around for my synaptics touchpad toget rid of that annoying tap click and make my scroll wheel work right, i adjusted the vertrefresh and hsync rates as well. I am at work currently and can not post my file or i would just to let someone get a look at it and perhaps see something im missing. however as i stated in my original post i have a second computer running suse 9.2 and i compared the two different xf86config files and found very few differences. on the video card and monitor sections the only difference i found was on my laptop i have the intel card and with the i810 drivers for it and LCD monitor. on my desktop with suse 9.2 the file dhowed generic S3 for the video card and generic vesa drivers for the monitor. I tried changing my settings on my laptop to the same as the ones on my desktop and it did absolutely nothing. Thank you to all trying to help i appreciate your feedback and responses.

curleyg 03-09-2005 04:25 PM

I was having the same problem with an IBM 600E. After cursing cussing and fussing for a few hours, I stumbled on seting the colors to "thousands of colors" V. "millions of colors". I then had the options of raising the resolution. I don't notice any degradation on the lcd.

cspclay 03-10-2005 12:10 AM

when i first installed suse on this laptop the default setting was thousands of colors and the resolution didnt work then either. my card is capable of running 1024x768 at 32 bit resolution. in linux the highest i can set the color setting is 24 bit and i cant even get the 1024x768 i want. im not too worried about only being able to get 24 bit color instead of 32 bit, i do however want my 1024x768 back. I only have a 15" screen and this 800x600 sucks majorly. thank you for the response and suggestion though.

J.W. 03-10-2005 01:55 AM

Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

Please post any replies to this thread Thanks -- J.W.

All times are GMT -5. The time now is 03:27 PM.