LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 12-18-2006, 06:22 PM   #1
linuxnewby34
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Rep: Reputation: 0
Unhappy Resolution messed up Fedora Core 6 Intel 915GM


A few days ago i installed fedora core 6 on my laptop:
packardbell easynote s4815
Mobile IntelŪ PentiumŪ M - 725A - 2MB L2 Cache - 1,6Ghz
512MB Geheugen
Intel 915GM
50GB HDD
After installing the resolution was 1024x768 i tried to change it but i messed it up now my monitor thinks it is an 1024x768 even the bios reconizes it as a 1024x768 while the native resolution was 1280x800 now i can't get it to 1280x800 not in windows not in the bios and not in linux. I tried already tried the 915resolution patch and also inserted a modline into xorg.conf. Can anyone help me please!!!

this is displayed in the xorg.0.log file
(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): Primary V_BIOS segment is: 0xc000
(II) I810(0): VESA BIOS detected
(II) I810(0): VESA VBE Version 3.0
(II) I810(0): VESA VBE Total Mem: 7872 kB
(II) I810(0): VESA VBE OEM: Intel(r)915GM/910ML/915MS Graphics Chip Accelerated VGA BIOS
(II) I810(0): VESA VBE OEM Software Rev: 1.0
(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
(II) I810(0): VESA VBE OEM Product: Intel(r)915GM/910ML/915MS Graphics Controller
(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) I810(0): Integrated Graphics Chipset: Intel(R) 915GM
(--) I810(0): Chipset: "915GM"
(--) I810(0): Linear framebuffer at 0xC0000000
(--) I810(0): IO registers at addr 0xB0080000
(II) I810(0): 2 display pipes available.
(II) I810(0): detected 7932 kB stolen memory.
(II) I810(0): Kernel reported 110080 total, 1 used
(II) I810(0): I830CheckAvailableMemory: 440316 kB available
(II) I810(0): Will try to reserve 32768 kiB of AGP aperture space
for the DRM memory manager.
(II) I810(0): Monitoring connected displays enabled
(II) I810(0): Will attempt to tell the BIOS that there is 12288 kB VideoRAM
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/lib/xorg/modules/libint10.so
(II) I810(0): initializing int10
(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): Primary V_BIOS segment is: 0xc000
(II) I810(0): VESA BIOS detected
(II) I810(0): VESA VBE Version 3.0
(II) I810(0): VESA VBE Total Mem: 12288 kB
(II) I810(0): VESA VBE OEM: Intel(r)915GM/910ML/915MS Graphics Chip Accelerated VGA BIOS
(II) I810(0): VESA VBE OEM Software Rev: 1.0
(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
(II) I810(0): VESA VBE OEM Product: Intel(r)915GM/910ML/915MS Graphics Controller
(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) I810(0): BIOS now sees 12288 kB VideoRAM
(--) I810(0): Pre-allocated VideoRAM: 7932 kByte
(==) I810(0): VideoRAM: 65536 kByte
(==) I810(0): video overlay key set to 0x101fe
(**) I810(0): page flipping disabled
(==) I810(0): Using gamma correction (1.0, 1.0, 1.0)
(II) I810(0): BIOS Build: 1225
(==) I810(0): Device Presence: disabled.
(==) I810(0): Display Info: enabled.
(II) I810(0): Broken BIOSes cause the system to hang here.
If you encounter this problem please add
Option "DisplayInfo" "FALSE"
to the Device section of your XF86Config file.
(II) I810(0): Display Info: CRT: attached: FALSE, present: TRUE, size: (720,400)
(II) I810(0): Display Info: TV: attached: FALSE, present: TRUE, size: (1024,768)
(II) I810(0): Display Info: DFP (digital flat panel): attached: FALSE, present: FALSE, size: (0,2059)
(II) I810(0): Display Info: LFP (local flat panel): attached: TRUE, present: TRUE, size: (1024,768)
(II) I810(0): Display Info: Second (second CRT): attached: FALSE, present: FALSE, size: (0,2059)
(II) I810(0): Display Info: TV2 (second TV): attached: FALSE, present: FALSE, size: (0,2059)
(II) I810(0): Display Info: DFP2 (second digital flat panel): attached: FALSE, present: FALSE, size: (0,2059)
(II) I810(0): Display Info: LFP2 (second local flat panel): attached: FALSE, present: FALSE, size: (0,2059)
(II) I810(0): Size of device LFP (local flat panel) is 1024 x 768
(II) I810(0): No active displays on Pipe A.
(II) I810(0): Currently active displays on Pipe B:
(II) I810(0): LFP (local flat panel)
(II) I810(0): Lowest common panel size for pipe B is 1024 x 768
(==) I810(0): Display is using Pipe B

Last edited by linuxnewby34; 12-18-2006 at 06:23 PM.
 
Old 12-19-2006, 04:35 PM   #2
chrisortiz
Member
 
Registered: Nov 2005
Distribution: Slackware, and of course the super delux uber knoppix universal live recovery cd
Posts: 429

Rep: Reputation: 30
if the problem is both in windows and linux, i would suggest updating, or reflashing the bios.
From what you just posted, it looks like the lcd is being detected as 1024x768 just like you said

Quote:
Will attempt to tell the BIOS that there is 12288 kB VideoRAM
definately update the bios.
I would also switch from VESA to FBDEV in X11.conf
 
Old 12-20-2006, 06:48 AM   #3
linuxnewby34
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I Already tried a bios update but that didnt worked, but where can i find the x11.conf or do you mean xorg.conf if it is xorg.conf where do i change vesa to fbdev?

Here is my xorg.conf file:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1280x800"
ModeLine "1280x800" 68.9 1280 1301 1333 1408 800 804 808 816 -hsync -vsync
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 12-20-2006, 07:02 PM   #4
chrisortiz
Member
 
Registered: Nov 2005
Distribution: Slackware, and of course the super delux uber knoppix universal live recovery cd
Posts: 429

Rep: Reputation: 30
Code:
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
add 1280x800 infront of 1024x768 in Modes

if that doesn't work
Code:
Section "Device"
        Identifier  "Card1"
        Driver      "i810"
        VendorName  "Intel Corp."
change driver "i810" to driver "fbdev"
it will use the same display driver the kernel does.
 
Old 12-21-2006, 07:16 PM   #5
linuxnewby34
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I changed the driver to a fbdev driver but then the xserver won't start i get an error saying could not select screen0 i also added 1280x800 resolution but still it doesn't work i think it is an problem with the vbt tables of the video bios but i'm not for sure

Last edited by linuxnewby34; 12-21-2006 at 07:18 PM.
 
Old 12-21-2006, 08:26 PM   #6
chrisortiz
Member
 
Registered: Nov 2005
Distribution: Slackware, and of course the super delux uber knoppix universal live recovery cd
Posts: 429

Rep: Reputation: 30
take out the fbdev entry. i must have misread info on fbdev.
 
Old 12-22-2006, 06:55 PM   #7
linuxnewby34
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I don't know what to do now do you have any solutions left?
 
Old 12-22-2006, 07:07 PM   #8
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 3,016

Rep: Reputation: 836Reputation: 836Reputation: 836Reputation: 836Reputation: 836Reputation: 836Reputation: 836
Take a breath.

You should have backed up your xorg.conf before you changed it. If you did just overwrite the new one and you'll be back to functional. If you did not then open xorg.conf in a CLI text editor and put it back the way it was.


Then when you get X working again you may try

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x800"
EndSubSection
EndSection

If that won't work then drop the default depth down to 16 bits per pixel.

You can also run as root
xorgconfig

Answer the questions with the correct values. Back up xorg first. No prob if you screw it up. just overwrite it with the good saved xorg.
 
Old 12-25-2006, 05:35 AM   #9
linuxnewby34
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Original Poster
Rep: Reputation: 0
@teckk

I changed the xorg.conf file to how it was before but when i changed it the color depth and the resolutions x says no screens found!
 
Old 12-25-2006, 07:54 AM   #10
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 3,016

Rep: Reputation: 836Reputation: 836Reputation: 836Reputation: 836Reputation: 836Reputation: 836Reputation: 836
1024x768 may be the best that you are going to get with that machine. You are editing xorg as root? The file wont changes if you edit it as user.

Put the xorg.conf back the way it was when it worked.
If you can't then run as root
Code:
xorgconfig
Use some meager values just to get X working. Then save that xorg somewhere. Then you can experiment with more resolution or depth. Or run xorgconfig several times changing things until you get what you want.

Also once you get X running in Fedora you can run I think it is
Code:
system-config-display
And tweak your display.

Once you get X working though save a copy of it so you can overwrite it when you mess it up tweaking.
 
Old 12-26-2006, 11:47 AM   #11
linuxnewby34
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I logged in as root when i changed the xorg.conf the changes took effect but not a good effect i can't get back to my native resolution (1280x800). I messed it up with a wrong driver now i get 1024x768 not only in linux but also in the bios and in windows. I tried to install the software that came with my computer but i still get the 1024x768 resolution. I'm looking for a way to change the vbt tables of the video bios i think when i changed that my notebook will work just the way it did before my only question is how?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 5 on laptop with 915GM evanwilson6 Linux - Laptop and Netbook 1 06-04-2006 01:38 PM
xorg.conf wanted for Intel 915GM display adapter on Dell D610 running on Fedora 3 syseeker Linux - Software 11 04-27-2006 01:02 AM
Intel 915GM idgeitman Linux - Laptop and Netbook 2 04-18-2006 06:05 AM
need information about Intel 915GM and intel 945 graphics chipsets mechmg93 Debian 1 04-15-2006 06:53 AM
Suse 9.3 Dell D610 Intel 915GM Cannot change resolution vancew22 Linux - Laptop and Netbook 7 10-06-2005 07:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration