LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 09-18-2003, 11:39 AM   #1
demise213
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Rep: Reputation: 0
Question Redhat Video Problems on a Thinkpad 600x


I've recently installed RedHat 9 on my old Thinkpad 600x and can't get the video out of 800x600 and into 1024x768 mode. Anyone had this problem? Suggestions for fixes?

Please be as detailed as possible as I'm still learning linux.

K

Last edited by demise213; 09-22-2003 at 05:47 PM.
 
Old 09-18-2003, 03:58 PM   #2
randomblast
Member
 
Registered: Aug 2003
Location: Manchester, England, UK, The World....
Distribution: Gentoo/SuSE 9.0
Posts: 291

Rep: Reputation: 30
sorry, opera screwed it up, ignore this post

Last edited by randomblast; 09-18-2003 at 04:03 PM.
 
Old 09-18-2003, 04:01 PM   #3
randomblast
Member
 
Registered: Aug 2003
Location: Manchester, England, UK, The World....
Distribution: Gentoo/SuSE 9.0
Posts: 291

Rep: Reputation: 30
Does your laptop monitor support 1024x768?
If so, and i'm assuming you're talking about X here, you need to press [alt] + F2 and type redhat-config-xfree86 which brings up a window which will let you change your resolution
 
Old 09-18-2003, 04:30 PM   #4
demise213
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Yes, the monitor supporst 1024x768. Looked great under WinXP. When I go and change the resolution in the redhat configurator, it asks me to reboot or restart X. I do so and it's still in 800x600. It has the correct video card detected, but is using "unprobed monitor". Could this be the issue? Thanks a ton!

K
 
Old 09-21-2003, 11:35 AM   #5
randomblast
Member
 
Registered: Aug 2003
Location: Manchester, England, UK, The World....
Distribution: Gentoo/SuSE 9.0
Posts: 291

Rep: Reputation: 30
Hmm, is your machine a 600x or a 900x?
You should go to /etc/X11/XFree86Config and make sure 1024x768 is listed under you video settings.

Another option is to try sending the kernel option vga=0x305 at bootup and see if that helps. (if your using lilo you should type linux vga=0x305 (linux being whatever boot image name you gave it))
 
Old 09-21-2003, 07:13 PM   #6
demise213
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Yah, it's a 600X.

Ouch, it is a 600x. I think I was so happy to get the build done (save the video) that I didn't pick it up when I proofread. Still no luck with the video workin' correctly.
 
Old 09-22-2003, 04:12 PM   #7
randomblast
Member
 
Registered: Aug 2003
Location: Manchester, England, UK, The World....
Distribution: Gentoo/SuSE 9.0
Posts: 291

Rep: Reputation: 30
Hmm, post your XF86Config here (/etc/X11/XF86Config) there is a sample XF86Config for a 600x here but i don't think it'll work with your distro.
 
Old 09-22-2003, 04:46 PM   #8
demise213
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
My XF86Config

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "neomagic"
VendorName "Videocard vendor"
BoardName "NeoMagic MagicMedia 256ZX (laptop/notebook)"
Option "externDisp" ""
Option "internDisp" ""
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 09-23-2003, 10:44 AM   #9
randomblast
Member
 
Registered: Aug 2003
Location: Manchester, England, UK, The World....
Distribution: Gentoo/SuSE 9.0
Posts: 291

Rep: Reputation: 30
Yes, you need to edit the bit near the bottom where it says

Depth 16
Modes "800x600" "640x480"
EndSubSection
EndSection

to
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Then use redhat-config-xfree86 to change your resolution, restart the X server and it should hopefully be fine.
 
Old 09-23-2003, 05:09 PM   #10
demise213
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
So edited the file as required, set the resolution, rebooted, and it came back as 800x600. I'm positive I edited the file correctly. Am I doing something wrong here?
 
Old 09-23-2003, 06:04 PM   #11
Macguyvok
Member
 
Registered: Sep 2003
Location: NewYork - Fredonia - USA
Distribution: MDK 10; SuSE 9.0; Gentoo
Posts: 79

Rep: Reputation: 15
Well, just checking, did u edit the file as root? Does the file still show the changes? I'm not sure baout with that distro, but I do know with Mandrake 9.1&9.2 RC2 or Redhat 8&9 you can choose "generic laptop display 1024x768" when you're setting it up. However, what's been said about editing the XF86Config should work for you, however, make sure you edit the fiel as root, and that you save it. Even then, re-open the file to make sure the changes took place. I know it might sound stupid to you, but I've done it myself a few times, and occasionally changes just wouldn't take the first time around. You also might want to try editing it from console mode ("init 3" as root). You can get back to X by either saying "startx" or "init 5". Also, as a sde note, if you need to restart the X server, without reboots, ctrl + alt + backspace will do it.
 
Old 02-27-2004, 12:28 PM   #12
nmrn1
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
I had this exact problem installing Red Hat 9 on a Dell Inspiron 3500 with a NeoMagic AVI+ card. I edited the XF86config as suggested to add the 1024x768 mode, but it still would set itself to 800x600.

I'm not sure why this fixed the problem, but as soon as I connected a monitor and had the display tool auto probe the monitor, it would then accept 1024x768 setting.

I did do a ctrl crt/lcd force on the keyboard to force the video just to the monitor. When I swtiched back to the LCD screen it worked as well in 1024x768. After disconnecting the monitor and restarting the xserver, it continued to work fine on the LCD.

I think this probably has something to do with the fact that the NeoMagic driver has settings to enable simultaneous internal and external displays.
Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
IBM A31 Thinkpad and RedHat 9 Video rnutter Linux - Hardware 1 11-13-2004 02:12 PM
Problems sending video out to a projection screen in redhat 9 jambeck Red Hat 2 01-31-2004 01:46 PM
Redhat 9 video problems installing Wolfsbane Linux - Newbie 6 08-27-2003 05:48 AM
installing RedHat 8 problems with ati video and LCD raresp Linux - Newbie 3 03-05-2003 03:37 PM
RedHat 6.1 video problems d_ttrain Linux - Software 7 12-27-2000 01:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 01:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration