-   Linux - Laptop and Netbook (
-   -   Redefinition error when building 2.6.9 kernel with acpi (

asmund1 12-02-2004 08:00 PM

Redefinition error when building 2.6.9 kernel with acpi

This might be some error that I have caused myself since this is the first time I've installed a new kernel, or it might already been fixed, but I thought I'd ask anyways.

I am upgrading from kernel 2.4.6 to 2.6.9 on my laptop running slackware 10. After running 'make menuconfig' and setting stuff up the way I thought it should be, I run 'make' and after a while get and error saying:

drivers/acpi/events/evxfevnt.c:272: error: redefinition of `acpi_set_gpe_type'

after some searching the web and getting no good results, I decide to check the file and find that (what I believe to be functions (as I'm not very used to C)) have been defined (as the error states) two times. This is the case with one function (acpi_set_gpe_type) in the file evxfevnt.c and three functions (acpi_ev_set_gpe_type, acpi_ev_update_gpe_enable_masks, acpi_ev_enable_gpe) in evgpe.c in the same directory.

I figured I could just remove these multiple instances so I did and the 'make' seemed to work. However a bit further down I get an error saying:

drivers/built-in.o(.text+0x1e75b): In function `acpi_enable_wakeup_device':
: undefined reference to `acpi_enable_gpe'

This doesn't seem to be the same function (there is an 'ev' in the functions I removed) should I try to add this 'ev'? Anyone got any good ideas what I should do to make this work? (btw, Id like to have acpi support so removing it would be annoying :P )

Thanks :)

zaicheke 12-02-2004 10:10 PM

have you tried apm. It generally words better on laptops.

asmund1 12-05-2004 02:18 PM

ahh .rej
Fixed it.

Seems I had some .rej files or something.
Just deleted the source I was building kernel 2.6.9 from, extracted it anew and did a 'make' again, works perfectly now. :)


All times are GMT -5. The time now is 04:03 AM.