-   Linux - Laptop and Netbook (
-   -   Ram problem with several distros (Toshiba A350-22E) (

prexX 12-11-2009 05:45 AM

Ram problem with several distros (Toshiba A350-22E)
Hi !
This is my first time posting here, I hope i'm not posting in the wrong section. :P

This is what happened:

I recently bought a new laptop.
Specs here

It came with windows vista, which I quickly removed and installed Windows 7 (I never used Vista and I kinda refuse to).
Windows 7 installed perfectly and it works without any problems at all, I was quite happy with the laptop until...

I decided to install linux so I could have dual boot like I had on my previous laptop.

I tried 3 different distros: Ubuntu 9.10, openSuse 11.2 and Slackware13 .
The 3 times, I couldnt reach any kind of X-Window (kde or gnome).
Everytime I typed "startx", it would just give me an error.
Graphics driver I thought, but then I thought it was really strange that neither of the distros or any available graphic drivers would work...

I found this:

Tried removing ram and it worked... I instantly got into KDE without even passing trough the terminal.
I didn't wanna remove 2gb from my computer so I searched for the BIOS option related to the "memory hole thingy" (sorry but I'm not an expert so I won't try to use terms i'm not familiar with) but the thing is, my bios doesn't have one single option related to any kind of memory....

I even tried adding a 1gb ram slot so I could have 3gb instead of 4gb but It gave me an error again...

The error usually says "Caught signal 11. Server aborting" (or something close to that) but from reading I could understand that specific error can mean a lot of thing.

Well I could use some help on solving this out cause I really don't wanna stay with just 2gb of ram on my laptop since it's the only computer I own.

Btw, I have slackware13 installed at the moment and, in case I find a solution, that's the distro im sticking with.

catkin 12-25-2009 01:22 AM

If the 1 GB RAM was "known good" the symptoms suggest a defective motherboard (memory socket, memory controller ...). Either way running a memory test utility such as Memtest86+ might identify the problem. Memtest86+ may be on one of your distro installation DVDs. ubuntu 8.04 came with it and installed it as a boot option.

All times are GMT -5. The time now is 01:42 PM.