LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Problems with ndiswrapper (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/problems-with-ndiswrapper-356276/)

hr_phenom 08-23-2005 05:58 PM

Problems with ndiswrapper
 
Hey all,
I'm having problems setting up my wireless card on an hp zv6000. I've compiled ndiswrapper. On modprobe it loads up successfully. I did a ndiswrapper -m for it to lead on start however this doesn't work. The ndiswrapper module isn't loaded at startup. modprobe.conf shows the ndiswrapper alias but nothing happens.

Another problem; I have a wireless router to which I am trying to connect. On scanning I can locate my wireless link but cannot conenct to it. It has a 64 bit key. I'm trying to configure using iwconfig but it just cannot connect to it. HEres what I am doing

iwconfig wlan0 - essid 'phenom'
iwconfig wlan0 - key 'XXXXXXXXXX'

Is this correct?

Thanks in advance

kz26 08-23-2005 10:16 PM

What wireless card do you have? Do /sbin/lspci and find out.

Also try adding a line 'ndiswrapper' to the file modules.conf (you may have to create it.)

jeffk42 08-24-2005 09:54 AM

Re: Problems with ndiswrapper
 
Quote:

Originally posted by hr_phenom
Hey all,
I'm having problems setting up my wireless card on an hp zv6000. I've compiled ndiswrapper. On modprobe it loads up successfully. I did a ndiswrapper -m for it to lead on start however this doesn't work. The ndiswrapper module isn't loaded at startup. modprobe.conf shows the ndiswrapper alias but nothing happens.

Another problem; I have a wireless router to which I am trying to connect. On scanning I can locate my wireless link but cannot conenct to it. It has a 64 bit key. I'm trying to configure using iwconfig but it just cannot connect to it. HEres what I am doing

iwconfig wlan0 - essid 'phenom'
iwconfig wlan0 - key 'XXXXXXXXXX'

Is this correct?

Thanks in advance

zv6000... so it's probably a broadcom card. Does 'ndiswrapper -l' show your driver working, hardware present, etc. ? It should be, if you can scan, but just to be sure. :)

Have you tried opening up your router by disabling encryption and then trying to connect? That's a good way to narrow down where the problem is. If you cannot connect when the WAP is wide open, recheck to make sure you're not trying to get an IP via DHCP if DHCP is disabled on the router. If you CAN connect with the router wide open, then your encryption settings may be messed up somehow. You're entering the hex key, not the passphrase string, correct?

No offense intended if this is obvious to you... just trying to cover some bases. :)

Also... if there's still a problem, what is the output of
Code:

dmesg | grep ndiswrapper

hr_phenom 08-24-2005 05:51 PM

Re: Re: Problems with ndiswrapper
 
Quote:

Originally posted by jeffk42
zv6000... so it's probably a broadcom card. Does 'ndiswrapper -l' show your driver working, hardware present, etc. ? It should be, if you can scan, but just to be sure. :)

Have you tried opening up your router by disabling encryption and then trying to connect? That's a good way to narrow down where the problem is. If you cannot connect when the WAP is wide open, recheck to make sure you're not trying to get an IP via DHCP if DHCP is disabled on the router. If you CAN connect with the router wide open, then your encryption settings may be messed up somehow. You're entering the hex key, not the passphrase string, correct?

No offense intended if this is obvious to you... just trying to cover some bases. :)

Also... if there's still a problem, what is the output of
Code:

dmesg | grep ndiswrapper

Heres the output of dmesg

ndiswrapper version 1.2 loaded (preempt=no,smp=no)
ndiswrapper: driver netbc564 (,10/01/2002,3.70.17.5) loaded
ndiswrapper: using irq 169
wlan0: ndiswrapper ethernet device 00:90:4b:a9:c5:19 using driver netbc564, configuration file 14E4:4320:103C:12F8.5.conf


The router is set on DHCP. It works with windows and even the ethernet connection on DHCP.


All times are GMT -5. The time now is 08:48 PM.