-   Linux - Laptop and Netbook (
-   -   problems booting with udev (

[gentoo-user] 12-13-2008 06:40 AM

problems booting with udev
Hi I have a Lenovo laptop which has been running gentoo quite happily for a couple of months with a kernel compiled with genkernel.

I took the leap and manually compiled a kernel to taylor it to my m/c and since i have not been able to boot with udev, I have confirmed it is udev stopping my system booting by using [code]gentoo=noudev[\code]; in which case the system boots.

I have traced the problem to the init script and the command


mount -n -t tmpfs -o exec,nousuid,mode=0755,size=10M udev /dev
from the file /lib/rcscript/addons/ but due to lack of experience I don't know what the problem with the command is :$

the way I understand it is:
'-n' means use /proc/devices instead of /etc/mtab for device info?
'-t tmpfs' means mount as a tmpfs (tempory filesystem?) type
'-o ...' declares the options to be used
'udev' is the name of the device
'/dev' is the location the device is to be mounted

I have noticed that genkernel used /dev/hda for my disk and the new kernel uses /dev/sda - I have made the changes to the following lines to account for this:
new fstab contains the following:


/dev/sda1    /boot        ext2    noauto,noatime        1    2
/dev/sda3    /            ext3    noatime                0    1
/dev/sda2    none          swap    sw                    0    0
/dev/cdrom  /mnt/cdrom    auto    noauto,users          0    0
shm          /dev/shm      tmpfs  nodev,nosuid,noexec    0    0

When boot using 'gentoo=noudev' i get the same error when 'Mounting local filesystems', this time however it is not critical and boot continues to the command prompt.

Any help on resolving this or clarifying my understanding of the mount process would be greatly appreciated :)

Tuttle 12-13-2008 07:51 AM

compile tmpfs into your kernel instead of as a module?

[gentoo-user] 12-13-2008 07:56 AM

Could you clarify? Are you suggesting creating an initramfs?

Tuttle 12-13-2008 08:06 AM

hmm... maybe I should have stepped back here, I usually get mount errors if my kernel uses modules for filesystem support... is it possible the same thing is happening here? Recompile with tmpfs built in then recreate your initrd?

mkinitrd -c -k 2.6.### -m xfs

the xfs bit makes xfs part of the ramdisk, maybe adding tmpfs will fix it?

mkinitrd -c -k 2.6.### -m xfs -m tmpfs

Excuse me if I talk poo, it's late :)

[gentoo-user] 12-16-2008 05:34 AM

Ok, have solved the problem by creating an initramfs using the excellent guide at:
watch out for those nasty pop-ups though :(

Tuttle 12-16-2008 06:15 AM

Glad you sorted it

All times are GMT -5. The time now is 07:50 AM.