-   Linux - Laptop and Netbook (
-   -   Problem with Yamaha OPL-3 SAx(Sa3) on Asus L7300 (

scahrossar 12-24-2003 05:42 AM

Problem with Yamaha OPL-3 SAx(Sa3) on Asus L7300
I have an Asus Notebook L7300, and recently I installed Slackware 9.1.
At the first it, the drivers for my isapnp card didn't load during kernel bootup. Well, allright, I compiled a new kernel with support for following sound modules:
My sound card is Yamaha OPl-3 SAx(SA3)

Kernel 2.4-22
<*> Sound Card support
<*>OSS sound modules
<*>Verbose initialisation
<*> Microsoft Sound System Support
<*>MPU-401 Support(NOT for SB16)
<*> 100% Sound Blaster compatibles(SB 16/32/64, ESS, Jazz16) support
<*> Yamaha FM synthesizer(YM3812/OPL-3) support
<*> Yamaha OPL3-SA2 and SA3 based PNP cards

...and after
pnpdump -> save as /etc/isapnp.conf
pico /etc/isapnp.conf
Set io, dma settings etc.
isapnp /etc/isapnp.conf

...the soundcards loads into the kernel.
opl3sa: dma, irq and io must be set,
opl3sa2: mss_io, io, dma, dma2 must be set.
...and at the end of kernel bootup:
Board 1 has identity 0f ff ff ff ff ff 00 08 a8 65: YMH0800 Serial No -1(checksum 0f)
YMH0800/ -1(1)<YAMAHA OPL3-SAx Audio System>: Port 0x201; --- Enabled OK

But it can't load into the alsa drivers, I've tried out many sorts of solutions now, but I haven't found the correct one.

If I try to run alsamixer or esd I got this faulty message
audio_alsa: no cards found!
alsamixer: function snd_ctr_open failed for default: No such device.

I really cherish help here, I've tried to figure it out, but I'm stuck here.
so I'll yell out:
"Help appreciated!!!"

Caeda 12-31-2003 04:43 PM

And might I assume you didnt bother to compile or even patch the kernel for Acpi?

If your laptop has acpi it is right in the specs for it...

All times are GMT -5. The time now is 11:37 PM.