-   Linux - Laptop and Netbook (
-   -   Problem with wireless atheros in Slackware 12.2 (

cstrieder 01-21-2009 07:28 PM

Problem with wireless atheros in Slackware 12.2

I am with problems with the wirelss in Slackware 12.2.

That was what happened:

I have yet did two installs of slackware 12.2.

In the first install all things are working, inclusive the wireless. But, some day, wireless stop to work. 'iwconfig' shows I am connected but 'dhclient wlan0' do not give me an IP.

I think it was a bug in the 'ath5k' module. So I unload 'ath5k' with 'rmmod ath5k' and give a try with madwifi driver. I can compile and install it but when I do 'modprobe ath_pci', 'dmesg' shows me that some thing is wrong, the output of 'dmesg' says "...HAL status 13..." and the driver is not loaded, and no 'ath0' device is created.

So, I give up with madwifi and give a try with ndiswrapper. I have used this configuration yet in slack 12.0 and it works nice. But with slack 12.2 some thing strange is happening and after 'modprobe ndiswrapper', dmesg show some bad things. The driver is not loaded again.

In this moment I did a fresh new install of slack 12.2.

All things work again.

But, about two weeks after, the same problem with the wireless. I unload the module(rmmod ath5k) and load it again(modprobe ath5k), dmesg shows that all is ok. But 'dhclient wlan0' do not give an IP.

Anyone have some thing to say to me?

I am in an acer aspire 5050. Atheros wireless. I had used slack 12.0 and 12.1 in this notebook.

hirts123 01-21-2009 09:38 PM

What chipset does your atheros wireless card have?

markush 01-22-2009 08:08 AM


what about running "dhcpcd" as root? (dhcpcd gets a new ip-configuration from the DHCP-server)
What I mean is, when your system worked for about 2 weeks then you should look at something that can have changed in this time. And it may be that the dhcp-lease has expired and has not been renewed.


farslayer 01-22-2009 10:47 AM

Have you tried the OpenHAL driver from madwifi


ACER 5050-4697 (AMD64 based) laptop with an AR5007EG device

cstrieder 01-22-2009 06:09 PM

Hi hirts123,

#lspci says:

02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)


cstrieder 01-22-2009 06:23 PM

Hi markush,

I run #dhclient.

But are you saying to run #dhcpd, I have not did some thing like this you are saying.

In any way, I did re-boot many times, and this means that #dhcpd, happened.

This things you are saying about dhcp-lease-time make sense to me. I will consider this next time, if have the same problem.


cstrieder 01-22-2009 06:36 PM

Hi farslayer,

That's the point! That is the solution,

I did make and make install of the version of the madwifi hal.

I put ath5k in blacklist.

It is needed to reboot before load the new madwifi module, 'modprobe ath_pci'.


farslayer 01-22-2009 11:26 PM

Hmm I know NYLEX had difficulties with his as well at first in Slackware. not sure exactly what his final resolution was though, but he is using that same driver.

Did you load both the ath_pci and ath_hal modules ?

Take a look at this thread, there maybe something there that will help turn the light on..

In post 15 I have all the queries against my hardware what modules are loaded, etc.. so maybe that will help you spot something that is missing in your modules or setup..

If you find it, please let us know what it was..

cstrieder 01-22-2009 11:59 PM

Hi farslayer,

I do not know if I let it clear, but any way, it is important to say:

I find the solution, as I write in the previous post. Now I am using Slackware 12.2, with internet through wireless. The module I am using is the madwifi-hal.

I only do 'modprobe ath_pci', I think ath_hal is called from ath_pci, any way, it is loaded as lsmod output's shows below:

$ lsmod|grep ath_*

ath_rate_sample 17152 1
ath_pci 243000 0
wlan 218352 5 wlan_wep,wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal 305376 3 ath_rate_sample,ath_pci


farslayer 01-23-2009 10:49 AM

Ahh Ok I missed the part where you said it's working now...

Glad we could help :)

All times are GMT -5. The time now is 07:17 PM.