-   Linux - Laptop and Netbook (
-   -   Problem with Toshiba Satellite C655D-S5138 wireless on multiple distros (

Beauxroux 06-02-2011 10:29 AM

Problem with Toshiba Satellite C655D-S5138 wireless on multiple distros
Alright so I've been battling with this laptop for 3 days now. It has a "Realtek Semiconductor Co., Ltd. Device 8176 ( rev 01 )" wireless card. I've tried Ubuntu, Fedora, Linux Mint, and openSUSE with the same issue on all of them. Wireless networks show up under the network manager on all of these distros, but when trying to connect to one of the networks the computer freezes. (Requires hard reset) Modprobe reveils that the rtl8192ce module is being used by the card. I tried deleting this module and replacing it with the possibly updated one from Realtek's website but it seems to do the same thing. Any help would be highly appreciated!

I tried using ndiswrapper and the corresponding windows rtl8192ce driver...As soon as i modprobed ndiswrapper the system froze.

camorri 06-03-2011 10:26 AM

Have a look through this thread -->

Post number 5 gives specific instructions on how to get this driver to work with Ubuntu, I would guess that would work with Mint as well since its a Ubuntu clone.

You have to have dkms installed. Note the version of the driver has to match the kernel you are running; according to the Realtek download site.

Right now I do not know what distro you have installed.

Beauxroux 07-20-2011 09:30 PM

Sorry for the late reply. This doesn't seem to work, as the card is supported by Ubuntu out of the box. Supported, but doesn't work.

Beauxroux 07-28-2011 09:13 PM


camorri 07-29-2011 06:10 AM


card is supported by Ubuntu out of the box. Supported, but doesn't work.
Does the driver install? If you run the command 'lsmod' does the driver show loaded?

Exactly what do you mean by 'doesn't work'? Have you configured it after loading? or won't load?

Beauxroux 08-31-2011 12:47 AM

It's loaded. It displays the wireless network in the network manager, but when I connect to one my computer completely freezes and requires a hard-restart.

camorri 08-31-2011 07:15 AM

Are you saying you have configured this for an ad-hoc connection?

I connect to one my computer
or are you going through a router?

Did you run these instructions as indicated in the post listed above?


sudo add-apt-repository ppa:lexical/hwe-wireless
sudo apt-get update
sudo apt-get install rtl8192ce-dkms

Beauxroux 09-17-2011 11:34 PM

I can't do that, because the proper drivers are already installed and running. The card is activated and it lists the available wireless networks, however, connecting to them causes the system to cash.

camorri 09-18-2011 07:35 AM


I can't do that,
I have no idea what you mean by "that". You need to be specific, if you want help. I can't do 'some specific action' would help.


connecting to them causes the system to cash.
Do you mean it boot? Does it lock up so can not input from the keyboard? These two conditions are quote different. The word 'crash' tells me little about the system condition. Remember we can not see your system. It is rare to see a linux system boot because of a device causing problems. Lock ups are far more common, and easier to fix. So, which is it???

Beauxroux 09-20-2011 01:44 PM

The driver that I was told to install is already installed. It appears to work but the second I connect to an AP, my laptop freezes. Completely frozen. I can't move the mouse, use the keyboard, switch to terminal, anything. I'm forced to hold the power button down until it turns off.

camorri 09-20-2011 04:43 PM

What is your currently installed distro?

I see from re-reading the thread you have tried a driver from Realtek. Was it source code you compiled?

Beauxroux 09-21-2011 11:37 AM

I've tried fedora, opensuse, ubuntu, and linux mint. They all appear to "support" the card out of the box. Like I said, the network manager shows the wireless networks around me, but when i click on one, hard freeze. I also tried using ndiswrapper with the matching windows driver that i use on windows 7. As soon as i did a "modprobe ndiswrapper" the computer did the same thing i described earlier. Freezes and requires the power button to be held down. I've also tried using older verions of ubuntu which did the same thing.

EDIT: No i didn't compile source code, I used the ppa that was suggested. And i may add that i've tried both 32 and 64 bit linux distros. I have windows installed right now because I need my wifi to work at school. I have an ubuntu 64 bit live cd in the drive atm

camorri 09-21-2011 11:56 AM

The only way the Realtek code will work is if you compile it. Its source code. Modules have to be compiled against the headers for any particular kernel.

Some of the distors you have tried use DKMS, it can compile source code on the fly. Distos like Ubuntu use it. The reason is the kernels are changed on a regular basis, DKMS will re-compile the source on a per user basis. This way Ubuntu does not have to compile thousands of drivers for all the machine out there.

I asked this earlier

What is your currently installed distro?
If you want help, please answer. We need to know what distro you are working with now, not the long list of failures.

The only way you are going to get this working is to settle on one distro, make sure the correct components are installed, get the source code, compile it ( possibly done by DKMS ) and load the module.

There are instructions out there on how to get this adapter to run in Ubuntu. Several other users have done it.

asdfzx 09-21-2011 02:52 PM

Lol wow I have the same problem (well almost) and it's frustrating me, I'll post details later.

camorri 09-21-2011 03:41 PM

The Ubuntu instructions to make this driver work.


Went to the above thread, which had a link to the Realtek driver website, grabbed the LINUX Realtek RTL8192CE-VA4 driver (previously I had tried to use the Windows 8188 driver from the Dell support website and ndiswrapper to no avail).

After I downloaded the driver I did the following:

1. Make sure you have kernel headers installed (just check in Synaptic "linux-headers-generic") This should be the default in Ubuntu but you never know...
2. Downloaded the Realtek driver to a thumbdrive, opened with archive manager, right click/move to/home folder.
3. Do not unpack the driver archive to the desktop as this causes problems with compiling the driver
4. Open Terminal
5. type command: cd rtl8192se_linux_2.6.0015.0127.2010 (or cd "whatever you have named the new driver folder")
6. type command: sudo su (log in to become "Super user")
7. type command: make (wait for terminal to unpack the file)
8. type command: make install (wait for installation)

9. restart computer
10. using command: lshw -C Network, check to make sure new driver is installed (it should indicate *Network, and the driver can be seen in the Configuration line)
11. Make sure wireless is on (usually F2)
12. Left click the wireless icon to see available networks, and set up your wireless (i had to type in the "key" one time but the rest was already there....
This is the link to RealTek.

All times are GMT -5. The time now is 07:24 PM.