-   Linux - Laptop and Netbook (
-   -   PCMCIA sharp notebook redhat 9 (

yihwen 09-21-2003 08:28 PM

PCMCIA sharp notebook redhat 9
I have got a sharp notebook which uses an external floppy and external cd-rom.
I want to install Redhat 9 and have created a boot disk using the rawrite. I am unable to configure the notebook to boot from the cd-rom.
I have boot up the laptop with the floppy disk and it has a prompt

What do I do next? The installation CD is in the CD-ROM but I dunno how to enable the CD-ROM. I have also create a disk from the pcmciadd.img but I do not know how to use the disk.
Any ideas?

msh8r 09-21-2003 09:44 PM

you might have to go into the BIOS settings of your notebook to change the boot order. Consult your documentation on how to get into the BIOS.
On some machines you press "delete" when the machine comes up, some use F10 (e.g. Compaq).
I assume that the external CD rom connects through the USB port, so that would have to be the first boot option. Sharp should have some information on how to boot your machine from a CD, this is also required if you want to reinstall the original software that came with your machine (e.g. Windows)

yihwen 09-22-2003 06:26 AM

Went to BIOS
I already did the following, but it still unable to boot it. So I am trying to activate the CD-ROM just like using the MSCDEX in windows.
Does linux have something like this after I boot using the boot disk?

msh8r 09-22-2003 07:57 AM

You haven't confirmed whether or not your CD-ROM is connected via USB (or what other port it uses).

The boot floppy gives you some choices of installation media to pick from, e.g. NFS server, hard drive, and - if I recall it correctly - CD-ROM.
The trick might be though to get the CD-ROM to work if it's on USB.

Q: Any modern laptop that I've seen lately came with a quick-restore CD. In order to restore your machine to factory condition you'd likely have to boot from that CD. What does you manual say about how this works?
The same method should allow you to boot from any other (bootable) CD, including Linux.

yihwen 09-22-2003 09:15 AM

it is connected via PCMCIA and it is an old laptop running on P2. I had problems setting up Win2k cos it is not bootable CD-ROM so I have to stick to the old floppy method to get the system up. I am familar with Win2k but totally clueless on Redhat

msh8r 09-22-2003 11:08 AM

yihwen, you should still be able to install from a CD, although a few extra steps are necessary:

use rawrite to create these 3 floppies:


Then you boot from the bootdisk. Select "local cdrom" for the installation method. On the next screen select "use a driver disk" then feed it those two other disks. You may have to try them in different order, but it should work.

Let me know how it goes.

yihwen 09-22-2003 11:14 AM

how to select local cdrom?
cos when I boot up using the bootdisk.img floppy, it prompts me for a

what shld I type?
there is not local cdrom for me to select

msh8r 09-22-2003 11:23 AM

just hit enter, it will then load the kernel from the boot floppy
(vmlinuz) then initrd, and start the kernel
next you select your language and keyboard
then you get to pick the installation method

yihwen 09-22-2003 12:40 PM

got around the problem but found that it was my boot disk problem
anyway i have loaded the driver disk but i do not know which is my driver disk for my PCMCIA CD-ROM
Mine model is Addonics Technologies Pocket CD-II
Where to get the drivers?

msh8r 09-22-2003 02:24 PM

I'm not familiar with that particular CD drive - have you tried all drivers that are on both driver disk(s) ?
What does Addonics' support say? (The claim on their website that their CD-II drive is supported on Linux (
(Although the drives on their website are all USB drives.)

Of course - if you can't get the CD to work - you have always other options of installing Linux, like the Hard Drive, NFS, FTP, HTTP - for the later two you need only the boot disk and the network card driver (and of course a network connection to an install server - e.g. one of the many mirrors on the Internet.

yihwen 09-22-2003 06:35 PM

the network connection is plug thru a USB enabled ethernet card amd the harddisk only has 3gb which is just enuf for Redhat 9

yihwen 09-22-2003 06:46 PM
I have seen the above website but I dunno in which part of the installation process do I need to perform the above mentioned steps

msh8r 09-23-2003 11:35 AM

that documentation on the addonics link is old - referring to RedHat 5.2 - RH9 should detect it without much fuss.

yihwen 09-23-2003 12:07 PM

apparently it didnt

msh8r 09-23-2003 12:50 PM

last resort:
take the HD out of the laptop, get a laptopHD-to-IDE adapter, hook the HD up to a desktop computer, install RH on it, run all updates from RedHatNetwork, then put the HD back into the laptop, boot it up, let the hardware detection take place - finished.
A little drastic, but - if none of the driver of the inital setup worked

All times are GMT -5. The time now is 02:02 AM.