-   Linux - Laptop and Netbook (
-   -   Panasonic Toughbook CF-29 Touch Screen (

Richard Craneum 09-19-2006 02:15 PM

Panasonic Toughbook CF-29 Touch Screen
Anybody tried to get the Touch Screen to work with Mandriva? Or knows what to do? Right now all works from the 1st install. Including wireless, monitor, sound, mouse (USB & Touch Pad) The distro is great! Just the Touch Screen does nothing. Is enable on the BIOS and works on MS (Duh! It was configured to work on MS anyway) I know it has to be something dumb that I am missing.


Nobles 09-22-2006 10:35 AM

Touch Screens
Have a look in this forum for the other dicussion that is going on regarding touchscreens on CF-29s - just do a seach for touchscreen. To summarize what has been discovered is that the CF-29 has an uncommon multiplexed PS2 type of connection that the touchscreen/touchpad uses and the latest 2.6 kernel has made it hard to get these things to work. There is no simple solution - you have to be a bit of a Linux expert as well as a programmer and know how to write a patch for the CF-29 hardware and then patch your kernel and configure X Windows to get it working - I would imagine you have to keep patching your kernel if you upgrade it as well to keep the touchscreen working. It can be done though - Emperor Linux is one distribution that has it working but they will only pre-install it on a CF-29 for you which is quite costly. There is also another company that has a CF-29 touchscreen driver for sale for $149.00.

Richard Craneum 09-25-2006 08:20 AM

Thanks for the reply :)

stan.distortion 10-03-2006 05:12 AM

bit of topic but tried searching the fourums for cf-27 and got no results. seen touchscreen probs on cf-27 and 29 here before. just got a 27 and needed to get the touchscreen to work. some info:
the ide can be be changed in the bios. it either shows up as ttyS1 or ttyS3
$ cat /dev/ttyS1 will give something like this:
when you touch the screen. a garbled message is the wrong settings on the port. 'setserial /dev/ttyS1 autoconfig' set that up ok for me.
have a small perl script (my first, and it worked :) which needs the guitest module installed (plenty of easy to understand docs on perl for that). will try and post it in another reply.
again my appologies for going off topic but if you can get any similar output from wherever the ps2 port appears in /dev on the 29 then a similar script should get things working.

fc3, 2.6.13, xorg.


stan.distortion 10-03-2006 05:25 AM

cf-27 touchscreen script
#!/usr/bin/perl -w

use X11::GUITest ("SetEventSendDelay","MoveMouseAbs","GetMousePos","PressMouseButton","ClickMouseButton","ReleaseMous eButton","IsMouseButtonPressed",":CONST");

open (TTY, "/dev/ttyS3");
$a = 0;
while () {
$val = <TTY>;
# print "$val";
$p = substr($val, 0, 1);
if ($p eq "T") {
# PressMouseButton(M_LEFT);
$a = $a + 1;
# get position values from tty output
$x = substr($val, 2, 3);
$y = substr($val, 7, 3);
# translate touchscreen output to X coordinates
$xs = ((($x-12)/980)*800);
$ys = (((930-($y-45))/930)*600);
MoveMouseAbs( $xs, $ys );
if ($p eq "R") {
# ReleaseMouseButton(M_LEFT);
# print "$a\n";
if ($a <= 5) {
elsif ($a <= 15) {
elsif ($a <= 40) {


again, needs guitest module to work.
draging windows or bars is too slow so the press and release is comented out. if someone could tell me how to speed that up it would be a big help. dont forget to delete this text and make it executable :)

stan.distortion 10-03-2006 02:17 PM

Had trouble with the cf-27 touchscreen, put a post with a pearl script here that got around the problem.
few questions about the cf-29:
is this all on a 2.6 kernel using udev or is it the same with a 2.4 kernel?
does a /dev/mouse0 or /dev/input/mouse0 show up and does it connect to a plugged in mouse?
have you tried 'cat' instead of 'od'?.
on the cf-27 'od' didnt output anything but 'cat' gave a list of states and coordinates when the screen was touched.
good luck with it.

Azizcoos 10-03-2006 07:31 PM

If the CF-27 touchscreen is appearing on a serial port, it is a completely different beast than the touchscreens in the CF-29 and CF-18. These are similar to the Fujitsu Lifebook touchscreens, but they are just different enough that the driver which is included in kernels >=2.6.17 doesn't work. What appears to be the problem at this point is that the initialization requirements are unknown. I sent an email to Toughbook tech support last week asking for information. I have not received any response yet. To the best of my knowledge, no one has been able to locate any output from the touchscreen on a CF-29. This is consistent with it being in an uninitialized state.

stan.distortion 10-04-2006 04:12 AM

my mistake, i should have checked the almost-a-link above for the lifebook. a lot of that page is over my head but it seems to suggest that a solution with a 2.6 kernel is possible and that a node with raw data should be in /dev using a 2.4 kernel. this piece of hardware sounds life a pain in the neck :). without having a cf-29 to poke at its certainley over my head, appologies for clutering up the thread.
best of luck with it.

stan.distortion 02-06-2007 09:23 AM

There was a similar question asked about the touchscreen on the cf-28 in this forum:
Needs subscription. No answer was found for it.
Google found a few things of interest:
For the summit link, ok it is against the grain but they seem to be offering free demo's. Their home page is at if anyone is interested.
I think someone has already mentioned the inclusion of the module in the kernel, the link for kernel-traffic suggests it has already been looked into.


PS, having a small problem with a touchscreen, every time I use the desktop pc I cant stop tapping the monitor. Anyone know a solution? :)

Azizcoos 02-06-2007 07:04 PM

Proprietary Drivers
Take a look at the end of this thread. There are at least two companies offering drivers for sale for these devices. This leads me to suspect that what is going on here is an extortion racket.

You may have the hardware, but unless you pay one of these business-model-challenged scammers, in the case of Xi it's about $150 USD, you don't get the "proprietary configuration code sequence", aka Magic Number, to make it work. Since I never received any response from Panasonic to my inquiry, I can only assume that they are in on the extortion scam, which would make Xi and Trident Magic Number resellers.

Panasonic has now superceded the CF-18 and the CF-29 with the CF-19 and CF-30 respectively. The only bright spot I can see is that this might make them more inclined to let slip the Magic Numbers for the out-of-production models.

For now, the only hope I can think of is if someone could figure out how to catch the Magic Number from an original Windows installation on one of these units.

Denying us the use of hardware that we have legally acquired is unethical at best. It's as if when you bought a used car, you had to pay the manufacturer a fat fee just to get the key to work for you. The Windows world is accustomed to bending over for such obvious scams, so I guess now the manufacturers take it for granted that they can get away with just about any form of extortion that they can dream up.

It would be a lot of fun to shine some light on this. If anyone has any ideas on how that might be accomplished, please don't hesitate to share them!

stan.distortion 02-07-2007 02:24 AM

Has anyone tried the windows drivers with wine? It has probably a snowballs chance in hell of actually making something work, but it should but it should be possible to monitor the communications at device level, 'cat /dev/input/mouse0' for instance.


Nobles 02-07-2007 09:39 PM

It is a bit of a conspiracy isn't it. I had a CF-30 in for demo and it uses the same touchscreen drivers in Windows XP as the CF-29 (at least CF-29 Windows XP Ghost image booted up and let the touchscreen work so I assume the magic code that lets the touchpad/touchscreen work should be the same for this model as for the older models). Our only hope is that if enough Toughbook models use same the sequence and using Linux on them becomes a more popular choice that somebody will figure it out for free or perhaps Panasonic will start supporting Linux on them.

stan.distortion 02-08-2007 06:02 AM

Usefull info. So it looks like the cf 28, 29 and 30 can all use the same driver. It also looks like the cf-18 is on that list too, can anyone shed some light on this?
As already mentioned, the cf-18 is in the kernel:
It seems it works but needs to be set up:
So the sequence to initialize the touchscreen should be the same as the original Fujitsu driver that the new kernel driver is based on:
I'm getting a bit over my head with this bit so please correct me if I am wrong, it looks like the original sequence is actually a sequence of event codes which, I assume, tells the touchscreen hardware what is expected of it:
Anyone feel like adding their cf 28, 29 or (you ba****ds :) ) 30 to /drivers/input/mouse/lifebook.c , compiling, poking the screen with their pinky any posting back with what happens?


Azizcoos 02-08-2007 07:22 AM

So where does the init sequence (write_ack...) go?
It doesn't appear in lifebook.c, but it must be in the system somewhere already to get the Lifebook touchscreens to work. But if that init sequence is already in the driver since 2.6.17, then that proves that sequence doesn't work with the Toughbooks. I tried adding the CF-29 to lifebook.c last fall:

              .ident = "CF-29",
              .matches = {
                      DMI_MATCH(DMI_PRODUCT_NAME, "CF-29"),

It switched the touchpad to absolute position mode, (Horribly unusable, jumpy mouse pointer, not recommended) but the touchscreen gave no response or output that I could find. Incidentally, I have found no evidence that it works with the CF-18 either, and I believe it produces the same result as it does on the CF-29. See the kernel bug report mentioned above.

If we could get Hoyer's hands on a Toughbook, or perhaps even just a copy of the Windows driver, he obviously knows how to do what needs to be done.

Nobles 02-08-2007 11:09 AM

More Info on Touchscreen
The link below has some interesting tidbits to add - perhaps you are seeing no touchscreen activity for some of the reasons they quote in the "Known Issues (or bugs)" section of what is discussed. It might also be interesting to try this with an older kernel that may make it easier to actually monitor what is happening with the dev/psaux port using what was known to work in the past - if we could find something that would let us know if we can get any visible output out of a Toughbook touchscreen that would be a starting point.

--- Quote from site above ----
Ivan Popovski has found that the psaux module does not work correctly on devices capable of multiplexing the PS/2 mouse port. You have such a device if dmesg says

i8042.c: Detected active multiplexing controller, rev 1.1.

or something like that. Don't be disappointed. By disabling the multiplexing feature of the PS/2 port, my psaux module works again. How?

* If the psmouse is loaded as a module, use the "i8042_nomux=1" parameter when you load that module.
* Most people would have compiled-in the psmouse driver, because the i8042.c also drives the keyboard. In that case, use "i8042.nomux" as a boot parameter.
---------------------- end of quote -------------------------------------------

All times are GMT -5. The time now is 10:54 PM.