-   Linux - Laptop and Netbook (
-   -   Old Toshiba Satellite - Wireless Connection Trouble (

Diomedes 08-28-2012 07:24 AM

Old Toshiba Satellite - Wireless Connection Trouble
I wiped the hard drive on my Toshiba Satellite A105-S4014 and installed the latest Arch. The process went smoothly - I like to think I have some idea of what I'm doing. However, when I got to wireless networking...

Here's the thing. I remember years ago (probably when I first joined this site) these laptops had issues with the onboard wireless. Something about Atheros drivers not being supported natively, and I had to use a madwifi driver, I think. Well, apparently it's supported, now. I think. See, when I was running off the live disc during install I had no trouble getting the network up via:

# ip link set wlan0 up
# wpa_supplicant -B -Dwext -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
# dhcpcd wlan0

This worked fine for me during install. Obviously, I had to redirect my WPA passphrase:

# wpa_passphrase <SSID> "<phrase>" > /etc/wpa_supplicant/wpa_supplicant.conf
So when I had the install complete and I chrooted into the new /, I went to work setting up netcfg to autoconnect. That is, I configured a new network profile PTM, changed netcfg config, and added netcfg to the daemon array. When I rebooted not only did it not autoconnect, but my wlan0 interface was locked down - I could not bring it up, and if I tried to scan for networks it told me the interface was busy. So I took netcfg out of the daemon array and rebooted, and then the above manual method worked fine (ip link ..., wpa_supplicant ..., dhcpcd ...)
I started from scratch with configuring netcfg, and instead of putting it in the daemon array I tried calling it manually:

# netcfg <profile>

:: paleman up      BUSY
> WPA Authentication/Association Failed

I've checked over all of my WPA credentials and everything looks good. I've tried the WPA key as plaintext and hex. What's worse, now the manual method won't work either! The commands finish without errors or warnings, and I'll check iwconfig, which says it's associated wlan0 with the access point, but I can't connect at all. I can't really bring down WPA temporarily as there are several people on this access point, but I did try netcfg with a new profile connecting to my Android tether (no encryption, no access control, full root permissions):

:: android up      BUSY
> DHCP IP lease attempt failed.

I can't tell if this is related to the problem or something else entirely. But, a few thoughts:
- Do you think maybe the ath5k/ath9k driver is still necessary? I hadn't thought it was, since I could connect once in a while, and the system obviously recognises the hardware, and as far as I can tell no firmware is ever called that wasn't found.
- Why would I suddenly just not be able to connect the same way I did before? It doesn't make any sense. I've retraced my steps and can't find anything I did differently, or did that I hadn't undone, in the process. I haven't touched wpa_supplicant.conf since the first reboot, and I've verified that it still contains the appropriate info.
- Also noteworthy to me, probably since the last time I even used this laptop was when I was trying to manually install madwifi with no internet connection, is that my wireless interface is recognised as wlan0, whereas it was before ath0.

Has anyone else had this problem, or happen to know what's going on?

Diomedes 08-28-2012 09:20 AM

UPDATE: I thought perhaps network and netcfg were arguing, so I took network out of rc.conf. Results are exactly the same, but at least there were no extra problems.

Diomedes 08-29-2012 07:37 AM

UPDATE #2: I'm certain it's the onboard. I changed nothing and connected a USB wireless card and tried the manual method. It's working just fine. I'm happy with this solution, but I would still like very much to figure out what happened. I don't like my system being broken.

business_kid 09-02-2012 08:45 AM

Atheros, usually behave themselves eventually.
Mention your device exactly - the line from lsusb/lspci and the kernel module. Check this out

Grep the kernel config and see if you have all the settings you want. Let me illustrate. My broadcom (b43) device wouldn't work. I grepped for B43 in the config and found it in ssb - the Sonics Silicon Backplane! Some small driver code (CONFIG_SSB_B43_PCI_BRIDGE) to make it appear on the pci bus. CONFIG_SSB_B43_PCI_BRIDGE didn't show in 'make menuconfig', but was configured by other stuff.

All times are GMT -5. The time now is 06:03 PM.